Drop-down text does not work in CHM

Explorer ,
Jan 04, 2021

Copy link to clipboard

Copied

I upgraded a project to RH2020 and in the CHM, clicking the link to open drop-down text had mixed results. Some opened normally, some didn't open at all, and others opened the wrong text (the text for a different drop-down link). I recreated all of the drop-down text links in that topic and now none of them open at all.

  • Robohelp 2020.3.32.
  • The drop-down text works in Responsive HTML5 output in Firefox and IE 11.
  • I imported the troublesome topic to a fresh RH2020 project and have the same symptom. Another topic in the same project opens the drop-down text as expected.
  • Workaround: After comparing the HTML of the working and non-working dropdowns, I discovered removing the script tag containing CDATA fixed the problem.

I plan to fix my updated project with the workaround I discovered. Recording here for others and if anyone has other suggestions or insight.

I tried making a fresh project in RH11 and cannot duplicate the problem when I upgrade it to RH2020. I can assume I forgot how the topic was made or something else weird happened.

So the final answer is try workaround of removing the script tag containing CDATA to fix the problem.

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Drop-down text does not work in CHM

Explorer ,
Jan 04, 2021

Copy link to clipboard

Copied

I upgraded a project to RH2020 and in the CHM, clicking the link to open drop-down text had mixed results. Some opened normally, some didn't open at all, and others opened the wrong text (the text for a different drop-down link). I recreated all of the drop-down text links in that topic and now none of them open at all.

  • Robohelp 2020.3.32.
  • The drop-down text works in Responsive HTML5 output in Firefox and IE 11.
  • I imported the troublesome topic to a fresh RH2020 project and have the same symptom. Another topic in the same project opens the drop-down text as expected.
  • Workaround: After comparing the HTML of the working and non-working dropdowns, I discovered removing the script tag containing CDATA fixed the problem.

I plan to fix my updated project with the workaround I discovered. Recording here for others and if anyone has other suggestions or insight.

I tried making a fresh project in RH11 and cannot duplicate the problem when I upgrade it to RH2020. I can assume I forgot how the topic was made or something else weird happened.

So the final answer is try workaround of removing the script tag containing CDATA to fix the problem.

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 04, 2021 0
Adobe Community Professional ,
Jan 05, 2021

Copy link to clipboard

Copied

I have seen CDATA in topics created from Word imports. Could that be a factor here?

 

Thanks for posting the fix.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2021 0
Explorer ,
Jan 05, 2021

Copy link to clipboard

Copied

I do not believe this topic, and others exhibiting the problem, were imported from Word. Pretty sure, though not 100% positive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2021 0
Adobe Community Professional ,
Jan 05, 2021

Copy link to clipboard

Copied

The only other thought is were they using the RoboHelp dropdowns or a script, such as the ones on my site. That could make a difference on upgrade.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2021 0
Explorer ,
Jan 05, 2021

Copy link to clipboard

Copied

I tried making a fresh project in RH11 and cannot duplicate the problem when I upgrade it to RH2020. I can assume I forgot how the topic was made or something else weird happened.

So the final answer is try workaround of removing the script tag containing CDATA to fix the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2021 0