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Dynamic Filtering - Solution Found to Index not Filtering Properly

Enthusiast ,
May 21, 2019 May 21, 2019

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RH 2017 (13.02.334) with Windows 10

So for a few months now, I've had an issue with the index not filtering correctly in our merged HTML5 help system. Through much trial and error, and through no small amount of effort, I'm sure, on Peter Grainge's part (Thank YOU Peter!), we found what was causing the problem.

Problem:

When unfiltered, all entries would be there as expected. When filtered, some entries would be excluded as expected, but others that should have been excluded weren't.

Cause:

We discovered that bolded index entries--entries that aren't linked--will show up in the index with their sub-entries visible, even if the topics for those sub-entries are marked with a topic-level filter that you're excluding.

For example, on this test index, Index 1 does get excluded when I am excluding the f_help_qdasconfigurator filter. But Index entries 2 and 3 still show up, even through their topics are marked with the same f_help_qdasconfigurator topic-level filter.

There are two solutions:

Solution 1:

Ensure that each bolded entry is linked to a topic in the help.

Solution 2:

Ensure that each bolded entry has the topic-level filter you're using for your filtering, like this:

Thanks again Peter!

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Enthusiast ,
May 30, 2019 May 30, 2019

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Hi all (and Peter),

Perhaps I spoke too soon. I have some additional feedback on this.

I implemented solution 2 in our actual indexes (before, I was just using the above test indexes), and it does work... at least up to a point.

I found that once an index started to get large that the problem returned. In my tests between a couple of Helps, I pulled out index entries 1/2 at a time and when it got somewhat smaller, it started to work again. In one of my indexes, in the .hhk file, if it got above 500 lines or so, it broke down, and the original problem returned. If I remove entries, it worked again.

I'm not sure if there's some problem with my files, but I personally am inclined to think this is a RoboHelp bug, and that it just can't filter large indexes properly. I could be wrong. I'd need to prove it out with more testing to be sure.

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Community Expert ,
May 30, 2019 May 30, 2019

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Very pleased to hear that you are making some progress. I think the way forward is for you to continue testing until you are satisfied your results are repeatable. Then create two zips. One where it all works and one where it does not because of the index size. Complile some notes and then send it to me.

I will then liaise with Adobe.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

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Enthusiast ,
Jun 10, 2019 Jun 10, 2019

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Thank you Peter. I finally managed to make some time to do that. I just sent you the files from my OneDrive.

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