Error: Failed to initialize database (in AIR Help output from RH10)

New Here ,
Feb 20, 2013 Feb 20, 2013

Copy link to clipboard

Copied

Hi, I recently upgraded a RH8 project to RH10. The project is a multiple merged help system as described in

http://blogs.adobe.com/techcomm/2010/07/merging_multiple_helps_in_air_help_output.html

The merged AIR Help output from RH8 worked fine, but now when you search for any text in AIR Help from RH10, the message "Error: Failed to initialize database" appears.

All other aspects of the upgraded AIR Help project seem to be ok. Is this a known issue with RH10 Air Help?

Thanks in advance!

Views

2.1K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

To the best of my knowledge there were no changes in AIR help in Rh10 so I am thinking the problem lays elsewhere.

If I recall correctly, the method of merging installed air help described in that blog merely creates a dropdown that enables you to access the separate help projects. It is not true merging where the whole help works as one. That is described in http://www.grainge.org/pages/authoring/merging_webhelp/merging_method_rh9.htm#air

Again though I am not inclined to think that is the problem. "Error: Failed to initialize database" is a problem that has been seen before and a search of the forum should help. First step I would try is to delete the CPD of each project and regenerate.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

Hi There,

This error occurs because there are some xml files which are missing after genearting the help file. Also you can try the steps suggested by Peter.

Thanks

Priyank

Thanks,
Priyank Shrivastava

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

Thank you for your replies!

Here is what I have done today:

  • Deleted CPD in all projects
  • Generated both .rha and .air outputs for each separate help project
  • Checked whxdata folders of both outputs for each project - identical names and number of xml, js files etc. in these folders
  • Checked search feature in individual project AIR applications - all ok
  • Combined all .rha files into one AIR application - on searching, initialize database error occurs in all projects accessed via drop-down list

When the project .rha files were previously combined in RH8, search was ok, now in RH10 it is not.

I have no idea how to fix this, other than to issue each project as a standalone AIR application.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2013 Feb 22, 2013

Copy link to clipboard

Copied

@Peter - is this thread in the correct category?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2013 Feb 26, 2013

Copy link to clipboard

Copied

I have moved the thread to AIR Help as it does seem to be specific.

I cannot help with why this is happening, I think you will have to take that up with Adobe. The only thing I can suggest is the alternative merge method and I cannot guarantee that will fix it for you.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 13, 2013 Jul 13, 2013

Copy link to clipboard

Copied

Hi Peter

I'm not sure if this requires a new discussion / thread. I am receiving the same error (Error: Failed to initialize database) but I believe I am creating a slightly different output than GeoffDMA. I am using Robohelp 10's Help Viewer Wizard to create an empty Adobe AIR file that is used to access individual help systems generated using the Adobe AIR Help Content Only output type (*.rha) which are referenced through a helpcfg.cfg file.

Therefore, I believe this is different from the merged help system GeoffDMA is referencing and more appropriately may be considered a "combined help" system. I use this method since I work in a corporate environment and so that IT only has to perform a one-time installation of the initial AIR file generated through the Help Viewer Wizard and place the .cfg file. I can then continuously update/change the individual "Help Content Only" .rha files and the users can replace these without requiring administrator privileges)

Anyway, as for the search - it will in fact work correctly if the individual help systems are generated using the Robohelp "Adobe AIR application" output type and the utilized as standalone applications. It is only when I change the output type to "Help Content Only" and view the combined files through the Help Viewer Wizard AIR file I have created that I receive the "Error: Failed to initialize database" message

Is this an issue with the AIR files generated by the Help Viewer Wizard?

Any assistance would be greatly appreciated

Thanks!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2013 Jul 15, 2013

Copy link to clipboard

Copied

I don't know whether anyone besides you and Geoff have found this issue but I think you are the only two who have reported it.

Your scenario is different in that you only get this problem if you use the Help Viewer Wizard but that does mean that at least you have a workaround.

I am trying to find out possible causes of the error message and will post back if I find anything that will help.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2013 Jul 18, 2013

Copy link to clipboard

Copied

Hi Peter

Thanks so much for responding. It is surely a perplexing issue. I am hoping against hope that perhaps TCS 5.0 will remedy this if no solution can be found beforehand. If you are able to find the issue that would be terrific.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2013 Jul 19, 2013

Copy link to clipboard

Copied

I am liaising with Adobe on this for general information about the error message but it may be a while before I can come back to you.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation