Highlighted

Error upgrading from RH9 to RH11

Community Beginner ,
Sep 22, 2015

Copy link to clipboard

Copied

I have RH9 projects under version control (TFS) that I need to upgrade to RH11. All projects work without error in RH 9, however when attempting to upgrade I get the following mindboggling errors below:

  1. I open the RH9 project
  2. Say yes to to adding this

    1RHCpDocs.apj.jpg
  3. Then I get

    1Cannot checkout all the files.jpg
  4. Apparently RH11 needs files that were not present in RH9 (or necessary?)

What on earth do I do now??

Correct answer by LykkeErik | Community Beginner

Back again and this time with a flawless installation. My brand new top-of-the-line Lenovo tablet was stripped and reinstalled. The culprit seems to have been the OS installation (Windows 8.1). Though no smoking gun was found!

Now everything works as it should. RH11 is up an running and all upgraded RH9 Projects are running.

Thanks to everyone for their advice on the rocky road to a solution

Cheers,

Erik

 

Topics

HTML

Views

282

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error upgrading from RH9 to RH11

Community Beginner ,
Sep 22, 2015

Copy link to clipboard

Copied

I have RH9 projects under version control (TFS) that I need to upgrade to RH11. All projects work without error in RH 9, however when attempting to upgrade I get the following mindboggling errors below:

  1. I open the RH9 project
  2. Say yes to to adding this

    1RHCpDocs.apj.jpg
  3. Then I get

    1Cannot checkout all the files.jpg
  4. Apparently RH11 needs files that were not present in RH9 (or necessary?)

What on earth do I do now??

Correct answer by LykkeErik | Community Beginner

Back again and this time with a flawless installation. My brand new top-of-the-line Lenovo tablet was stripped and reinstalled. The culprit seems to have been the OS installation (Windows 8.1). Though no smoking gun was found!

Now everything works as it should. RH11 is up an running and all upgraded RH9 Projects are running.

Thanks to everyone for their advice on the rocky road to a solution

Cheers,

Erik

 

Topics

HTML

Views

283

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Sep 22, 2015

Copy link to clipboard

Copied

--continued:

After trying a couple of times I also get the warning "Parameter is not valid" - but nothing about which parameter??

HELP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 24, 2015

Copy link to clipboard

Copied

This upgrade has been far from smooth!

Lessons learned:

  1. Smaller RH9 Projects scratched through by checking out all files in TFS (several times) and adding new files (several times), continously ignoring the previously mentioned warnings.
  2. More complex Projects the approach above did not Work. In the end I had to delete cpu and xpj and use hhp to initiate the project (rebuild) before an upgrade was possible.

Issues after upgrading:

  1. hyperlinks in the Projects CSS were stripped
  2. Masterpages greyed out and no longer accessible

Wishing list:

On my wish list from the Robohelp team:

  1. is a detailed upgrade do's and don't's and especially more attention to projects under source control
  2. Words of wisdom not to follow is when Adobe support say you should disengage the project prior ro upgrading. If you do that your history in TFS goes down the drain

Good luck to the next poor soul attempting to upgrade

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 24, 2015

Copy link to clipboard

Copied

Hi Erik,

1. There isn't much to say about upgrading. Just open and RH do it's thing. Optionally, you can check out the project in Visual Studio, remove the CPD and then open the project.

2. Absolutely true. If you want to disconnect and retain your history: October 2004 - Banishing the sorcery

Do you still get the 'Parameter not valid' error? If not, did you find a way to solve it? That error message has been bugging me for quite a while now and I have not found a solution as of yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 24, 2015

Copy link to clipboard

Copied

Knock on wood - I haven't encountered it since. However "There isn't much to say about upgrading" is the understatement of the year! I certainly didn't find it easypeasy, sorry.

However on a completely different note, did you encounter:

"Issues after upgrading:

  1. hyperlinks in the Projects CSS were stripped
  2. Masterpages greyed out and no longer accessible"

And do you know of any quick fixes?

Prior to upgrading all CSS's in the projects had several entries for hyperlinks (see pix below) now in RH11 hyperlinks only have one entry and has moved out of the Characters-section to its own independent one. however all my projects now show links in different colors??

RH 11 hyperlinks.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 24, 2015

Copy link to clipboard

Copied

Hi there

Hopefully you made a backup copy of the CSS before upgrading. While it would seem that the upgrade process clobbered the CSS a bit, I'd be interested to see if you simply copied a backup copy with those entries in it, if they would survive the trip once inside the upgraded project.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 29, 2015

Copy link to clipboard

Copied

Re-introducing the RH9 CSS did nothing. And apparently the changes in the CCS happened´in RH10 (there is only one entry for Hyperlink and for this one you can set pseudo classes corresponding the old entries in RH9).

I think I have narrowed the problem with popups show red despite they ought to be blue down to a viewing problem, see enclosed

Hope someone can help (is this a windows viewer problem) or....

This affects RH11 as well ín the viewing mode (the glasses' function)RH 11 hyperlinks.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 29, 2015

Copy link to clipboard

Copied

While it's possible that browser settings are overriding the styles, I'm going to say it's probably unlikely.

My guess is that it's totally the CSS at play here.

I know that earlier I suggested you copy in the CSS separately and it seems that didn't do what we hoped. There is one other way to try and that's to choose the desired CSS at the time you generate. As this appears to be a CHM file, look at the SSL recipe card for Microsoft HTML Help and choose the option to apply a CSS to all topics.

tmp1.png

This method is slightly different than the others. Also, since it appears that RoboHelp may have altered the CSS file when you brought it in again, I might again suggest just using Windows Explorer to copy it over and replace the existing CSS. See what happens that way.

In case you haven't picked up on it, I don't give up easily.

tmp2.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 30, 2015

Copy link to clipboard

Copied

Great Rick!

However stamina is not always enough. Yesterday I sent one of my RH11 projects to Adobe for analysis. The verdict is back for a Windows 7 environment. This has no problems in their environment. Windows 8.1 environment is still pending.

Regarding your suggestions, they have already been tried and with the same result as the first one.

My company's IT department suspects a faulty Windows viewer or Windows 8.1 installation and have decided to reinstall my laptop. I'll get back with the end result

Cheers,

Erik (at the wrong end of the stick in Copenhagen)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 06, 2015

Copy link to clipboard

Copied

Back again and this time with a flawless installation. My brand new top-of-the-line Lenovo tablet was stripped and reinstalled. The culprit seems to have been the OS installation (Windows 8.1). Though no smoking gun was found!

Now everything works as it should. RH11 is up an running and all upgraded RH9 Projects are running.

Thanks to everyone for their advice on the rocky road to a solution

Cheers,

Erik

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...