Extra space in the first row of steps

Community Beginner ,
Jun 09, 2016 Jun 09, 2016

Copy link to clipboard

Copied

Hi,

I am generating print output from RoboHelp 2015. I observed an extra space in the begining of each step.

Find attached the screen capture.

Extra space in Steps.jpg

Regards,

Prashant

TOPICS
Documentation

Views

579

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2016 Jun 10, 2016

Copy link to clipboard

Copied

I have seen that before and it usually occurs when you have used spacing between the number and the text that is not the default, either in the source or, more likely, in the Word template.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2016 Jun 10, 2016

Copy link to clipboard

Copied

Hi Peter,

I checked indentation of Word and RoboHelp. I did not find any issue.


So, I tried different approach. I have got two similar Word templates. Except font, there is no difference between them. One template has Calibri font and another has Tahoma font. When I generate output with one which has Calibri font, the output is generated as expected. But the issue comes when I generate output with template that has Tahoma font. 

Customer needs Tahoma only, not Calibri.

Do you think, this issue is because of font? Please help me in this.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2016 Jun 10, 2016

Copy link to clipboard

Copied

First take the default CSS from a new project and the Style Mapping template in that project to see if it happens with those files. If it does not, them examine the differences with your CSS and template.

If that does not solve the problem, then create a one topic project using the same CSS and Word template for printed documentation. Test that it reproduces the problem. See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

It may be a good few days before I can look at it.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 14, 2016 Jun 14, 2016

Copy link to clipboard

Copied

Hi Peter,

I read your website's Contact page. I did not get how to transfer my project to you.

What does this mean:

To post to the forums, make sure you are logged on in both places shown with red arrow.

When I go to www.wetransfer.com, it asks me to enter email address of the recipient. Should I add your email ID into it and send you the project. But, on Contacts page it is recommended that files should not be sent over email.

Please guide me how to send you the project.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2016 Jun 14, 2016

Copy link to clipboard

Copied

The first key point on my Contact page is about not contacting me direct without trying the forums first. I therefore cover how to log into the forums first. Because of forum changes, that part may need rewording. I will take a look.

Then I ask that people do not attach projects to direct emails. Putting my email address into WeTransfer is OK as they do not email the project you upload there, instead they email a link so that I can download it. It's OK to enter my email in WeTransfer.

It will likely be the weekend before I can look at it.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 14, 2016 Jun 14, 2016

Copy link to clipboard

Copied

Peter,

Thank you for taking care of such basic queries.

I will upload project on WeTransfer. I will wait for your reply on weekend.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2016 Jun 19, 2016

Copy link to clipboard

Copied

You didn't send me the project so I cannot look at it.

If I receive it on Monday I might be able to look but after that for personal reasons it will be quite some time before I can respond to any forum posts or direct emails for several weeks.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2016 Jun 19, 2016

Copy link to clipboard

Copied

Hi Peter,

I have already sent you project on: robohelp@grainge.org.

I hope this is correct email ID. If not, please let me know correct email ID. I will try to send it ASAP.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2016 Jun 19, 2016

Copy link to clipboard

Copied

I hope you mean you used WeTransfer with that address but either way I have

not received anything.

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2016 Jun 19, 2016

Copy link to clipboard

Copied

Hi Peter,

Thanks for quick reply.

Yes, I have used WeTransfer for the same.

I have also got download link as: https://we.tl/5y6CB0oiUD

I will be online and will be waiting for your next reply.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2016 Jun 19, 2016

Copy link to clipboard

Copied

Hi Peter,

I tried with this link (https://we.tl/5y6CB0oiUD)and I am able to download from this.

Please try and let me know. I will respond you IST morning 07:00.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2016 Jun 19, 2016

Copy link to clipboard

Copied

I don't know quite how you used WeTransfer but I didn't get the usual email

from them. By posting the link online, anyone can now download your project.

It's late here now so I will download in the morning and then delete the link.

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2016 Jun 20, 2016

Copy link to clipboard

Copied

Hi Peter,

I hope you could download the project. Please let me know if there is any concern.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2016 Jun 20, 2016

Copy link to clipboard

Copied

Every time I try to generate the project as sent, I get a VB runtime error. I have tried to generate a new print layout and there I got an application error using your Word template and the Style Mapping template that was in your project.

Eventually I did get a Word document by using the Style Mapping template from another project. That was a clean template and it shows the error and that suggests the problem is the amount of indentation generally for the list.

I was amazed at the number of list styles you have and that makes working on the problem difficult. Let's get back to basics. Create a brand new project and create a similar topic but do not edit any styles, use what RoboHelp supplies. Then generate using the default style mapping template and I suspect that will be OK.

Let me know what happens there. Also please read the RoboHelp Multi Level Lists on my site but do not make any of the changes there until you followed the instructions above.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2016 Jun 20, 2016

Copy link to clipboard

Copied

Hi Peter,

Sure i will try in fresh project. But to cater the customer requirement, i need to create new styles or need to do changes for few existing RH styles in my original project. I hope this should be fine.

To clarify, I am not using any list style in my project. I need to delete those. Instead, i am using multilevel list styles only.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2016 Jun 21, 2016

Copy link to clipboard

Copied

Hi Peter,

I tried with default Style Mapping Template. it works fine. But, we want the project with our template.

I will try some workarounds with our template and let you know the progress according to RoboHelp Multi Level Lists

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

So your projects styles work with Style Mapping so that is a step forward. You have established the problem is in your template rather than RoboHelp, although given the indents you have in RoboHelp I am surprised by that. The more you indent lists, the more problems you have and setting them up in Word on its own can be fun, at least, I think that's the word!

What I would do now is tweak the Style Mapping template one style at a time and test. That way you will what it is that causes things to go bang. If you read the Printed Documentation pages on my site, you will see that I always advocate tweaking that template to give what you and your clients want, rather than starting from scratch. Doing that has solved many problems in the past where there is no logical reason the home brewed template should not work.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

Hi Peter,

Thank you very much for your advice. I will try and I hope it will resolve the issue.

Meanwhile, I tried a workaround after generating Word output which takes half a minute to remove the blank spaces infront of numbers and bullets. But ideally, we want final print output from RoboHelp itself.

About indentation of the lists, unfortunately, that is what customer has prescribed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2016 Jun 23, 2016

Copy link to clipboard

Copied

Indentation itself is OK, the problems arise with deep indentation. That can be dealt with but requires a bit more trial and error.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2016 Jun 23, 2016

Copy link to clipboard

Copied

LATEST

Ok.

Currently, I have specified indentation for steps and bullets using Multilevel List. Like, create a Multilevel List style, then create Level 1, Level 2, Level 3 and specify indentation with these buttons:

While working on topic in RH, I just use these buttons for changing the Levels:

Its works all fine in RH, but not in Word output.

The strange thing is - All this works with "another word template" having Calibri font, like this:

And when I use the same "another word template" by changing its font to Verdana, it does not work.

Regards,

Prashant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation