Highlighted

Failed to Generate Responsive HTML5 Output - How to fix?

Enthusiast ,
Jul 25, 2017

Copy link to clipboard

Copied

I'm using RH 2017, Update 1.

When generating to HMTL5 output on one of a small skeleton project our team uses, I'm getting this error.

Any ideas on how to fix it? It's something with this project but I don't know what. HTML5 output works fine on sample projects RH provides.

The compliation log is below. It really doesn't give any deatils on how to fix this:

Starting compilation...

Responsive HTML5 preprocessor 13.0.1.279

Clearing output folder...

Compiling D:\git\pcdmishelp\Skeletor\!SSL!\Responsive_HTML5\index.htm ...

Preparing to create Responsive HTML5 output...

Preparing files for Responsive HTML5 output...

Copying files...

Updating files...

Finished preparing in 4 sec(s)

Initializing compiler...

Generating Responsive HTML5 1.00 (13.0.1.279)...

Processing TOC data...

Updating topics...

Updating Book_Topic_(NonCore).htm...

Updating Book_Topic_(Planner).htm...

Updating Book_Topic_1.htm...

Updating Book_Topic_2.htm...

Updating Dropspot_Examples.htm...

Updating Files_in_Automation_Objects_Help.htm...

Updating Images.htm...

Updating MindMap_Files.htm...

Updating Movies.htm...

Updating NonCore_Topic.htm...

Updating object_hierarchy_chart.htm...

    Warning:Image maps are not converted to relative size.

Updating Process_to_Modify_the_Chart.htm...

Updating ReadMe.htm...

Updating Scripts.htm...

Updating Snippets.htm...

Updating Some_Skeleton_Structure.htm...

Updating Style_Sheets.htm...

Updating SubFolder1/NestedFolder/Topic_in_a_Nested_Folder.htm...

Updating SubFolder1/SubFolder_1_-_Planner_Test_Topic.htm...

Updating SubFolder1/SubFolder_1_Topic_1.htm...

Updating SubFolder1/SubFolder_1_Topic_2.htm...

Updating SubFolder1/Subfoler_1_-_NonCore_Test.htm...

Updating SubFolder2/SubFolder_2_Topic_1.htm...

Updating SubFolder2/SubFolder_2_Topic_2.htm...

Updating Usage.htm...

Updating Welcome_to_Skeletor.htm...

Updating What_s_In_It_.htm...

Finished updating topics in 1 sec(s) : total 27 topic(s).

Processing index data...

Processing glossary data...

Processing full-text search data...

...........................................................

Finished processing full-text search data in 1 sec(s)

Processing context-sensitive help data...

Applying screen layout page (Topic) to topics...

Finished compiling Responsive HTML5 output in 7 sec(s)

Internal error encountered,  Failed to generate Responsive HTML5.

Compilation complete.

I don't know if this is related, but I think there might be something messed up with the screen layouts. If I try to any layout from the Gallery, it gives me this:

I tried changing the name to Charcoal_Grey3. It gets past this "already exists" error and I can generate, but then I still get the first "Failed to Generate" error.

Topics

HTML5 layout

Views

324

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Failed to Generate Responsive HTML5 Output - How to fix?

Enthusiast ,
Jul 25, 2017

Copy link to clipboard

Copied

I'm using RH 2017, Update 1.

When generating to HMTL5 output on one of a small skeleton project our team uses, I'm getting this error.

Any ideas on how to fix it? It's something with this project but I don't know what. HTML5 output works fine on sample projects RH provides.

The compliation log is below. It really doesn't give any deatils on how to fix this:

Starting compilation...

Responsive HTML5 preprocessor 13.0.1.279

Clearing output folder...

Compiling D:\git\pcdmishelp\Skeletor\!SSL!\Responsive_HTML5\index.htm ...

Preparing to create Responsive HTML5 output...

Preparing files for Responsive HTML5 output...

Copying files...

Updating files...

Finished preparing in 4 sec(s)

Initializing compiler...

Generating Responsive HTML5 1.00 (13.0.1.279)...

Processing TOC data...

Updating topics...

Updating Book_Topic_(NonCore).htm...

Updating Book_Topic_(Planner).htm...

Updating Book_Topic_1.htm...

Updating Book_Topic_2.htm...

Updating Dropspot_Examples.htm...

Updating Files_in_Automation_Objects_Help.htm...

Updating Images.htm...

Updating MindMap_Files.htm...

Updating Movies.htm...

Updating NonCore_Topic.htm...

Updating object_hierarchy_chart.htm...

    Warning:Image maps are not converted to relative size.

Updating Process_to_Modify_the_Chart.htm...

Updating ReadMe.htm...

Updating Scripts.htm...

Updating Snippets.htm...

Updating Some_Skeleton_Structure.htm...

Updating Style_Sheets.htm...

Updating SubFolder1/NestedFolder/Topic_in_a_Nested_Folder.htm...

Updating SubFolder1/SubFolder_1_-_Planner_Test_Topic.htm...

Updating SubFolder1/SubFolder_1_Topic_1.htm...

Updating SubFolder1/SubFolder_1_Topic_2.htm...

Updating SubFolder1/Subfoler_1_-_NonCore_Test.htm...

Updating SubFolder2/SubFolder_2_Topic_1.htm...

Updating SubFolder2/SubFolder_2_Topic_2.htm...

Updating Usage.htm...

Updating Welcome_to_Skeletor.htm...

Updating What_s_In_It_.htm...

Finished updating topics in 1 sec(s) : total 27 topic(s).

Processing index data...

Processing glossary data...

Processing full-text search data...

...........................................................

Finished processing full-text search data in 1 sec(s)

Processing context-sensitive help data...

Applying screen layout page (Topic) to topics...

Finished compiling Responsive HTML5 output in 7 sec(s)

Internal error encountered,  Failed to generate Responsive HTML5.

Compilation complete.

I don't know if this is related, but I think there might be something messed up with the screen layouts. If I try to any layout from the Gallery, it gives me this:

I tried changing the name to Charcoal_Grey3. It gets past this "already exists" error and I can generate, but then I still get the first "Failed to Generate" error.

Topics

HTML5 layout

Views

325

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Jul 25, 2017

Copy link to clipboard

Copied

Hi there

For starters, try simply closing and restarting RoboHelp.

If that doesn't help, I might try deleting any of the layouts you aren't using. Then try to generate again. But before you do, I would create a totally new SSL of the Responsive HTML 5 type. Of course, you will also need to choose a layout for it before proceeding.

Give that a try and see how you fare.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
Jul 25, 2017

Copy link to clipboard

Copied

Thanks for fast reply Rick!


The issue in part has something to do with the SSL output. I cleaned out the contents in that directory and rebuilt. It at least generates fine now. That clears up the "Failed to Generate" issue.

I still get the "screen layout [layout-name] already exists" message unless I rename the layout with a uniqe name for some reason. But that's less of an issue.

Anyway, I haven't modified any of these layouts so I'm okay trashing them. I tried doing that, but I still get the "already exists" error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...