false hyperlinks

Participant ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

RH 10 on system 7. HTML5 output.

I am getting headings that appear to be hyperlinks, but they don 't actually open anything or fail to open anything. They just appear in hyplink color and appear active when you hover them.

Then when you click on one nothing happens but it continues to act like an active hyperlink.

I am not even sure how to describe it.

TOPICS
HTML

Views

182

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

Hi there

If they are hyperlinks, try double-clicking one in the RoboHelp editor. If it's a hyperlink, the Hyperlink dialog should open. If that happens, grab a screen shot and post it here using the little camera icon.

tmp1.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 06, 2015 Oct 06, 2015

Copy link to clipboard

Copied

The popup says it is a bookmark, but I put no bookmark there. It seems every single heading is a bookmark.

The content originates in MS Word.

Capture.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 06, 2015 Oct 06, 2015

Copy link to clipboard

Copied

Okay, so try this.

Open the topic in the RoboHelp editor.

Press Ctrl+End.

Press Enter about 20 times.

Now view the topic and click the links. Do they work?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 06, 2015 Oct 06, 2015

Copy link to clipboard

Copied

I am sorry I am not following. These bookmarks should not be there. At least, I didn't put them there. They look like maybe Robohelp/Word put them in to compile TOC ? I really don' t know.

There is not supposed to be any link associated with the word that has the false link. It is simply a text heading, not a link to anything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 06, 2015 Oct 06, 2015

Copy link to clipboard

Copied

LATEST

I think that's how "a name" tags show in the RH editor when applied across text, instead of just in front of or behind text. The little flag icon in from of Executive Summary is an example of how a bookmark appears when not applied across text. It would probably have come from the word document when you import a document that included a table of contents (see first screenshot vs second screenshot below). Or if the bookmark was manually applied that way in Word.

It shouldn't appear as a hyperlink in the output, so is more of a distraction in the RH editor.

If it's a real problem, one option might be to delete the ToC from the Word document and re-import. Although this would only be an option if you haven't made a lot of changes since importing. It might not be an option if the Word document is linked.

Or if you are comfortable with regular expressions you could do a find and replace, preferably using a third-party tool. You would need to change the code from something like:

<a name="This_is_a_heading_2">This is a heading 2</a>

to:

<a name="This_is_a_heading_2"></a>This is a heading 2

Remember to take a backup of your project before doing the replace, too.

Import_word_toc.pngImport_No_Word_TOC.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation