Fixed HTML errors keep returning -- help!

New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Hi there -- Robohelp formatting seems quite buggy! I've been able to fix most of the errors in the HTML. Then I save. But the errors return when I go back into the editing screen.  Examples: incorrect numbering removed in the 1st example, incorrect numbering back in 2nd example. In the 3rd example, extra spacing has been removed, in the 4th example the extra spaces are back. Does anyone know how I make these fixes permanent? The 1st one I fixed by deleting <li> before and </li> after the paragraph. The spacing I fixed by removing space between </em> and </span> and </li>.

Dorothy5C47_0-1607545779903.png

Dorothy5C47_1-1607545824302.png

Dorothy5C47_2-1607546094780.png

Dorothy5C47_3-1607546372112.png

Finally, I have no idea how to remove this numbering from in front of the word contents in the mini-TOC. The HTML is pasted below. Thank you for any suggestions! Dorothy

Dorothy5C47_4-1607547422002.png

Dorothy5C47_0-1607550600369.png

 

 

TOPICS
New UI

Views

160

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

What version of Robohelp are you using. You can find the version under the Help menu or File > Help, depending on the version. Please include all numbers.

 

What output are you generating? And what skin are you using?

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Also where are you editing? In the CSS editor or the content?

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Hi -- I'm using Robohelp 2019.01.11.(I'm using a trial while I wait for my organization to buy a subscription.) 

The output is Responsive HTML5. The skin is Indigo. I was fixing the errors directly in the HTML. Thanks for the help, I really appreciate it! Dorothy

 
 

 

 

 

 
 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Is this a new project or one that's been upgraded from Classic? If it's upgraded, I wonder if something hasn't translated properly.

 

If it's upgraded you could try adding a new Indigo skin (give it a slightly different name from your existing one) and generate with that. Does it make a difference to the minitoc? If not, in your browser, right-click on the minitoc "Contents" heading and select "Inspect". The "contents" p tag should be selected and the right-hand panel should indicate which stylesheets are providing the styles - you won't be able to edit the skin stylesheets directly, but it might help pinpoint where the problem is. You can post a screenshot of the Developer Tools window if you're not sure what you're looking at.

 

Regarding the screenshots of the green text, I think we'd need to see a sample of some code, and also the output code to see what's going on. Certainly it's not something I've come across.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

There were three more updates after 11 so try applying them to see if they help. Go to Help > Check for Updates.

 

In addition to what Amber has said...

 

List issues are best fixed in the CSS. Before you try any fixes create a copy of your project so that if your attempts to fix the issue backfire, you can get back to where you were.

 

Then select one of the errant lists and click this icon to remove any inline formatting.

 

image.png

 

That alone may fix the problem but if not go to the Styles tab and select All Styles. Click in the list that is still wrong and the style in use should be highlighted in the list of styles. Open the CSS editor and make changes there.

 

Are the topics created from a Word document import? If they are then they may well have brought in all sorts of Word HTML that always cause problems.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Hi -- It is a new project. I stripped the text of formatting in Notepad++ before pasting it and formatting. I don't think the issues are in the skin stylesheets, as they show up in the Preview section of the Author section (before the skin is applied.) I can't apply the updates because it's a trial version of Robohelp. I think I've figured out most of the issues but if you have any ideas about why the contents title is numbered, that would be very helpful. TYSM!

Dorothy5C47_1-1607727726921.png

 

Dorothy5C47_0-1607727609858.png

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Okay the numbering is set in your default.css.

 

Go into you stylesheet and click on the p.minitoc-caption entry, expand the Autonumber section and set Style to none. That should remove the numbering from the caption.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

Trial versions can be updated. There is a bug in updating the version you are using so download 2020.3 from Adobe - Support : RoboHelp Support Center : Service Releases

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

Hey, thanks for the tips. The numbering for p.minitoc-caption was already set to none, so unfortuantely that's not it. I've added the 2019 Robohelp updates (your note about the updater not working is a lifesaver!!), but it seems if I want 2020 updates I have to buy a different liscence. Is it worth it? I need to convince my bosses so it would be great to hear your expertise. Dorothy

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

RH2020 is subscription only now - no perpetual licenses. Sounds like your copy of RH2019 is a perpetual one, otherwise you could download and run both versions if you wanted.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

Odd. Your screenshot of the code definitely shows the counter being set on the p.minitoc-caption. Can you post a screenshot of the stylesheet editor with p.minitoc-caption selected and the Autonumber section expanded?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Within the trial period you can apply updates without charge?

Has your trial period expired? 

Are you seeing a dialog saying you cannot update?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

@Dorothy5C47 Upgrading is going from 2019 to 2020 while updating is within a version. Is this issue in the trial of 2020 and with updates applied?

 

If you only have a licence for 2019 you can nonetheless install 2020 as a trial and you can update that. Double clicking the RHPJ will try to open the project in 2020 but you will be warned before it upgrades the project. Open a project from within either version will open it in that version.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Hi -- The page was created in the trial version of Robohelp available from the Adobe website in early Dec 2020, which said it was 2019.01.11. I didn't see an option to choose a different version. My trial ends Dec 30. I will email Adobe about this. Dorothy

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

If Help > Updates doesn't produce anything for you in 2019, try this page - https://www.adobe.com/support/robohelp/downloads.html

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

@Amebr - Here is the p.minitoc-caption with the p.minitoc-caption selected and the Autonumber section expanded. There's also a substyle (?) called ::before. I don't know if it's relevant but here's the css that contains ::before 

 

a.reltopics-list-item {}
p::before {
counter-increment: p;
content: counter(p, decimal)".";
padding-right: 0.5rem;
}
p.minitoc-caption::before {
padding-right: 0.5rem;
}

 

 

Dorothy5C47_0-1608064346091.png

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Very strange. The css for your output does not seem to be the same as your source.

 

You do seem to have numbering set on all normal paragraphs using the default css as well. If that's not what you want, I would go in to the p style and unset the Autonumber settings.

 

I wonder if it's worth creating a new blank project and copying the stylesheet from that, for a fresh style start.

 

Just to explain a bit about the substyle, as you called it. When you set the Autonumber settings on a style, behind the scenes Robohelp is actually setting the :before substyle. 

 

Technically, it's a pseudo-element:

"A CSS pseudo-element is a keyword added to a selector that lets you style a specific part of the selected element(s). For example, ::first-line can be used to change the font of the first line of a paragraph."

https://developer.mozilla.org/en-US/docs/Web/CSS/Pseudo-elements 

 

I kind of get the feeling Adobe doesn't know who they're aiming the interface at. In some cases, the CSS technicalities are front and centre, but in other cases they are obscured. I'm not sure the decisions make it easier for either technical or non-technical users. 🙂

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation