Highlighted

Flash SWF not appearing in RH

Explorer ,
Jan 22, 2015

Copy link to clipboard

Copied

I am using TCS 4 with FM 12 and RH 11.

I have an animation built in Flash and published to a SWF file.

The animation is added to a FM doc. Publishing to PDF shows the animation as expected.

I link an RH project to the FM book and the animation is missing.  There is an empty frame where the animation should be, and what is in the frame is a blank PNG with a made up name (i.e. filename004.png).  I can add the SWF file manually into the frame but it gets wiped during the next update. I can turn off updates but that defeats the purpose of Single Sourcing.  There is no setting I can find in RH to manage importing media files.

Any help?

Topics

FrameMaker integration

Views

266

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Flash SWF not appearing in RH

Explorer ,
Jan 22, 2015

Copy link to clipboard

Copied

I am using TCS 4 with FM 12 and RH 11.

I have an animation built in Flash and published to a SWF file.

The animation is added to a FM doc. Publishing to PDF shows the animation as expected.

I link an RH project to the FM book and the animation is missing.  There is an empty frame where the animation should be, and what is in the frame is a blank PNG with a made up name (i.e. filename004.png).  I can add the SWF file manually into the frame but it gets wiped during the next update. I can turn off updates but that defeats the purpose of Single Sourcing.  There is no setting I can find in RH to manage importing media files.

Any help?

Topics

FrameMaker integration

Views

267

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 22, 2015

Copy link to clipboard

Copied

Is it in an anchored frame? Try a test – try importing into a blank project instead of linking to see if there’s a difference.

Another thought – try adding it as a baggage file to the RH project & generate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 23, 2015

Copy link to clipboard

Copied

Yep, anchored frame.

Adding baggage files did not help.

Embedding or linking within FM did not help.

Starting with your suggestions I did a little testing and found the problem.  There are, in fact, 2 SWFs in the one frame, and that was causing RH to give up on the frame entirely.  If I only put a single SWF in the frame, it seems to work.

I went back into Flash and glued both SWFs together to make one, which has solved it. However it would be interesting to know if there is a way to have 2 SWFs in a single FM frame.

Thanks for the help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 23, 2015

Copy link to clipboard

Copied

Aha! The old “2 SWFs in 1 frame” trick! LOL ;>)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...