Highlighted

Frameless output: Bugs/Issues (Favorites, Search, Favicon)

Community Beginner ,
Aug 15, 2019

Copy link to clipboard

Copied

I've been trying out the new frameless output, added in update 8. Overall, it provides a good experience and eliminates several drawbacks of the responsive Indigo layout. However, I've encountered several issues with it:

1. Favorites not working correctly when html files are put into folders

If project html files are organized into folders, this causes issues with favorites in the generated output: after you add a topic, located in a folder, to favorites (using the Set as Favorite button), and then try to open the favorites topic by following the generated link in the Favorites pane, the resulting link is broken, because the hyperlink also contains the folder of the topic where you are currently located, which is not necessary. For example:

- topic one: helpsite.com/FolderOne/TopicOneName.htm - this topic is added to favorites

- topic two: helpsite.com/FolderTwo/TopicTwoName.htm - the topic where you are located when trying to open the saved favorite topic

- when trying to open the topic one favorite while the topic two is open, the resulting link is: helpsite.com/FolderTwo/FolderOne/TopicOneName.htm (incorrect because of the added FolderTwo part)

If you'are located in a topic in the same folder, the link is still broken - the folder name is added twice. E.g.: helpsite.com/FolderOne/FolderOne/TopicOneName.htm

However, if you are trying to open a saved favorite from a topic that is not put into any project folder (i.e. located in the site root folder), the link is correct.

Also, an important note: this issue appears only after publishing a generated frameless output on a server. If the generated output is open locally, the issue is not reproduced. So, I was wondering whether this is a bug in the frameless output or the problem is on the server side where the generated site is published.

2. Favicon is displayed only on the Home page

In the frameless output: the favicon is displayed correctly when you are on the Home page, but after opening a topic, the favicon is no longer available.

3. Search query sometimes does not refresh prediction text and, in this case, pressing Enter no longer initiates search

In the frameless output, the search does not always work correctly. Sometimes, if you type a query, and then decide to remove it (with Backspace) to type another query, the predictive text for the initial query remains "hanging" and if this happens, the search does not start by pressing Enter. Although, you still can search by clicking the Search icon next to the search box. The Enter key does not do anything after this and the predictive text is no longer suggested until you refresh the page. This may be hard to reproduce - in my case, for some weird reason, queries starting on the "C" letter mostly cause this issue (it may depend on the content, I'm not sure). In my case at least, such queries as "create" or "connector" can always reproduce this problem.

Hope these issues will be addressed in the future updates. Maybe someone could help with any of these.

Hi,

First two issues related to favorites and favicon are there. We have logged RH-5256 and RH-5257 and they will be fixed as part of upcoming update.

Regarding the third issue of search query, I am not able to reproduce that. I tried with a large project as well.

Can you please share your project with us for this issue to reproduce? Please email it to me at sumahesh@adobe.com

Thank you so much for your feedback. It helps us in improving our product experience and provide the best.

Regards,
Surbhi Maheshwari

Views

279

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Frameless output: Bugs/Issues (Favorites, Search, Favicon)

Community Beginner ,
Aug 15, 2019

Copy link to clipboard

Copied

I've been trying out the new frameless output, added in update 8. Overall, it provides a good experience and eliminates several drawbacks of the responsive Indigo layout. However, I've encountered several issues with it:

1. Favorites not working correctly when html files are put into folders

If project html files are organized into folders, this causes issues with favorites in the generated output: after you add a topic, located in a folder, to favorites (using the Set as Favorite button), and then try to open the favorites topic by following the generated link in the Favorites pane, the resulting link is broken, because the hyperlink also contains the folder of the topic where you are currently located, which is not necessary. For example:

- topic one: helpsite.com/FolderOne/TopicOneName.htm - this topic is added to favorites

- topic two: helpsite.com/FolderTwo/TopicTwoName.htm - the topic where you are located when trying to open the saved favorite topic

- when trying to open the topic one favorite while the topic two is open, the resulting link is: helpsite.com/FolderTwo/FolderOne/TopicOneName.htm (incorrect because of the added FolderTwo part)

If you'are located in a topic in the same folder, the link is still broken - the folder name is added twice. E.g.: helpsite.com/FolderOne/FolderOne/TopicOneName.htm

However, if you are trying to open a saved favorite from a topic that is not put into any project folder (i.e. located in the site root folder), the link is correct.

Also, an important note: this issue appears only after publishing a generated frameless output on a server. If the generated output is open locally, the issue is not reproduced. So, I was wondering whether this is a bug in the frameless output or the problem is on the server side where the generated site is published.

2. Favicon is displayed only on the Home page

In the frameless output: the favicon is displayed correctly when you are on the Home page, but after opening a topic, the favicon is no longer available.

3. Search query sometimes does not refresh prediction text and, in this case, pressing Enter no longer initiates search

In the frameless output, the search does not always work correctly. Sometimes, if you type a query, and then decide to remove it (with Backspace) to type another query, the predictive text for the initial query remains "hanging" and if this happens, the search does not start by pressing Enter. Although, you still can search by clicking the Search icon next to the search box. The Enter key does not do anything after this and the predictive text is no longer suggested until you refresh the page. This may be hard to reproduce - in my case, for some weird reason, queries starting on the "C" letter mostly cause this issue (it may depend on the content, I'm not sure). In my case at least, such queries as "create" or "connector" can always reproduce this problem.

Hope these issues will be addressed in the future updates. Maybe someone could help with any of these.

Hi,

First two issues related to favorites and favicon are there. We have logged RH-5256 and RH-5257 and they will be fixed as part of upcoming update.

Regarding the third issue of search query, I am not able to reproduce that. I tried with a large project as well.

Can you please share your project with us for this issue to reproduce? Please email it to me at sumahesh@adobe.com

Thank you so much for your feedback. It helps us in improving our product experience and provide the best.

Regards,
Surbhi Maheshwari

Views

280

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 15, 2019 0
Adobe Community Professional ,
Aug 15, 2019

Copy link to clipboard

Copied

I have brought this to Adobe's attention.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2019 2
Community Beginner ,
Aug 16, 2019

Copy link to clipboard

Copied

Thank you, Peter.

A small update regarding the favicon issue: it is not displayed on the browser tab only in case the topic's htm file is not in the root folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2019 0
Adobe Employee ,
Aug 19, 2019

Copy link to clipboard

Copied

Hi,

First two issues related to favorites and favicon are there. We have logged RH-5256 and RH-5257 and they will be fixed as part of upcoming update.

Regarding the third issue of search query, I am not able to reproduce that. I tried with a large project as well.

Can you please share your project with us for this issue to reproduce? Please email it to me at sumahesh@adobe.com

Thank you so much for your feedback. It helps us in improving our product experience and provide the best.

Regards,
Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2019 2
Community Beginner ,
Aug 19, 2019

Copy link to clipboard

Copied

Hi Surbhi,

Thanks for the reply. I'm glad that provided feedback is useful and helps make the product better. I'll share the project with you for analysis, and also probably record a video to demonstrate it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2019 0