Generated help inserting extra slash into download button URL

New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Hi,

 

We're trying to implement the help in our product with the option to download the pdf format of the help. However, we run into issues with the download button because an extra slash is inserted into the URL for it during the generation process and Linux is not able to resolve the URL. For example, clicking on the button executes the following URL:

https://<system_name>/system/help/en/us/administration//assets/downloads/User_Guides.zip

 

Is this controlled anywhere in Robohelp itself? Can I prevent this from happening in Robohelp? Please advise.

Views

126

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

If you insert a link from a topic, does that have the same problem?

 

To answer the problem for a button you need to give us the version of RoboHelp, the output type and the skin.

 

If you are using 2019, Classic or New UI?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

Thanks for responding back. I am sorry, i do not understand what you mean by  "insert a link from a topic".

 

We are using latest version of robohelp - 2020.3.32

Frameless output type.

We have dowload button on top, that is suposed to download the pdf version of the help. 

help.png

 

[image added by moderator - please use image icon in web interface instead of attachments]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

Let's backtrack. I just tested adding a PDF to a frameless skin and it worked fine. Which skin are you using?

 

Also I missed that you are referring to Linux. I am not sure whether you have installed RoboHelp on a Linux box or are generating the output for use on Linux. Either way according to this page on Adobe's site, Linux is not supported. Versions of Windows and MS Word compatible with RoboHelp (adobe.com)

 

Can you try it on a Windows box to see if the issue occurs there?

 

Otherwise try dragging the PDF from your Contents panel to the TOC and then generate again. Does that link work?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

i am using Windows machine for robohelp.

the issue in dowload happens when help is served through our product. i have raised an issue with Adobe: https://tracker.adobe.com/#/view/RH-8694

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

Also are you connected with the poster of this thread?

 

https://community.adobe.com/t5/robohelp/generated-help-inserting-extra-slash-into-download-button-ur...

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

Yes, we work together. His post kept disappearing from the forum, so i reposted it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

I can see the double slash on a Windows desktop PC when I check my download history. 

 

I think this is a bug, myself, as the output should work on any web server (my understanding is the system requirements are only for running the Robohelp application, not running the output). You can request features and report issues here: https://tracker.adobe.com/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

Thanks, i have filed the bug: https://tracker.adobe.com/#/view/RH-8694

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

I think the other post has a response from Adobe as I had alerted them to it.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

Thanks. We have filed a bug with them: https://tracker.adobe.com/#/view/RH-8694

 

Thanks for your help!

Gagan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

Just to update. this bug has been resolved in update 4. Thanks Gagan for reporting it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Great. thanks a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Update 4 is now available via Help > Updates.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

LATEST

thank you! will try it soon 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation