Highlighted

Git + DevOps Repo = "Unable to push...fatal: Authentication failed..."

Engaged ,
Feb 14, 2020

Copy link to clipboard

Copied

Environment

 

Issue Summary:

Attempting to "Collaborate using Git" (instructions in RoboHelp Help) and add/manage version control for an existing RH2019 project in a Git repo hosted in DevOps. Using the HTTPS connection method (not SSH), which per our developers, should work. Running into a RoboHelp-generated/displayed authentication error when I attempt to add the project to the connection profile (and make that initial "push" of the entire project up to the repo). The title of the dialog is "Unable to push" and the error message text is:

 

fatal: Authentication failed for

'https://mycompanyname.visualstudio.com/ProjectName/_git/widgethelp/' 

 

Where mycompanyname is my company's name, ProjectName is the name of the DevOps project, and widgethelp is the name of my DevOps repo (configured in the RH Git connection profile). Note also that this entire https path is the exact https path that DevOps provides as the repo URL. 

 

In troubleshooting this issue, I was able to successfully add the RoboHelp project’s folders/files to a DevOps repo via GitBash (command line - "git push.."). However, this doesn't solve the issue of RoboHelp not being able to push to (and I assume pull from) the DevOps repo.

 

I also confirmed that my DevOps user has full read/write permissions for the repo. 

 

RoboHelp does report success when I make a change in the project and Collaborate>Commit the changes.

 

Additional areas of uncertainty for me:

  1. I haven't tried the SSH repo URL method yet; I was hoping to just use the HTTPS method. Our developers use DevOps repos, and the one I talked to indicates that HTTPS should be fine. He believes I'll experience the same error/issue via SSH.
  2. Windows Credential Manager and Authentication: Microsoft Active Directory auth or DevOps Git Credentials auth (provided as part of the HTTPS repo URL in DevOps)? We use AD for most authentication, including access to DevOps. However, the DevOps repo URL includes/provides a separate Git user and auto-generated password. I've tried both sets of credentials in the RH connection profile, but still get the same auth error above. 

 

SOLVED!

 

First, a quick recap on the enviro - this part is important - b/c the solution is Git repo enviro-specific.

 

My Laptop/PC Environment

  • Note: Employer administers/manages employee resource access via Windows AD SSO and 2-factor authentication.
  • Win 10
  • RoboHelp 2019.14 new
  • Git for Windows (latest and greatest) installed
  • GitHub Desktop (https://desktop.github.com/) preferred diff/merge tool - latest version installed

 

Git Repositories Environment

 

SOLUTION

Summary 

Create a personal access token in MS DevOps (with Read/Write permissions for repos). Use the PAT's auto-generated password (provided when creating the PAT) when setting up/opening your RoboHelp connection profile for the first time. 

 

Details

  1. Open DevOps.
  2. Locate your initials, in the top right corner of DevOps.
  3. Select User settings, (the "person" icon to the immediate left of your initials). A drop-down appears.
  4. Select Personal access tokens.
  5. Select + New Token.
  6. Assign it a name - for example, RoboHelp. Note, the name doesn't matter.
  7. Set an expiration date. It currently defaults to 1 month, but you can set it to 1 year.
  8. Assign permissions. You can select Full access or Custom defined. If you select Custom defined, be sure to select Read & write (or greater) under the Code permissions (which handles repo access/permissions).
  9. Select Create.
  10. IMPORTANT: Copy the auto-generated/supplied password to the clipboard. This is the only chance you have to see/copy the password, and it's the password you need to enter in RoboHelp when setting up the connection profile. 
  11. Open RoboHelp and create your Git connection profile.
  12. The first time you open/connect to the profile, RoboHelp will prompt you to enter the password. Do NOT enter your personal Microsoft domain network/sign-on password. Instead, paste/enter the password DevOps created/you copied to the clipboard when creating the PAT.
  13. That's it.

 

Topics

Version control

Views

313

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Git + DevOps Repo = "Unable to push...fatal: Authentication failed..."

Engaged ,
Feb 14, 2020

Copy link to clipboard

Copied

Environment

 

Issue Summary:

Attempting to "Collaborate using Git" (instructions in RoboHelp Help) and add/manage version control for an existing RH2019 project in a Git repo hosted in DevOps. Using the HTTPS connection method (not SSH), which per our developers, should work. Running into a RoboHelp-generated/displayed authentication error when I attempt to add the project to the connection profile (and make that initial "push" of the entire project up to the repo). The title of the dialog is "Unable to push" and the error message text is:

 

fatal: Authentication failed for

'https://mycompanyname.visualstudio.com/ProjectName/_git/widgethelp/' 

 

Where mycompanyname is my company's name, ProjectName is the name of the DevOps project, and widgethelp is the name of my DevOps repo (configured in the RH Git connection profile). Note also that this entire https path is the exact https path that DevOps provides as the repo URL. 

 

In troubleshooting this issue, I was able to successfully add the RoboHelp project’s folders/files to a DevOps repo via GitBash (command line - "git push.."). However, this doesn't solve the issue of RoboHelp not being able to push to (and I assume pull from) the DevOps repo.

 

I also confirmed that my DevOps user has full read/write permissions for the repo. 

 

RoboHelp does report success when I make a change in the project and Collaborate>Commit the changes.

 

Additional areas of uncertainty for me:

  1. I haven't tried the SSH repo URL method yet; I was hoping to just use the HTTPS method. Our developers use DevOps repos, and the one I talked to indicates that HTTPS should be fine. He believes I'll experience the same error/issue via SSH.
  2. Windows Credential Manager and Authentication: Microsoft Active Directory auth or DevOps Git Credentials auth (provided as part of the HTTPS repo URL in DevOps)? We use AD for most authentication, including access to DevOps. However, the DevOps repo URL includes/provides a separate Git user and auto-generated password. I've tried both sets of credentials in the RH connection profile, but still get the same auth error above. 

 

SOLVED!

 

First, a quick recap on the enviro - this part is important - b/c the solution is Git repo enviro-specific.

 

My Laptop/PC Environment

  • Note: Employer administers/manages employee resource access via Windows AD SSO and 2-factor authentication.
  • Win 10
  • RoboHelp 2019.14 new
  • Git for Windows (latest and greatest) installed
  • GitHub Desktop (https://desktop.github.com/) preferred diff/merge tool - latest version installed

 

Git Repositories Environment

 

SOLUTION

Summary 

Create a personal access token in MS DevOps (with Read/Write permissions for repos). Use the PAT's auto-generated password (provided when creating the PAT) when setting up/opening your RoboHelp connection profile for the first time. 

 

Details

  1. Open DevOps.
  2. Locate your initials, in the top right corner of DevOps.
  3. Select User settings, (the "person" icon to the immediate left of your initials). A drop-down appears.
  4. Select Personal access tokens.
  5. Select + New Token.
  6. Assign it a name - for example, RoboHelp. Note, the name doesn't matter.
  7. Set an expiration date. It currently defaults to 1 month, but you can set it to 1 year.
  8. Assign permissions. You can select Full access or Custom defined. If you select Custom defined, be sure to select Read & write (or greater) under the Code permissions (which handles repo access/permissions).
  9. Select Create.
  10. IMPORTANT: Copy the auto-generated/supplied password to the clipboard. This is the only chance you have to see/copy the password, and it's the password you need to enter in RoboHelp when setting up the connection profile. 
  11. Open RoboHelp and create your Git connection profile.
  12. The first time you open/connect to the profile, RoboHelp will prompt you to enter the password. Do NOT enter your personal Microsoft domain network/sign-on password. Instead, paste/enter the password DevOps created/you copied to the clipboard when creating the PAT.
  13. That's it.

 

Topics

Version control

Views

314

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 14, 2020

Copy link to clipboard

Copied

I think you're going to need to contact the RH boffins directly on this one - techcomm@adobe.com.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Feb 14, 2020

Copy link to clipboard

Copied

And now all of a sudden, it's working. I can now edit a topic in RH, save the change, Collaborate>Commit, Collaborate>Push (no error; temporarily displays success message), and separately view the DevOps repo and see the updated topic there. No RH, Git, or DevOps settings were changed; still using HTTPS repo URL. Very weird.

 

Notes/observations about the currently functioning enviro:

  1. RH connection profile username setting: is my email address (my MS AD auth username - not the DevOps repo-provided/suggested username)
  2. RH connection profile repo HTTPS URL setting: does not include the ".git" extension appended to the end, as documented in Adobe's "Collaborate using Git" help topic. (Earlier, I'd tried setting the URL both with the .git extension and without, and was still getting the error.) Odd that it's successfully pushing without the documented .git extension.

 

I'm going to go back and attempt this for some other projects, to document the process for the rest of my team and confirm that it's a dependable/repeatable process. We'll see how that fairs, and whether I can identify a culprit. I'll update the post accordingly. In the meantime, if anyone has any additional thoughts/insights, please add them here! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Sep 18, 2020

Copy link to clipboard

Copied

SOLVED!

 

First, a quick recap on the enviro - this part is important - b/c the solution is Git repo enviro-specific.

 

My Laptop/PC Environment

  • Note: Employer administers/manages employee resource access via Windows AD SSO and 2-factor authentication.
  • Win 10
  • RoboHelp 2019.14 new
  • Git for Windows (latest and greatest) installed
  • GitHub Desktop (https://desktop.github.com/) preferred diff/merge tool - latest version installed

 

Git Repositories Environment

 

SOLUTION

Summary 

Create a personal access token in MS DevOps (with Read/Write permissions for repos). Use the PAT's auto-generated password (provided when creating the PAT) when setting up/opening your RoboHelp connection profile for the first time. 

 

Details

  1. Open DevOps.
  2. Locate your initials, in the top right corner of DevOps.
  3. Select User settings, (the "person" icon to the immediate left of your initials). A drop-down appears.
  4. Select Personal access tokens.
  5. Select + New Token.
  6. Assign it a name - for example, RoboHelp. Note, the name doesn't matter.
  7. Set an expiration date. It currently defaults to 1 month, but you can set it to 1 year.
  8. Assign permissions. You can select Full access or Custom defined. If you select Custom defined, be sure to select Read & write (or greater) under the Code permissions (which handles repo access/permissions).
  9. Select Create.
  10. IMPORTANT: Copy the auto-generated/supplied password to the clipboard. This is the only chance you have to see/copy the password, and it's the password you need to enter in RoboHelp when setting up the connection profile. 
  11. Open RoboHelp and create your Git connection profile.
  12. The first time you open/connect to the profile, RoboHelp will prompt you to enter the password. Do NOT enter your personal Microsoft domain network/sign-on password. Instead, paste/enter the password DevOps created/you copied to the clipboard when creating the PAT.
  13. That's it.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...