Having trouble copying drop-down text

Participant ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi guys,

I've been using a lot of drop-down text section in my documentation.  I use them to show/hide additional information on certain sections, and I have anything between 2 and 10 of them on each of the pages in my documentation, so I can't just leave them out.

 

However, since upgrading my project to the 2019 layout, I keep getting "failures" on my drop-down text sections.  A bunch of them simply stopped working, in other words they don't "drop down" when I double-click them in the editor, and they also don't work when I click them in the HTML5 output.

 

Further, in the previous version (2017), I used to simply copy-paste the collapsed drop-down text section to where I needed a new one (because I have some containers in them I use across the board) and edited the images or tables as needed.  When I do the same now, it seems the drop-downs get linked together, so if I open up one in the output, they all open up and the images are all stuffed up.

 

I did some research and it seems like the drop-downs are handled differently between the two versions.  In 2017, the dropdowns were named and numbered like this:

 

<a class="dropspot" data-rhwidget="DropSpot" data-target="POPUP5151179732"...etc

 

The dropdown contents would then be linked via that same data-target POPUP#### number.  I went back and looked in the 2017 project - copying this automatically increments that number behind the popup, resulting in a unique, working drop-down in each case.  In 2019, they simplified this drastically and changed the naming style to:

 

<a class="dropspot" data-rhwidget="DropSpot" data-target="drop_down4"... etc

 

So while the only difference is the naming of the dropdowns to "drop_down##", it isn't working that well.  Copying that dropdown creates a new one in the editor, but it doesn't update the drop-down number accordingly, so you have two (or more) pieces of code in the backend that has the same data target, which is why I assume I'm having issues with the reliability and contents.

 

Sometimes, clicking the one drop-down doesn't even open both, but it opens another one (where it was copied from) at another place in the page.  Has anyone else found this issue as well, and if so, how did you go about fixing it?  Is it something Adobe is aware of?  I've searched, but can't find the same issue anywhere...

 

Hoping to hear from you guys soon, as helpful as you always are!

TOPICS
HTML5 layout, New UI, Single source layouts

Views

280

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Having trouble copying drop-down text

Participant ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi guys,

I've been using a lot of drop-down text section in my documentation.  I use them to show/hide additional information on certain sections, and I have anything between 2 and 10 of them on each of the pages in my documentation, so I can't just leave them out.

 

However, since upgrading my project to the 2019 layout, I keep getting "failures" on my drop-down text sections.  A bunch of them simply stopped working, in other words they don't "drop down" when I double-click them in the editor, and they also don't work when I click them in the HTML5 output.

 

Further, in the previous version (2017), I used to simply copy-paste the collapsed drop-down text section to where I needed a new one (because I have some containers in them I use across the board) and edited the images or tables as needed.  When I do the same now, it seems the drop-downs get linked together, so if I open up one in the output, they all open up and the images are all stuffed up.

 

I did some research and it seems like the drop-downs are handled differently between the two versions.  In 2017, the dropdowns were named and numbered like this:

 

<a class="dropspot" data-rhwidget="DropSpot" data-target="POPUP5151179732"...etc

 

The dropdown contents would then be linked via that same data-target POPUP#### number.  I went back and looked in the 2017 project - copying this automatically increments that number behind the popup, resulting in a unique, working drop-down in each case.  In 2019, they simplified this drastically and changed the naming style to:

 

<a class="dropspot" data-rhwidget="DropSpot" data-target="drop_down4"... etc

 

So while the only difference is the naming of the dropdowns to "drop_down##", it isn't working that well.  Copying that dropdown creates a new one in the editor, but it doesn't update the drop-down number accordingly, so you have two (or more) pieces of code in the backend that has the same data target, which is why I assume I'm having issues with the reliability and contents.

 

Sometimes, clicking the one drop-down doesn't even open both, but it opens another one (where it was copied from) at another place in the page.  Has anyone else found this issue as well, and if so, how did you go about fixing it?  Is it something Adobe is aware of?  I've searched, but can't find the same issue anywhere...

 

Hoping to hear from you guys soon, as helpful as you always are!

TOPICS
HTML5 layout, New UI, Single source layouts

Views

281

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 09, 2019 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

Classic or new UI?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Participant ,
Oct 09, 2019

Copy link to clipboard

Copied

New UI. Classic one follows the 2017 convention, as far as I can make out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

Applied all the patches?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Participant ,
Oct 09, 2019

Copy link to clipboard

Copied

I have applied all the patches and my program is up to date, yes. I also have the hotfix installed. Same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

Apologies for the confusion in what I posted earlier. I'm taking another look now!

 

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

Am I right in understanding that rather than creating new dropdowns, you are pasting a "master" from somewhere and that is when the problem occurs?

 

Are you copying the hotspot and the content? Does it work OK if you just paste the content into a new dropdown?

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Participant ,
Oct 09, 2019

Copy link to clipboard

Copied

If I create a new hotspot and just copy-paste the content, it works fine. That's because if I create a new drop-down, it automatically get the correct drop-down number. It's when I copy the collapsed drop-down hotspot where the trouble happens. I can make a video to explain the problem I have, if that would help?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Adobe Community Professional ,
Oct 10, 2019

Copy link to clipboard

Copied

No need for a video. It's clear that pasting the whole dropdown (hotspot and content) is what's causing the problem. For now you have a workaround, don't paste the hotspot. I will report the problem to Adobe.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2019 0