Help topics are not displaying when using Windows 8/IE 10

Explorer ,
Jan 04, 2013 Jan 04, 2013

Copy link to clipboard

Copied

I have a WebHelp system created in RoboHelp 7. When opening that Help from our application using Windows 8 with Internet Explorer 10 and allowing blocked content, the Help topics do not display in the right pane when clicking a topic from the Contents in the left pane. Below are the steps:

1. Open the Help system from the Help menu within the application.

2. The Allow Blocked Content displays and I allow it.

3. The Help opens and if I click a topic from the TOC in the left pane, the topic doesn't display in the right pane.

A workaround we found was to widen the left pane and the topic then displays. Also, if you don't allow blocked content, this issue doesn't happen. However, I need to allow blocked content in order for PDFs within the Help to open properly and also because the Search doesn't display without allowing blocked content.

We also tested this with a Help system that was created using Robohelp 9 and have the same issue. I'm wondering if RoboHelp 10 would solve this problem.

Does anyone know if IE 10 requires Help systems to be created in RoboHelp 10 to work properly, at least when allowing blocked content?

TOPICS
WebHelp

Views

14.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2013 Feb 28, 2013

Copy link to clipboard

Copied

Just an idea - check these setting:

Tools > Compatibility View settings

The defaults are Compatibility View off for all sites, but Compatibility View on for intranet sites. Also, the site should not be listed in the compatibility view list (i.e. it hasn't been added to the Compatibility View list).

In addition, Microsoft maintains a list of sites which are known to require compatibility view, and uses it automatically for those sites. 

See http://windows.microsoft.com/en-US/internet-explorer/ie10-win8-privacy-statement

So I'm wondering if the browser you are using is using compatibility view automatically for some reason? I think it will be shown as active (not grayed)in the Tools menu if it is not being used for the current page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2013 Feb 28, 2013

Copy link to clipboard

Copied

I don't think Compatibility was enabled. I certainly have not set it to be. Cannot check that machine until Monday week.

I have reported this to Adobe and will check any IE10 machine I can.

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2013 Mar 11, 2013

Copy link to clipboard

Copied

I have managed to force the issue on my Windows 8 machine. I think the key one was deselecting the first check box as the URL was a Favourite.

ie10settings.PNG

I spoke to Adobe about this whilst I was at WritersUA and will be following up.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2013 Mar 11, 2013

Copy link to clipboard

Copied

Great! Thanks for persisting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 19, 2013 Mar 19, 2013

Copy link to clipboard

Copied

I have carried out some more tests and posted the results at http://www.grainge.org/pages/snippets/snippets.htm#webhelp Item 15

You can access the help I created at

http://www.grainge.org/demos/pg9/

http://www.grainge.org/demos/pg10/

Please post here if you get different results.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 05, 2013 Apr 05, 2013

Copy link to clipboard

Copied

The patch released today should fix these issues. I will be testing this problem again on Monday after applying the patch.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2013 Apr 05, 2013

Copy link to clipboard

Copied

Thanks for the credit Peter!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 05, 2013 Apr 05, 2013

Copy link to clipboard

Copied

@donalmc Sorry, did I miss acknowledging something you had done or am I missing your meaning?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2013 Apr 05, 2013

Copy link to clipboard

Copied

No - I'm saying thanks for the credit on your site.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 05, 2013 Apr 05, 2013

Copy link to clipboard

Copied

I have noticed that the IE10 problem is not listed in what has been fixed. I am trying to clarify whether or not it is fixed. Unfortunately I don't have access to my IE10 machines until Monday.

If anyone goes ahead and tests this, please advise the results.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2013 Apr 16, 2013

Copy link to clipboard

Copied

Hello Peter. Just curious if the incompatibility issues with WebHelp and Internet Explorer 10 have been resolved in any way besides the Meta tag method (which doesn't seem to be working for me). Strange that Adobe or Microsoft have not yet acknowledged this incompatibility problem in any way yet - as there must be a lot of WebHelp-formatted content acting strangely in IE10 these days. The screen resizing and Compatibility View methods seem to clear up the problems somewhat, but I'm looking for something that won't require any additional user steps (something that will FORCE Compatibility View mode right away) and, unfortunately, as I mentioned, that Meta tag insertion in the top of the first loaded topic's html doesn't seem to work. Hopefully Adobe will address this with a patch of some sort - but I'm curious as to how others are dealing with this problem as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 16, 2013 Apr 16, 2013

Copy link to clipboard

Copied

The meta tag has to go in the start page, not the default topic.

I am told that IE10 has more compatibility issues than just this one and I have no doubt the matter is being worked on. All I can say is Watch this Space.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2013 Apr 17, 2013

Copy link to clipboard

Copied

We have found that this issue is tied to the "Do Not Track" setting in IE under Advanced.  If you turn this off, the help files work fine.  So, the question is why does RoboHelp not work with the "Do Not Track" feature?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2013 Apr 17, 2013

Copy link to clipboard

Copied

jerle78--you beat me to it! I discovered that fix this morning. One of my coworkers said he added our help URL domain to his trusted sites to fix it. So I looked on the Advanced tab to see what new security feature was added in IE10 and found the "Always send Do Not Track header" check box, which I hadn't seen before. Clearing the check box makes this problem go away (i.e., allows the topic to display), which is awesome, but now everyone wants to know what is in the generated RoboHelp code that would be affected by this setting? For now, I'll have to write a knowledgebase article for our (few?) customers who are using IE10, and maybe add a link to the KB from the toolbar of every helpset so they know how to fix it. (Probably just on newest versions of help.) I've informed our sales and support people, too (who are asking "Why?"). Unfortunately, I don't know enough about JavaScripting to look at the code and say "Eureka!"

(BTW, this issue also appears on Windows 7 if you install IE10. But most end-users with IE10 have Windows 8.)

--Karla--

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 19, 2013 Apr 19, 2013

Copy link to clipboard

Copied

Adobe have released three fixes.

One is to the Rh10 installation so that freshly generated help does not have this problem.

The second is to fix existing webhelp generated from Rh10 so that you do not have to regenerate.

The third is to fix webhelp generated from Rh9.

http://helpx.adobe.com/robohelp/kb/help-visible-using-win-8-ie.html

The link name is misleading as the problem occurs with help viewed in IE10, regardless of whether you are using Windows 7 or 8.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2013 Apr 19, 2013

Copy link to clipboard

Copied

Thanks, Peter, for posting the fix, and thanks, Adobe, for providing it!

--Karla--

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

I applied the files Adobe provided and the problem remains. Based on my reading of the instructions, I put the new files here:

C: ..\..\PROJECT_FOLDER\Online Help\!SSL!\WebHelp_Pro

Did I miss something?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

The first time I tried it (RH10), I didn't apply the fix correctly. Not saying that you did the same thing, but review the steps and what you did carefully. In may case, when I unzipped the files, I was focused on the whtbar.js changes (because I have some customization in mine) and neglected to copy and paste whskin_frmset01.htm. Be sure to edit the installation files, too, so you don't have to do that every time you generate help. (But make backup copies first!) Also, you may have to clear the cache in IE AND close and reopen it for it to read in the changes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

"Be sure to edit the installation files..." - Please clarify. I put the updated whskin_frmset01.htm and whtbar.js in the ..\WebHelp_Pro folder; your comment suggests I need to put the updated files somewhere else.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

yes - the c:\program files (whatever)\adobe\robohelp10\... folder that it describes in the link

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

Yes, Dan_18. On the adobe link above, there are 3 fixes: one for newly generated help, one for already generated help, and one for RH9.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

The one for RH9 only applies to output generated with RoboHelp 9. It does not fix the installation, meaning that you need to apply the patch to your output every time you generate.

On my site you can find a fix for your RoboHelp 9 installation so that you only have to fix RH itself once. See http://www.wvanweelden.eu/blog/2013/04/24/ie10-patch-robohelp-9-installation for more information.

Greet,

Willam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

Thanks, Peter. I downloaded the fix to our published RH 9 folder and the pages do display now in IE 10.

However, the Index issue in IE 10 is still there. I thought the fix would solve this issue, too. But whenever I click an index keyword or subkeyword with multiple entries, the entries display cut off in the pop-up list. Single entries display fine.

I've also since discovered that Chrome also has index issues where it doesn't display any pop-up list when you have multiple entries for a keyword.

Do you know what might be causing this issue and if there is a fix for it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2013 Apr 25, 2013

Copy link to clipboard

Copied

No to the cause and no to the fix.

I'll see if I can replicate it but that will be some days away.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 29, 2013 Apr 29, 2013

Copy link to clipboard

Copied

LATEST

I am not seeing the problem with a new project created in Rh9 and viewed in IE10. Try a new project to see what you get.

I also upgraded the test to Rh10 and it still works OK.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation