Highlighted

HHC5003 compile error with URL

Community Beginner ,
Jul 17, 2017

Copy link to clipboard

Copied

Hello helpers.

I know that this error is no big deal, and the file does work fine. But it bugs me...

I use RH 11. When I compiled, I kept getting the "compilation failed while compiling" a specific URL. I found that the URL was used only in the index, and it turned out that it was a broken link. I found all of the instances and replaced them with a working link, and the failed URL disappeared from the URLs folder. However, the compilation error for it remains.

Any thoughts on getting the error to disappear, or find where RH thinks the URL still is? I've searched the index and the bad URL is not linked to anything, nor does it appear in any topic.

Thanks!

Dimi

The fact you are seeing this "error" seems to suggest you are compiling into CHM format. Is that correct?

Assuming so, it's possible that one of the buttons has been programmed to open that URL when clicked. Have you looked at the Window Properties? It may well be that this is where the link is hiding.

Cheers... Rick

Topics

HTML

Views

414

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

HHC5003 compile error with URL

Community Beginner ,
Jul 17, 2017

Copy link to clipboard

Copied

Hello helpers.

I know that this error is no big deal, and the file does work fine. But it bugs me...

I use RH 11. When I compiled, I kept getting the "compilation failed while compiling" a specific URL. I found that the URL was used only in the index, and it turned out that it was a broken link. I found all of the instances and replaced them with a working link, and the failed URL disappeared from the URLs folder. However, the compilation error for it remains.

Any thoughts on getting the error to disappear, or find where RH thinks the URL still is? I've searched the index and the bad URL is not linked to anything, nor does it appear in any topic.

Thanks!

Dimi

The fact you are seeing this "error" seems to suggest you are compiling into CHM format. Is that correct?

Assuming so, it's possible that one of the buttons has been programmed to open that URL when clicked. Have you looked at the Window Properties? It may well be that this is where the link is hiding.

Cheers... Rick

Topics

HTML

Views

415

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Jul 17, 2017

Copy link to clipboard

Copied

Hi there

When you look at your Project Manager pod, you should see a "folder" that is named "URLs".

tmp2.png

Your URL should appear in this location. And you should be able to right-click it to see options.

Have you tried that?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 17, 2017

Copy link to clipboard

Copied

Well, yes. That's how I got started. The problematic URL was in there and was used only in the index. I went to all the index keywords and used the correct URL and after replacing all of the incorrect URLs with the correct one and deleting the incorrect one, the incorrect one disappeared from the URLs folder. When I compile the file, however, it still shows up with HHC5003 "cannot compile this URL."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 17, 2017

Copy link to clipboard

Copied

Have you tried deleting the CPD and then reopening the project?

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 17, 2017

Copy link to clipboard

Copied

I did just now, but still get the error.

I suppose it's just one of those things I'll have to live with. At least the help file is OK.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jul 17, 2017

Copy link to clipboard

Copied

The fact you are seeing this "error" seems to suggest you are compiling into CHM format. Is that correct?

Assuming so, it's possible that one of the buttons has been programmed to open that URL when clicked. Have you looked at the Window Properties? It may well be that this is where the link is hiding.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 17, 2017

Copy link to clipboard

Copied

You're a genius!! That's where the URL was and I've deleted it.

Thanks bunches!

Dimi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...