Highlighted

How do I get books with topics to open the topic on first click?

New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

I am using Robohelp 10 (10.0.1.292) to (re) build a webhelp sample for my portfolio that I originally built in a SaaS tool called HelpIQ/ProProfs Knowledgebase. When I built that system, I had the typical TOC with books and topics, and because I don't like empty books, in that system, the books were also topics, typically the overview topics on a particular subject with links to the sub-topics.

In RH 10, WebHelp is my primary (and only) output. As I am (re)creating my TOC structure, I am taking the overview topics, converting them to books in the TOC and then making it a book with link and selecting the topic. All fine. But the output has one issue:

When I click on a book, just one action occurs: opening the book to show the sub-topics. What's interesting is that I can click on the book a second time, and the topic will display.

What should happen, what I expect to happen, what I have seen happen in the aforementioned tool, is that clicking on a book makes both happen with one click. Is there a way for RH's WebHelp output to do that?

Please note: Upgrading to the latest version is NOT an option for me; this is my personal version, and unless someone wants to donate a license for the latest version, I am stuck with this one.

TOPICS
WebHelp

Views

495

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I get books with topics to open the topic on first click?

New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

I am using Robohelp 10 (10.0.1.292) to (re) build a webhelp sample for my portfolio that I originally built in a SaaS tool called HelpIQ/ProProfs Knowledgebase. When I built that system, I had the typical TOC with books and topics, and because I don't like empty books, in that system, the books were also topics, typically the overview topics on a particular subject with links to the sub-topics.

In RH 10, WebHelp is my primary (and only) output. As I am (re)creating my TOC structure, I am taking the overview topics, converting them to books in the TOC and then making it a book with link and selecting the topic. All fine. But the output has one issue:

When I click on a book, just one action occurs: opening the book to show the sub-topics. What's interesting is that I can click on the book a second time, and the topic will display.

What should happen, what I expect to happen, what I have seen happen in the aforementioned tool, is that clicking on a book makes both happen with one click. Is there a way for RH's WebHelp output to do that?

Please note: Upgrading to the latest version is NOT an option for me; this is my personal version, and unless someone wants to donate a license for the latest version, I am stuck with this one.

TOPICS
WebHelp

Views

496

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

Can you post some screenshots to illustrate the effect you're getting? Is it dependent on what browser you use?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Locally, anyway, I see the same behavior in Firefox and Edge. Interestingly, the current iteration of the help system doesn't render at all in Chrome. (And I should have mentioned Windows 10.)

Screen caps would not show the behavior as well as video, but it'd take some time to create those.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

I would expect browser fixes to be needed - see Re: ToC books not opening in Chrome about all that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Nope, not a browser issue. All browsers are latest.

Besides, running from web server, I can view the help system in all 3 browsers (although Chrome doesn't update to newest TOC, for some reason, even when forced to do a full refresh), but I see identical behavior in all 3. So the behavior is clearly not a browser limitation, but an issue with the RH code. Question is, is it a setting somewhere that I'e overlooked or a RH issue that needs to be fixed--if Adobe would even fix it in an older RH version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

It could also be that it's code that was brought from the previous tool. To rule that out, open one of the sample projects that ships with RoboHelp and see how that behaves in the same browsers, Chrome excepted as in the link Jeff posted.

If the sample works, then it suggests (not proves) it is something brought in as the behaviour you are seeing is not normal.

Post back with how the sample works.

Also you say I am taking the overview topics, converting them to books in the TOC and then making it a book with link and selecting the topic. That sounds like two processes but in RoboHelp you simply link a topic to a book. What do you mean by converting a topic to a book.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
LEGEND ,
Feb 26, 2018

Copy link to clipboard

Copied

Yeah, I'm not sure how much I would expect Adobe to address it. 10 is pretty long in the tooth as far as versions go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Last question first:

1. Add topic to TOC.

2. Right-click topic in TOC, select Create Book from Page.

3. Right-click new book, select Properties.

4. Select Book with Link check box.

5. Select topic to be used.

6. Click OK.

No, I did not import a project. I created a brand new project, and am importing topics (as HTML files) one-by-one, and building a TOC one topic and book at a time. (Nearly every topic requires some fixes, but the HTML that came from the export from HelpIQ is pretty clean. )

The portfolio piece, or what I've built out of it so far (with most links not working if you try; those will be the last thing I fix everywhere) is at http://chuck.martin.name/portfolio/ItsOnHelp/index.htm

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

Just fyi the site was blocked for me:

  • Access has been blocked as the threat Mal/HTMLGen-A has been found on this website.

Edited by Moderator - Peter Grainge

Knowing who the poster is I was surprised to see this warning so I tested on spare machine and Kaspersky was OK with the link. I went ahead and the machine used is fine.

I am leaving the link in for that reason.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

Chuck

I see what you are reporting but I also see something else which is making me think that it is linked to the issue in the thread Jeff pointed you to.

The other thing I am seeing is that when you click one book, the previously opened book closes. That is not normal WebHelp behaviour in RoboHelp but I saw it when dealing with the other issue. That issue went away when the fix was applied. Take a look at Item 14 in Using RoboHelp 2017. I know that is not your version but others have reported the fix works in older versions too.

Keep the old files so that you can back out but my guess is that will also fix what you posted about. The only downside I know of at the moment is that TOC synchronisation seems to break with this fix. That has been reported to Adobe but I doubt that will be fixed in your version. Then again, it might not break that in your version.

Let us know how that goes.

Kind regards.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
New Here ,
Feb 27, 2018

Copy link to clipboard

Copied

Thanks for the idea Peter. I considered that, but I dismissed it originally because this was behavior I saw across browsers. At your urging, I gave it a try anyway, and it did not change the behavior I've been seeing. (Locally, anyway, I have not tried it on my web server.)

OK, to be fair, after I made the backup, I only commented out the offending line, adding its replacement below. But of course that should not affect the behavior.

However, I am curious about what this is doing.

change the following line from
sText = sText.replace("\n", "");
to
sText = sText.replace(/\n/g, "");

As I read it, the original line replaces all line feeds in a text string with nothing, effectively removing all line feeds. in doing a search, I find that /\n/g is a RegEx for line feeds. Is this to make the replace function cross-platform? That is, it it designed to work on whatever platform the web server is using, even Windows servers.

Maybe I'll experiment with some of the other web-based outputs. But if this little code tweak didn't work, it's hard to be optimistic, especially as I'm using an older version of RH and can't update.

Amebr: Whatever software you're using for malware detection needs to have its signatures updated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

I think maybe you have applied Willam's fix. Read on in the thread and there is a link to Using RoboHelp 2017 on my site. There is a different fix there from Adobe. You'll need to backout Willam's fix.

I don't know if that will make a difference but worth a try.

Let me know how that goes.

IGNORE. See later post.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

If that doesn't make a difference, see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

I'll see if a later version makes a difference.

- If it does, then it could be a browser issue as there were issues as browsers upgraded.Generating a sample project as I suggested earlier would help with confirming that.

- If it doesn't then we could still be looking for something in your project but at least knowing that is where the issue is.

Post back when you have tried the Adobe fix and tried the samples.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

/g means replace all, not just the first, apparently.

JavaScript RegExp Object - Using Regular Expressions with Client Side Scripting

And my AV is corporate so not much I can do. I checked the provided link and it says the site can be submitted for reconsideration if it's a mistake - I'll try to remember when I'm home.  Maybe they just assume all .name sites are nefarious.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 28, 2018

Copy link to clipboard

Copied

Apologies for confusing the fix that Jeff referred to with another one.

Nonetheless, as it could be an issue with code from your version of RoboHelp not working with later browsers, the offer to generate from RoboHelp 2017 to see if it makes a difference remains open.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 28, 2018 0