How to fix double vertical scroll bar in responsive output

New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

After implementing the solution provided for the question 'Responsive HTML5 Output: How to auto adjust the screen resolution for all devices?', the function bar in output does not appear and also another vertical scroll bar in the output. I edited the max-width value in the layoutfix.min.css file and fixed the function bar issue. How can I do away with the additional vertical scroll bar?

TOPICS
HTML5 layout

Views

2.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to fix double vertical scroll bar in responsive output

New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

After implementing the solution provided for the question 'Responsive HTML5 Output: How to auto adjust the screen resolution for all devices?', the function bar in output does not appear and also another vertical scroll bar in the output. I edited the max-width value in the layoutfix.min.css file and fixed the function bar issue. How can I do away with the additional vertical scroll bar?

TOPICS
HTML5 layout

Views

2.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 21, 2015 0
LEGEND ,
Apr 23, 2015

Copy link to clipboard

Copied

Which RoboHelp version? (I need the patch number.) Make sure you update to 11.0.4.

Which layout is this happening? Can you post a screenshot? You are probably using an old version of the layout. If you update to 11.0.4, remove the current layout and add it from the gallery, it should be fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2015 0
Community Beginner ,
May 07, 2015

Copy link to clipboard

Copied

I'm having the same issue, and I am using the most recent version of the layout. My version is 11.0.4.291. The issue occurs in every browser I've tried. The real issue appears to be that Robohelp is putting a scrollbar on every topic, and when the topic exceeds the viewable window, it's adding a second scrollbar. The latter is functional. The former is not. Note that in both example images the extra scroll bar is the same length.

singlescroll.png   doublescroll.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2015 0
LEGEND ,
May 07, 2015

Copy link to clipboard

Copied

Which skin are you using? If we tweak the height here end ther we can remove the second scroll bar, but then I need to know the layout you're using.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2015 0
Community Beginner ,
May 07, 2015

Copy link to clipboard

Copied

Which responsive layout? I modified the black theme to display our product colors.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2015 0
Explorer ,
May 07, 2015

Copy link to clipboard

Copied

I have the same issue. Eagerly awaiting the solution! I'm on Windows 8 with RH 11. 0.4.291. I'm using Willam's free Responsive_Layout_TOC_only. (Which is lovely, BTW.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2015 0
LEGEND ,
May 13, 2015

Copy link to clipboard

Copied

I've looked into the issue.

@Delennish: In your case, the size of the iframe is too large, or you have an extra empty element below the iframe. You can try 2 things:

1. Best solution but may have side effects: In the main.css, add the following code:

div.contentholder { overflow: hidden !important;}

For this option, please check for undesired side effects.

2. Works, but is ugly: In the main.css, add the following code:

div.floatholder iframe.wTopic { height: 95% !important;}

Try playing with the height setting until the 2nd scrollbar disappears.

@CarolW: The layout you're using is very old. I've made a new responsive layout with TOC only. Please use that one instead: http://www.wvanweelden.eu/sites/default/files/attachments/Theme1_Standard_TOC_Only.zip (I'll update my site with this new version later.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2015 0
Community Beginner ,
May 14, 2015

Copy link to clipboard

Copied

I ended up replacing the theme with a back-up even though I hadn't changed anything since the backup. No more issue. I hate resolutions that don't result in an increase in knowledge.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2015 0