How to set up RH 11 so that it locates MS Word?

Explorer ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

After upgrading to TCS 5 the new RH 11 cannot find my installed MS Word applications. How do I tell RoboHelp where to look for them? The Adobe help did not give me a clue, since the information for editing the regedit are not up-to-date.

I'm no programmer, just a simple techwriter.

TIA

TOPICS
HTML

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

What version of MS Word are you using? See the FAQ link below for the supported versions:

http://www.adobe.com/uk/products/robohelp/faq.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

Actually both supported versions: 2010 and 2013.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

After reinstalling the TCS 5, there ist still no Word, according to RoboHelp. When I try to print a Captivate project, all works fine and Cp opens the DOC-file correctly in Word 2010.

So this is a Robohelp issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

Just to be clear, you have successfully installed TCS5 and RH did find your Word version. The problem is that once you try to do anything in RH using Word, it can't find it?

Try opening a word file in Word 2013, closing Word and try generating again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

Not quite. Robohelp cannot find Word (neither 2010 nor 2013), whereas Captivate can. Both running after successfully installing TCS 5.

I opened a word file in Word 2010, closed and started RH 11. It still cannot find Word (whichever version). Do I have to uninstall one version of Word so that there is no confusion?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

There could be an issue with the dual Word versions, although I am aware of people having multiple Word versions with earlier RH versions and having no real issues. When you installed TCS5 did it say it had found a supported Word version? If my memory isn't too shaky RoboHelp does this when installed standalone. Not sure about the TCS5 though. If it is the multiple Word versions and you uninstall one of them, I suspect a further reinstall of at least the RH component of the TCS would be required to pick the configuration change up.

I am hoping Peter Grainge can confirm this thinking. He will probably be online later. Can it wait until then?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

Thanks very much. Sure I can wait. I read something about editing the registry on his website, but I am running Windows 8.1, so the items he mentioned weren't there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

I saw that too and had thought of possible registry issues. I'll send Peter a quick email and hopefully he will pick it up later. As an old crinkly part timer these days he doesn't work on Fridays, but I'd be surprised if he doesn't give in to temptation at some point........

......especially when he reads what I've said about him

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

No respect from kids these days! I believe that in the UK the above qualifies as ageism so put your pennies aside.

There is no confirmation that Rh has picked up Word in either TCS or Rh that I have seen.

On a dual Word machine (2010 and 2013) that I used, Rh defaulted to Word 2010 but that's how double clicking a DOC file worked so no surprise there. With the standalone version of Rh, that also meant the PDF add-in did not work until I removed Word 2010. Then everything was fine. That's not quite how Word normally works with dual installations and I think it was in part because 2013 was a corporate subscription and 2010 was a perpetual licence. Not sure.

That's background rather than helping this problem. Nowadays, it does not matter in which order Rh and Word are installed so that's not it. Was Rh installed with admin rights? That is essential.

Also are your normal.dot files in your user profile on your local machine?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

Thanks for joining: I completely uninstalled TCS 5 and Word 2013. I even deleted those pesky files in the Adobe folder. Application Manager works now (it didn't do before) and the rest is fine and running. But RoboHelp cannot find Word. Still no difference. Now that I started editing the RH project I am working on, there is no way back to the TCS 4, I'm afraid.

I will try adding Word 2013 tomorrow and see if that helps. This thing turns out to get frustrating.

Now where should I keep my normal.dot file? It worked quite well with TCS 4 btw. So I kept a custom made *.dot file close to the project and generated the Word file from that. But I cannot access those settings because RH blocks me out. So I suspect it has got to do something with the RH settings or the registry.

And, yes, I am admin.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 25, 2014 Jan 25, 2014

Copy link to clipboard

Copied

UPDATE: I reinstalled Windows 8.1 from my virtual machine and updated it. Since TCS4 was installed already, I took the test and tried the exporting process to a printed documentation from RH 10. Evertything fine. PDF and Word were produced without hiccups.

Then I installed TCS 5 again. "Word is not found on this system."

So we have an issue with RH 11 here, I think.

Producing a review PDF is no problem, though. I hope Adobe gets this fixed within the next two weeks.

But this time I will keep TCS 4.

Updated by Thomas Böttiger

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 25, 2014 Jan 25, 2014

Copy link to clipboard

Copied

During beta testing I am not aware of anyone having problems with Rh finding Word and I at least had two versions of Word.

I really don't see Adobe fixing an issue only seen on one machine within two weeks, that sort of turnaround is when all users are unable to do anything.

Personally I would uninstall TCS (both) and Word (both), then install Word 2013 followed by TCS5.

Normal.dot should be within your user profile.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 25, 2014 Jan 25, 2014

Copy link to clipboard

Copied

Well I hope this only an issue for me.

But I will try when I got the time to uninstall and install (TCS 5 and both Word apps, as I need both)...

What amazes me is the fact that RH 10 runs fine and RH 11 does not. Same files, same machine, same configuration. As I stated in the beginning, I am just a techwriter and neither an IT expert nor a programmer. It's just one of those things that spoil the weekend.

😉

Thank you for your help and enthusiasm to assist me even on a Saturday.

Regards

UPDATE:

I did as Peter suggested. I uninstalled Word 2010 and Word 2013, both TCS 4 and TCS 5, then reinstalled Word 2010, reinstalled TCS 5 -- bur RH still cannot locate Word.

I found some tips on Peter's website (http://www.grainge.org/pages/authoring/printing/print_issues.htm#word_issues), but to no avail.

Updated by Thomas Böttiger

Update 2: removed some silly words. And added a sentence.

Further information: I installed a fresh virtual machine running Win 7, installed Word 2010, restartet, opened Word and closed it, installed Robohelp 11 from the TCS 5. Same result. RH 11 cannot find Word.

Updated by Thomas Böttiger

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

This is a normal Word installation with the Normal.dot template on your machine rather than a network drive? What operating system?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

Also, did you run Word after the reinstall? You must.

Please use the camera icon when you reply to add a screenshot of the error message.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

Yes, I ran the Word installation to check if everything's there. The Acrobat XI plugin performed as it should.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

The PDF addin cannot function unless it has found Word so I am completely mystified now.

If you select both PDF and Word, what happens?

If you select just Word, what happens?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

O sorry, that was a misunderstanding: After installing Word, I export some text as PDF to see if Word's plugin work.

The problem in RH11 is, that as soon as I click "Generate" or "Settings" in the layout pane to generate the option "printed documentation" (which I had configured a few months ago using RH 10, I get the message that Word cannot be found. The same click using RH 10 produces the settings window where I can select the output options (doc or pdf etc.)

When I set up a completely new project from one of the samples) and click on "printed documentation", the same message is displayed. I can however generate a Review PDF from RH 11.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

We have seen this problem in previous versions of Rh and it has required a fix from Adobe. I will alert them.

I doubt this will work but please try right clicking on the layout and selecting Properties. Does that work?

If not you contact Support and let us know what they say. Don't be beaten into accepting this is anything other than an installation issue, they are free.

Do let us know how what they say.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

I doubt this will work but please try right clicking on the layout and selecting Properties. Does that work?

No. That does not make any diference.

I will contact support. Thank you very much for your patience.

I will keep you informed.


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 11, 2014 Feb 11, 2014

Copy link to clipboard

Copied

Did Support manage to resolve this for you?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 11, 2014 Feb 11, 2014

Copy link to clipboard

Copied

Hello Peter,

No. We have been exchanging a few e-mails and they pointed to some damaged registry, but none of the solutions they offered solved the problem. Eventually, they gave me the old *.dll, which was supposed to work with RH 9.0.2, but this crashed RH altogether. I have mailed them today again but have not received an answer yet.

So we still have an open support ticket here...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 11, 2014 Feb 11, 2014

Copy link to clipboard

Copied

Post back if they don't get this resolved for you. In fact, also post back if they do and share the solution.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2014 Jan 27, 2014

Copy link to clipboard

Copied

A normal Word 2010 installation with a Normal.dot on a Windows 8.1 machine.

Word version corrected by Thomas Böttiger

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation