HTML Help Home Button - How to Edit Content

New Here ,
Aug 01, 2016

Copy link to clipboard

Copied

I'm using Robohelp 11 and we display our content as microsoft HTML help.  I am wondering how to edit the content of the home button on the top of the page next to the forward and back buttons.  Since it's HTML Help I cannot use a skin to change the buttons but I need to change what displays when the home button is clicked.  I can't find how to change where the button links to.  I would just like to link it to our home topic.

Thanks!

Matthew

TOPICS
HTML

Views

627

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

LEGEND , Aug 01, 2016
Captiv8r LEGEND , Aug 01, 2016
Hi thereOn the outside chance you aren't really wanting to tackle the "skin in a CHM" quite yet, try this.First, note the path and filename of the file you want to present when the user clicks the Home link.Open the Project Setup pod. (View > Pods > Project Setup)Then expand the Windows section and double-click the CHM window. (If you don't see a CHM window, you may need to create one)From the Window Properties click the Advanced Properties button.And from the Advanced Properties dialog, you typ...

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Aug 01, 2016

Copy link to clipboard

Copied

You can use a skin! RoboHelp 10 introduced a script that converts webhelp to a CHM. See the RoboHelp Tour on my site and look at RoboHelp 10 New Features.

By using that you also get a few webhelp features that will work in the CHM.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 06, 2016

Copy link to clipboard

Copied

Thanks for the help Peter!  For now I would like an easy fix without having to set up a whole skin.  Could come in handy in the future though.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 01, 2016

Copy link to clipboard

Copied

Hi there

On the outside chance you aren't really wanting to tackle the "skin in a CHM" quite yet, try this.

First, note the path and filename of the file you want to present when the user clicks the Home link.

Open the Project Setup pod. (View > Pods > Project Setup)

Then expand the Windows section and double-click the CHM window. (If you don't see a CHM window, you may need to create one)

tmp4.png

From the Window Properties click the Advanced Properties button.

tmp3.png

And from the Advanced Properties dialog, you type (yes, you heard that right, TYPE) the path and file name of the desired file. (Remember that first step?) Note that you can also type a URL pointing to a web site here.

tmp2.png

Hopefully this helps... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 06, 2016

Copy link to clipboard

Copied

Hi Rick,

Thanks for the help.  That is what I was looking for but couldn't find where it was.  It looks like the topic I want as a home talk already was entered in that window but it's not displaying correctly when the home button is clicked.  Do yout think it could be because the topic is the very first topic in my TOC and not in a subfolder while all other topics are in subfolders?

Thanks,

Matthew

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 06, 2016

Copy link to clipboard

Copied

Hi Matthew

Not displaying at all or not displaying correctly? Can you share a screen capture of what you are seeing?

Thanks... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 08, 2016

Copy link to clipboard

Copied

Hi Rick,

I'm just seeing the typical 'This Page Cannot Be Displayed" message.

Hi Rick,

I'm just seeing the typical 'This Page Cannot Be Displayed" message.

Thanks for the continued help!

Matthew

Thanks for the continued help!

Matthew

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 08, 2016

Copy link to clipboard

Copied

Hmmm, so if you would be so kind as to indulge me, share a screen capture of your project manager with the desired Home topic highlighted. If it's inside a folder, I'll want to see the folder name(s) too.

And show me a screen capture of the dialog where you configure the Home button.

With those two bits of information I believe we can solve the issue!

Cheers... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 11, 2016

Copy link to clipboard

Copied

Did you give up on us?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 11, 2016

Copy link to clipboard

Copied

Hi Rick,

I've just been busy working on other things.  The requested screen shots are below.  Thanks for the continued help on this!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 11, 2016

Copy link to clipboard

Copied

Appreciate the info.

One more bit of information please. Right-click that Home item you have highlighted in the first screen and choose Properties. I'd like to see what the General tab shows.

Thanks... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 15, 2016

Copy link to clipboard

Copied

Hi Rick,

Here is the requested properties window.  I really appreciate all the help!

Matt

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 15, 2016

Copy link to clipboard

Copied

Hmmm, wasn't really the dialog I was hoping to see but I think it will provide what I need,

So, I'm noticing the file you are linking to seems to have a period following the 1 and I'm wondering if the compiler is gagging on it or if it's causing the issue after compiling.

I might suggest that you try right-clicking the topic in the Project Manager pod and renaming this topic so you either totally remove the period and leave behind a file with the name of 1ONLINEHELP.html or replace it with an underscore so it would end up being 1_ONLINEHELP.html.

I don't believe that RoboHelp will auto-adjust the home button properties to match so whatever you end up with should reflect what you renamed it to.

Give that a go and let us know what the outcome was!

Cheers... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 15, 2016

Copy link to clipboard

Copied

Actually, I was doing some testing on my end. Seems that the .html file extension makes things go haywire on my end. So try renaming the page so it ends in .HTM instead of .HTML. Then amend the field where you configure the home button link and recompile.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 16, 2016

Copy link to clipboard

Copied

Hi Rick,

I've done what you said.  It may be a while before we get around to testing it.  I'll keep you posted an update the post once I know if the html extension is what was causing the problem.

Thanks for everything!

Matthew

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 29, 2016

Copy link to clipboard

Copied

Curious if this solved your issue?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 04, 2016

Copy link to clipboard

Copied

I actually just did at the end of last week.  All of your suggestions, which were great, didn't solve the issue so I put it on the backburner for a while.  Then when I came back to it, I noticed on one of the 4 versions (we have 4 different versions of our software) the home button worked.  Then I found that the home topic actually had a conditional tag on it for the one version that worked.  For some reason the conditional tag only appeared on the topic under project manager and not under the TOC.  Normally all our conditional tags are in the TOC, so I'm not sure why there was a conditional tag in the project manager in this case. 

Thanks for all the help, and sorry to waste your time with something as simple as a conditional tag.  I inherited this project recently and I'm just starting to wrap my head around it.  It has over 6,000 topics so it's pretty large and a bit messy. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Oct 04, 2016

Copy link to clipboard

Copied

Not a problem at all. However, it is rather curious about the tagging. If anything, I would have expected to see the opposite. Having a tag on something actually CAUSING the issue. LOL

Hey ho - Glad it's working!

Cheers... Rick

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
technicald20774695 AUTHOR LATEST
New Here ,
Oct 04, 2016

Copy link to clipboard

Copied

The tag was the issue becuase the home topic was only for that version.  That's why the home button didn't work on any of the other versions, including the one I was testing.  I removed the tag, making the topic available to all versions, and the home button now works regardless of the version.  Thanks again for all the help!

Matthew

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more