HTML5 Responsive Layout - Output URL includes '%2F' in the path. Why?

Community Beginner ,
Sep 11, 2015

Copy link to clipboard

Copied

Hi,

I'm using RH2015.

I have generated a responsive layout in both a single project and a merged project and in the generated output the path is being written as per.....

index.htm#t=mergedProjects%2F10act%2Fact%2Fact_rl5.htm

Why in the URL path is '%2F' being added?

This is what I would expect to be in the path:

index.htm#t=mergedProjects/10act/act/act_rl5/act_rl5.htm

If I change it to this manually the topic displays correctly but if I click to another topic then back the path reverts back to having '%2F' in the path.

Anyone know why this is happening?

Because %2f is the HTML Entity for the slash character?

Click here for more

Cheers... Rick

TOPICS
HTML5 layout

Views

198

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

HTML5 Responsive Layout - Output URL includes '%2F' in the path. Why?

Community Beginner ,
Sep 11, 2015

Copy link to clipboard

Copied

Hi,

I'm using RH2015.

I have generated a responsive layout in both a single project and a merged project and in the generated output the path is being written as per.....

index.htm#t=mergedProjects%2F10act%2Fact%2Fact_rl5.htm

Why in the URL path is '%2F' being added?

This is what I would expect to be in the path:

index.htm#t=mergedProjects/10act/act/act_rl5/act_rl5.htm

If I change it to this manually the topic displays correctly but if I click to another topic then back the path reverts back to having '%2F' in the path.

Anyone know why this is happening?

Because %2f is the HTML Entity for the slash character?

Click here for more

Cheers... Rick

TOPICS
HTML5 layout

Views

199

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 11, 2015 0
LEGEND ,
Sep 11, 2015

Copy link to clipboard

Copied

Because %2f is the HTML Entity for the slash character?

Click here for more

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2015 0
Community Beginner ,
Sep 14, 2015

Copy link to clipboard

Copied

OK thanks. Do you know if this is something to do with HTML5 as previous outputs (webhelp) created in RH10 did not display this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2015 0
Captiv8r LATEST
LEGEND ,
Sep 14, 2015

Copy link to clipboard

Copied

Hello again

No, I'm very doubtful it's related to the HTML5. But it could be related to a change in the way the RoboHelp development team creates the output. I would expect the same to occur in nearly any of the web based outputs.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2015 0