Highlighted

IE11 renders a blank webhelp popup window(doesn't happen on first instance but from thereon) Version: Robohelp 2015 Trail.

New Here ,
Aug 28, 2015

Copy link to clipboard

Copied

HI

I am using trail version of robohelp2015, I have few issues when i open webhelp popups from the links in webpage in IE. It works fine in Chrome.

I click on help in on page, which opens a webhelp popup window. i don't close the popup and go to next page in my test website on now again click on help. Now it refreshes the webhelp popup with blank window in IE11.

Help would be appreciated.

The page is entirely blank without skin

d1.png

The script i am using to open webhelp:

<A HREF='javascript:RH_ShowHelp(0, "helpfiles/index.htm>>Mainwindow",  HH_HELP_CONTEXT, 2564462)' style="text-decoration:none;">?</A>

Also as i am quite new to robohelp, just wondering where should i change if I want my webhelp window on top whenever someone clicks help.  Do i need to change in Robohelp_csh,js file or any other file.

Thanks

Hi Prajwal,

Sorry for the delay in response. The fix is still with our testing team.

But, I shall be able to give you a private copy of the fix within 48 hours.

Regards,

Ankit

Topics

Classic

Views

3.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

IE11 renders a blank webhelp popup window(doesn't happen on first instance but from thereon) Version: Robohelp 2015 Trail.

New Here ,
Aug 28, 2015

Copy link to clipboard

Copied

HI

I am using trail version of robohelp2015, I have few issues when i open webhelp popups from the links in webpage in IE. It works fine in Chrome.

I click on help in on page, which opens a webhelp popup window. i don't close the popup and go to next page in my test website on now again click on help. Now it refreshes the webhelp popup with blank window in IE11.

Help would be appreciated.

The page is entirely blank without skin

d1.png

The script i am using to open webhelp:

<A HREF='javascript:RH_ShowHelp(0, "helpfiles/index.htm>>Mainwindow",  HH_HELP_CONTEXT, 2564462)' style="text-decoration:none;">?</A>

Also as i am quite new to robohelp, just wondering where should i change if I want my webhelp window on top whenever someone clicks help.  Do i need to change in Robohelp_csh,js file or any other file.

Thanks

Hi Prajwal,

Sorry for the delay in response. The fix is still with our testing team.

But, I shall be able to give you a private copy of the fix within 48 hours.

Regards,

Ankit

Topics

Classic

Views

3.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Aug 30, 2015

Copy link to clipboard

Copied

Hello,

Seems like the anchor tag has a typo. There should be only one '>' character for specifying the window name.

Try changing the anchor tag to this: <A HREF='javascript:RH_ShowHelp(0, "helpfiles/index.htm>Mainwindow",  HH_HELP_CONTEXT, 2564462)' style="text-decoration:none;">?</A>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 31, 2015

Copy link to clipboard

Copied

Anchor with '>>' instead of '>' makes the window more or like popup window. A '>' opens it as new tab.

There should be issue with Robohelp_csh.js script file and its functions.

I think its issue with this piece of code:

if(oDivCon)

  {

  if(gbNav6)

  {

  if(oDivCon.getElementsByTagName&&oDivCon.getElementsByTagName("iFrame").length>0)

oDivCon.getElementsByTagName("iFrame")[0].src=sFileName;

  else

  oDivCon.innerHTML=sHTML;

  }

  else

  oDivCon.innerHTML=sHTML;

  }

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 01, 2015

Copy link to clipboard

Copied

Hi PY563,

Have you previously seen the '>>' working in webhelp CSH output?

If yes, with which RoboHelp version?

Please also specify the version of IE you are using.

Regards,

Ankit Rajpoot

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 01, 2015

Copy link to clipboard

Copied

Hi Ankit,

If i inferred the question ambiguously, just clarifying  that '>>' not giving any sort of problem because i did also tested with '>' before posting the original question there would be same issue.

I was using RoboHelp 2015 trail version and It was on Internet Explorer 11. I did mention both in the question.

1.png

As of Robohelp_csh.js it states on top the below lines..

// Adobe

// Copyright© 1998-2008 Adobe Systems Incorporated. All rights reserved.

// RoboHelp_CSH.js

Hope the information i provided was helpful.

-------------------------------------------------------------------------------------------------------------------------

Update: when i checked the debugger Console in IE11 shows access denied error in whcsh_home.htm line 295

function postWindowNSOpen()

{

  if(goNewWnd)

  {

  if (gsURL)

  goNewWnd.document.location.href=gsURL;  //error

  window.close();

  goNewWnd.focus();

  top.blur();

  }

}

and for focus issue in chrome the developer tools shows Uncaught type error in  whcsh_home.htm line 234

if(gbNav4 || gbSafari)

  {

  if (gbNav6)

  {

  gsURL = sURL;

  goNewWnd=window.open("about:blank",sNewName,strOpt);

  setTimeout("postWindowNSOpen();",100);

  }

  else

  {

  window.open("about:blank",sNewName,strOpt);

  var oNewWnd=window.open(sURL,sNewName);

  window.close();

oNewWnd.focus(); //chrome error

  top.blur();

  }

  }

Thanks

Prajwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 01, 2015

Copy link to clipboard

Copied

Hi Prajwal,

Can your share your project with me over dropbox. My email address is rajpoot(at)adobe(dot)com

Thanks,

Ankit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 01, 2015

Copy link to clipboard

Copied

If it's not possible for you to share the complete project, can you zip and share the WebHelp output that is causing problems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 02, 2015

Copy link to clipboard

Copied

i don't use dropbox i can send you a zip file to email.

IE11 doesn't flag the gbIE5 variable used in Robohelp_csh.js file but it flags off gbNAV6 variable as navigator.appName() for IE11 returns netscape but not microsoft or msie unlike others.

As per my knowledge if in postWindowNSOpen() 'NS' stands for Netscape IE11 should supposed to go to that method only ( infact it should not goto peice of code where method is called).

Check the code in below files: <they may cause of error>

whcsh_home.htm between lines 217-250 and Robohelp_CSH.js between lines 119-160.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 02, 2015

Copy link to clipboard

Copied

ZIP via email might not be feasible if the size is above more than a few megabytes.

If not dropbox, can you share the files over gdrive/onedrive or any other cloud file storage?

I would need to look at the actual output before I can make any comment on the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 02, 2015

Copy link to clipboard

Copied

its more or less 2mb so it wouldn't be any issues. i am just sending a test file with Web-help output with sample text.

You see the below locked thread in mean time for the error msgs in IE11 and Chrome <No focus error> when i debug the script:

Re: IE11 renders a blank webhelp popup window(doesn't happen on first instance but from thereon) Ver...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 03, 2015

Copy link to clipboard

Copied

Hi Prajwal,

I have not received any email.

Please make sure you send it to rajpoot(at)adobe(dot)com.

Thanks,

Ankit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 03, 2015

Copy link to clipboard

Copied

Did you check your spam folder, i sent it with my work email address which is hosted on a private server.

I sent it again.

I do see flags for IE11 being set in whver.js file netscape flags are also set for IE11 in the same file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 03, 2015

Copy link to clipboard

Copied

wetransfer.com works better than attachments. It's free and no

registration. I use it regularly to send stuff like this.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 03, 2015

Copy link to clipboard

Copied

i will resend him with my personal email if he doesnt get it this time around. But i think i solved the blank page for IE11 issue. I need make sure once again checking with Microsoft Edge.

But Still the focus on help window issue is still pending on chrome and firefox.

I would be happy to give the piece of edited code where i made changes. It was test project for company to see if robohelp was feasible for the original project.

Thanks

Prajwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 09, 2015

Copy link to clipboard

Copied

Hi Prajwal,

I did not received any email.

Have you completely resolved the issue on your own, or still need help?

Thanks,

Ankit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 09, 2015

Copy link to clipboard

Copied

sorry for the inconvenience here is the google drive link as you open it please delete the comment:

browserRoboHelpTest1.zip - Google Drive

I also sent again email from personal email address.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 09, 2015

Copy link to clipboard

Copied

i have solved a part of problem of displaying blank pages second time around in different browsers, but not the focusing issue: which happens in different browsers when user clicks help option second time around there is no focus on help window (if it is opened before) after loading the data. End user doesn't know whether page is refreshed or not in anyway unless he opens help window.

once you check the files i just gave you in chrome or Firefox you will exactly get an idea of what i am saying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 14, 2015

Copy link to clipboard

Copied

Hi Peter

Could you also please look into the issue, it is simple as of now. As i solved blank pages problem and only focus issue remains.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 17, 2015

Copy link to clipboard

Copied

Prajwal,

Sorry for the delay in response.

I am currently looking into it. But it is going to take some more time.

I appreciate your patience.

Ankit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 18, 2015

Copy link to clipboard

Copied

thanks for the update Ankit. The only issue remaining is web-help window is not focused second time around which I mentioned in second response on top of thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 22, 2015

Copy link to clipboard

Copied

I have the same problem. How can I solve it? What kind of update was used by PY563?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 22, 2015

Copy link to clipboard

Copied

Hi Peter,

what problem your are having: the blank screen or focusing issue on webhelp window.

I didnt get a update in a sense like code patch or something, I was just thanking Ankit for the reply.

But i did solve the Blank window/Screen issue. I can help you with that..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 23, 2015

Copy link to clipboard

Copied

Hi Prajwal,

I have the problem "blank window" and I'm looking forward to your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 23, 2015

Copy link to clipboard

Copied

Hi Prajwal, Peter,

We have fixed the issue and it is currently under testing.

We will publish it soon.

Thanks,

Ankit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 23, 2015

Copy link to clipboard

Copied

Peter

For Blank window, You can download the code i shared here in previous comments and once compare it with your robohelp generated files and replace them with changed files. Or you can just ignore my html pages and used the remaining files.

Let me know if you have any further complications.

Thanks

Prajwal

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Ankit,

Thanks for the help and fixing the issue.

Here in Communities Profile Can't i change my first name and last name, i dont remember giving those details, may be it picked them up from gmail. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 24, 2015

Copy link to clipboard

Copied

Prajwal,

thanks for your help. It solves the problem when I open help from one HTML page.

But my application has different pages using frames. Opening help from different pages / frames still shows window with blank page or even window with blank and new tab.

I have to debug the application and understand the procedure RoboHelp opens and fills new windows. If I'm going to find a solution, I'll post it here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 24, 2015

Copy link to clipboard

Copied

Peter

if u want to debug you could start checking files whcsh_home.htm and whver.js files, i think i forgot to comment few alert boxes you could do that. And also in my test.html page in that code, you can find other ways to call help you could try them as well.

if possible try to share a dummy html page from where you are calling help with my code and mapID's. I will look around it after leaving work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 01, 2015

Copy link to clipboard

Copied

Hi Ankit

How  are u doing?

When can we expect the patch or update?

Thanks

Prajwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 02, 2015

Copy link to clipboard

Copied

i sent you email.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 03, 2015

Copy link to clipboard

Copied

Thanks for the help I think i solved it. But it exists in new Microsoft Edge Browser

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 14, 2015

Copy link to clipboard

Copied

Ankit RajpootWebHelpRoboHelp‌ Hi Ankit,

I hope you got a chance to look into the script shared. If so please try to get back, so that i can update my employer.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...