IE11 renders a blank webhelp popup window(doesn't happen on first instance but from thereon) Version: Robohelp 2015 Trail.

New Here ,
Aug 28, 2015 Aug 28, 2015

Copy link to clipboard

Copied

HI

I am using trail version of robohelp2015, I have few issues when i open webhelp popups from the links in webpage in IE. It works fine in Chrome.

I click on help in on page, which opens a webhelp popup window. i don't close the popup and go to next page in my test website on now again click on help. Now it refreshes the webhelp popup with blank window in IE11.

Help would be appreciated.

The page is entirely blank without skin

d1.png

The script i am using to open webhelp:

<A HREF='javascript:RH_ShowHelp(0, "helpfiles/index.htm>>Mainwindow",  HH_HELP_CONTEXT, 2564462)' style="text-decoration:none;">?</A>

Also as i am quite new to robohelp, just wondering where should i change if I want my webhelp window on top whenever someone clicks help.  Do i need to change in Robohelp_csh,js file or any other file.

Thanks

TOPICS
Classic

Views

3.9K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Oct 05, 2015 Oct 05, 2015
Hi Prajwal,Sorry for the delay in response. The fix is still with our testing team.But, I shall be able to give you a private copy of the fix within 48 hours.Regards,Ankit

Likes

translate

Translate

Translate
Adobe Employee ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

Hi Prajwal,

Sorry for the delay in response. The fix is still with our testing team.

But, I shall be able to give you a private copy of the fix within 48 hours.

Regards,

Ankit

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2015 Oct 05, 2015

Copy link to clipboard

Copied

Thanks Ankit.

Let me know if you need my email address.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 06, 2015 Oct 06, 2015

Copy link to clipboard

Copied

Hi Prajwal,

Please provide your email address so I can give you the fix. For this, you can send me a private message with your email address.

We will also be including the fix in the next patch for RoboHelp.

Regards,

Ankit

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2015 Oct 06, 2015

Copy link to clipboard

Copied

I did message you, Thanks for all the help.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2016 Apr 15, 2016

Copy link to clipboard

Copied

Hi Ankit,

I have bought RH 2015 recently (couple of weeks back) and also applied the Alril 12, 2016 patch as well.

I am still facing the same issue. Is this issue resolved now?

It will be great if you can provide some lead in this.

Regards,

Prashant

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 23, 2015 Sep 23, 2015

Copy link to clipboard

Copied

Peter

For Blank window, You can download the code i shared here in previous comments and once compare it with your robohelp generated files and replace them with changed files. Or you can just ignore my html pages and used the remaining files.

Let me know if you have any further complications.

Thanks

Prajwal

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Ankit,

Thanks for the help and fixing the issue.

Here in Communities Profile Can't i change my first name and last name, i dont remember giving those details, may be it picked them up from gmail. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Sep 24, 2015 Sep 24, 2015

Copy link to clipboard

Copied

Prajwal,

thanks for your help. It solves the problem when I open help from one HTML page.

But my application has different pages using frames. Opening help from different pages / frames still shows window with blank page or even window with blank and new tab.

I have to debug the application and understand the procedure RoboHelp opens and fills new windows. If I'm going to find a solution, I'll post it here.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 24, 2015 Sep 24, 2015

Copy link to clipboard

Copied

Peter

if u want to debug you could start checking files whcsh_home.htm and whver.js files, i think i forgot to comment few alert boxes you could do that. And also in my test.html page in that code, you can find other ways to call help you could try them as well.

if possible try to share a dummy html page from where you are calling help with my code and mapID's. I will look around it after leaving work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2015 Sep 02, 2015

Copy link to clipboard

Copied

i sent you email.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 03, 2015 Sep 03, 2015

Copy link to clipboard

Copied

Thanks for the help I think i solved it. But it exists in new Microsoft Edge Browser

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2015 Sep 14, 2015

Copy link to clipboard

Copied

Ankit RajpootWebHelpRoboHelp‌ Hi Ankit,

I hope you got a chance to look into the script shared. If so please try to get back, so that i can update my employer.

Thanks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation