Import Xliff - invalid folder

Community Beginner ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

Hi there, 

I'm using Robohelp 2020.  I managed to export some of my topics into Xliff to send to our translation agency.  Now the translated files are back (still xliff) and I want to import them. 

1) I go to the master project > Translations > select the sub-project.  The topics list opens.

2) I click on the icon to import xliff.  The file browser opens.

3) I want to select the xliff files, but cannot do it as the .xlf format is not listed. (why not?)

4) I select the folder where my xliff files are, and then I received the following message: 

Invalid folder.  Please select a valid language folder. 

 

I'm afraid I don't understand that message.  What does it mean?   What do you mean by language folder?

What do I have to do?

Thank you for your help.

Best regards, 

Views

152

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Jan 28, 2021 Jan 28, 2021
Hi,  Make sure the .mpf file which gets generated during export, is present in the folder that contains translated XLIFF files. Do not change anything that is in that file, simply copy-paste it. 

Likes

Translate

Translate
Adobe Employee ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

2) I click on the icon to import xliff.  The file browser opens.

What opens, is the "Select Folder" dialog. You select the folder in which the translated XLIFF files are located. 

 

3) I want to select the xliff files, but cannot do it as the .xlf format is not listed. (why not?)

See above. Because you just select the folder. Not indivdual files.

 

How is the folder named where the translated files are?

And do the translated files match the language of the language you are doing the import for?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

It looks like you don't need to select the files as the button says "Select Folder". I think RH automatically picks up all files in the selected folder. (It's very disconcerting and unexpected behaviour, for a user, in my opinion.)

 

Disclaimer: I haven't done any translations, so everything following is based on faking things without knowing what I'm doing.

 

I'm not sure about the error mesage, however a quick fake test displays the message if the folder I browse to doesn't include  an mpf file - which might be a specific robohelp file so that RH knows which files to import? Perhaps the mpf needs to be sent with the xlf files and returned without being translated? Or copied into the folder with the translated file?  I'm really not sure on this point though and the help doesn't mention where the translated files should be before importing, or any requirements for the import to work.

https://helpx.adobe.com/robohelp/user-guide.html/robohelp/using/translation.ug.html

 

You might be best contacting Adobe directly before trying anything as I'm not sure of the implications. See here for your contact options:

https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

@Stefan-Gentz Does the .mpf file need to be in the same directory? I can reproduce the error message if I copy one of the exported .xlf files to a new directory without the .mpf file, and try to import it. I haven't actually translated anything, just copied the file and pretended it was a new file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Hi, 
Make sure the .mpf file which gets generated during export, is present in the folder that contains translated XLIFF files. Do not change anything that is in that file, simply copy-paste it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

LATEST

Hi, 

Yep, correct.  That was my mistake. I didn't realise the importance of that mapper file (.mapperFile.mpf).   I've done as you suggested and I got no more error message.   

Thank you very much. 

Thank you all for your time and dedication

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation