Highlighted

Importing Table Styles in Robohelp 2019

New Here ,
Jul 20, 2019

Copy link to clipboard

Copied

Hi,

I am importing content from FrameMaker 2019 to Robohelp 2019.   The content is in tables with the first column shaded in dark grey backgaround and the second column in white.  The content is imported almost neatly, similar to my FrameMaker document.  However, in the ouput, the tables do not display, and the text in them is scattered.   Especialy, in webhelp and responsive HTML.  Please help!

Topics

FrameMaker integration, New UI

Views

777

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Importing Table Styles in Robohelp 2019

New Here ,
Jul 20, 2019

Copy link to clipboard

Copied

Hi,

I am importing content from FrameMaker 2019 to Robohelp 2019.   The content is in tables with the first column shaded in dark grey backgaround and the second column in white.  The content is imported almost neatly, similar to my FrameMaker document.  However, in the ouput, the tables do not display, and the text in them is scattered.   Especialy, in webhelp and responsive HTML.  Please help!

Topics

FrameMaker integration, New UI

Views

778

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 25, 2019

Copy link to clipboard

Copied

Thread moved to FrameMaker Integration.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 25, 2019

Copy link to clipboard

Copied

You doing this import in RH2019 Classic or with the new style version? I'd be inclined to have a look at the resulting HTML code in your RH topic and then see how it appears in your output's HTML. That might give you some clues as to where it's going sideways.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

Hi Jeff,

Thanks for your reply.  I'm using the new Robohelp version.  I've attached a screenshot of the source code from the webpage. Is this what you are looking for ?Code1.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

That appears to be the output from your browser - what's it look like in the RH project's topic?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

After importing to Robohelp, this is how it looks.  All styles are imported correctly.ImportedVersion.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

OK, now what's that table took like when you flip the view to look at the RH code view?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

Hopefully, this is what you are looking for ImportedVersion.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

Please check the code view. RHCodeview.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

As a test, try creating a new project in RH2019 Classic and do your import - see how that works. You're all up to date with the latest releases of RH2019 right?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

I'l try Classic.  Robohelp is up to date (14.0.8).  Hopefully it helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 25, 2019

Copy link to clipboard

Copied

Can you post a snip of the resulting code? (may need to be a screenshot...)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

Hi Matt,

Thanks for you reply.  I've attached the source code.  If you are looking for something else, please direct me on how to get you what you want.Code2.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

Yep, that's what I expected to see...

Note that your p elements are formatted with class=FM_TagName, where TagName is the FrameMaker paragraph style.

Use the Style Mapping in the Publish settings to map Fm styles to things in your CSS (and create new styles if the existing ones don't suffice)

Also, map your Table style to a CSS style, or create a new style in the CSS to map to.

This should solve your problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

@Matt wouldn't you have to have those FM_xxxx styles all defined in your CSS anyway?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

It's a longer discussion, but because the styles are automatically written (and rewritten, and rewritten) upon import, I NEVER use them in my output.

Your mileage may vary, but writing online format based on print specs from Fm is frustrating for me.

But by now you know my preference for outputting help from Fm directly, including CSH.

Having said that, I did acquiesce to one client's requirements and set up a FrameMaker template for conversion that allowed them to use Fm to manage their online formatting. It worked, but it felt tenuous.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

Oh, and the FM_TagName entries are in a series of secondary CSS files, attached to the individual topics.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

I would get around that by using a "apply to all" CSS when generating - there was a bug starting around RH11 that caused the output HTML in the topics to have 2 lines of CSS references in the wrong order, but a quick delete of all the topic-level CSS files would quickly fix that one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 02, 2019

Copy link to clipboard

Copied

The problem is that you'll have to do that each time you update. Best to map the styles one time and use the single CSS to control.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...