Highlighted

In RH2019 New UI, issue with importing a project and then not being able to resolve to the css file

Explorer ,
May 05, 2020

Copy link to clipboard

Copied

I imported a project into another project. In the imported project, when specifying the css file, I had selected local files and selected the css that way. So when I imported the project to an existing project, even though the file structure was the same, because I had selected local files for the imported project I had to go through and configure each topic to use the css file in my existing project. If I had selected project files in the imported project, would this have just worked on import, if the file structure is exactly the same?

 

So I went through the topics in my imported project and selected project files and selected the css in my exisiting project. However, the explorer dialog opened and not the internal RH dialog that allows you to select the css file from within the project.

 

Now though, I cannot generate any word output. PDF and Responsive HTML work fine. When I checked the c:\users\username\appdata\local\temp\rhtmp\word folder, I can see that the output is failing at this imported project, so it is obviously failing to resolve the css. 

 

Do you know how I can fix this? I was thinking maybe in the imported topics try selecting local file and selecting the path to the css in my existing project that way. However, I could generate word output when the imported topics were pointing to the local css file in the original project. So maybe I need to go back to the css file in the original project? 

 

I tried creating a new word preset but it failed. I can generate word output from other projects. 

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

Forget the above.

 

By comparing the original file with the copy, I have found the root cause. If you look at your version of the topics below in source view, you will see this line.

 

<td style=""><strong></strong></td>

 

Alarm Activity Grid

Manual Alarm Type Combo Box

Suppressed Event Grid

 

Change it as below and the Word document generates.

 

<td style=""></td>

 

Views

523

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

In RH2019 New UI, issue with importing a project and then not being able to resolve to the css file

Explorer ,
May 05, 2020

Copy link to clipboard

Copied

I imported a project into another project. In the imported project, when specifying the css file, I had selected local files and selected the css that way. So when I imported the project to an existing project, even though the file structure was the same, because I had selected local files for the imported project I had to go through and configure each topic to use the css file in my existing project. If I had selected project files in the imported project, would this have just worked on import, if the file structure is exactly the same?

 

So I went through the topics in my imported project and selected project files and selected the css in my exisiting project. However, the explorer dialog opened and not the internal RH dialog that allows you to select the css file from within the project.

 

Now though, I cannot generate any word output. PDF and Responsive HTML work fine. When I checked the c:\users\username\appdata\local\temp\rhtmp\word folder, I can see that the output is failing at this imported project, so it is obviously failing to resolve the css. 

 

Do you know how I can fix this? I was thinking maybe in the imported topics try selecting local file and selecting the path to the css in my existing project that way. However, I could generate word output when the imported topics were pointing to the local css file in the original project. So maybe I need to go back to the css file in the original project? 

 

I tried creating a new word preset but it failed. I can generate word output from other projects. 

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

Forget the above.

 

By comparing the original file with the copy, I have found the root cause. If you look at your version of the topics below in source view, you will see this line.

 

<td style=""><strong></strong></td>

 

Alarm Activity Grid

Manual Alarm Type Combo Box

Suppressed Event Grid

 

Change it as below and the Word document generates.

 

<td style=""></td>

 

Views

524

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 05, 2020

Copy link to clipboard

Copied

Open the Topic List Report and change the columns so that you can easily see Stylesheets. Do all the topics show the correct CSS in the combined project? That will rule out issues there or allow you fix them. Select any topics that are not correct, right click and then apply the required CSS.

 

Try again after that and post back.

 

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 05, 2020

Copy link to clipboard

Copied

Yes it is all correct in the topic list. I have dug a bit deeper and found these errors in the word document. ehtml 

 

Validation error count=1
Converting About_Alarm_Management.htm
Error 1
Description: Attribute 'http://schemas.openxmlformats.org/wordprocessingml/2006/main:styleId' should have unique value. Its current value 'Code' duplicates with others.
ErrorType: Semantic
Node: DocumentFormat.OpenXml.Wordprocessing.Style
Path: /w:styles[1]/w:style[23]
Part: /word/styles.xml

 

I am getting these errors for all the topics in the imported project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 05, 2020

Copy link to clipboard

Copied

Your project should contain default.css which is what ships. Is that as supplied? If not create a new project to get a clean copy. Add it to your project, renaming if need be.

 

In the Topic List select all topics, right click and apply that css to all topics. Then generate again.

 

What I am hoping is that the document will then generate, albeit looking rubbish. Then we know with a bit more certainty that the issue is in your CSS. At that point, we can start checking things out.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 05, 2020

Copy link to clipboard

Copied

Generating with a default css did not work. Also something strange, if I go to the topic list report, none of my topics are listed there. Only two, homepagefooterdark.htm and topicfooterdark.htm? So I just copied over the default.css to the folder instead. I also tried one that I know works but that failed as well. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 05, 2020

Copy link to clipboard

Copied

Something else to try. Recently someone had an issue with their PDF generation failing. The cause was their CSS contained em space definitions. I know you are generating to Word but I wonder if it could be the same issue?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 05, 2020

Copy link to clipboard

Copied

Even though your topic list may show no filters applied, select one and see if anything shows then.

 

See https://community.adobe.com/t5/robohelp/topic-list-blank/m-p/11105933#M130339.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 06, 2020

Copy link to clipboard

Copied

I just tried deleting the TOC entries for my imported project and was able to generate the word output. At least I have a sort of work around now in that I can just generate output for the imported project separately and just copy and paste them to the same word document. I perhaps could try the import again.  The steps I followed were:

 

  1. In explorer, created a folder in the project for the files I wanted to import 
  2. In explorer, copied the project files I wanted to import to the project I wanted to import the files to.
  3. In RH, created a folder for those files and then right clicked my main project and selected Import > Folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 06, 2020

Copy link to clipboard

Copied

In 2019 you added the files from one project into another. That's OK as long as you added them to the equivalent place. It's just a copy and paste. Once there they are part of the project. You need to fix things like variables and so on. I am not getting why you then imported. This sounds like you were doing it the way the Classic versions would have needed. 2019 New UI is very different. It also sounds like you have duplicated things.

 

See http://www.grainge.org/pages/authoring/opening/opening_projects.htm and scroll down to the line One way of dealing with a problem project when all other avenues have been exhausted is to create a new project and start rebuilding it by copy parts of the old project bit by bit. It's just above the heading Glossary.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 06, 2020

Copy link to clipboard

Copied

Thank you for that link Peter. When I go to c:\users\username\appdata\local\temp\rhtmp\worddocument and look in the _doc folder, I can see that some of the files have been converted and some havent:

image.png

Its not because the file names are too long? Also the project is using default.css and there seems to be another css called about_alarm_management.css. 

Also, I think you right and I didnt import correctly. I may just remove those files and try and import the again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 07, 2020

Copy link to clipboard

Copied

I am identifying the problem files but I am finding the only way to fix the issue create new topics and type the content in. Even copying and pasting a couple of paragraphs caused the whole project to stop generating word output again. 

When I look at the source, it looks fine, nothing in there that can be causing a problem.  There must be some corruption somewhere but I cant work out what it is. At least I have learnt how to import properly though! 

Thank you again for all your help though. I find this site invaluable and I have learned so much. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...