Highlighted

index.aspx error

New Here ,
May 15, 2018

Copy link to clipboard

Copied

Hey All,

I'm using Sharepoint Online, with the "Responsive HTML5" layout. I know that RoboHelp cannot publish directly to Sharepoint Online, so in the Sharepoint section, under Advanced Options, I have Generate SharePoint Native Output before Publishing checked. I have the result generating to a local folder, which I eventually upload to a document library on Sharepoint.  When I open index.aspx in Internet Explorer (from it's local location, not Sharepoint Online), I get the following error:

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


End tag 'head' does not match the start tag 'link'. Error processing resource 'file:///U:/sharepoint/index.aspx'. Line 42,...

</head> --^

I found that the following lines were not self-closing:

<link rel="stylesheet" type="text/css" href="template/styles/widgets.min.css">

<link rel="stylesheet" type="text/css" href="template/styles/layoutfix.min.css">

<link rel="stylesheet" type="text/css" href="template/styles/layout.min.css">

So I changed them to:

<link rel="stylesheet" type="text/css" href="template/styles/widgets.min.css" />

<link rel="stylesheet" type="text/css" href="template/styles/layoutfix.min.css" />

<link rel="stylesheet" type="text/css" href="template/styles/layout.min.css" />

I then got the following error:

This page contains the following errors:

error on line 50 at column 148: xmlParseEntityRef: no name

Below is a rendering of the page up to the first error.

Once I upload the exported contents to Sharepoint, almost everything loads corrects, except that the Table of Contents frame to the left is empty. Looking back at the error referring to line 50, I commented out the following code, and everything worked perfectly.

<div class="logo" data-attr="title:@KEY_LNG.HomeButton;href:rh.consts('DEFAULT_TOPIC')" data-click="!(@KEY_SCREEN_DESKTOP || @KEY_SCREEN_TABLET) && @KEY_ACTIVE_TAB(null)">

 

</div>

It's worth noting that the HTML version of the export (index.html) works perfectly fine with no modifications.

Any thoughts on the issues above and how to avoid them in the future?

Thanks,

Scott

Topics

HTML5 layout

Views

249

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

index.aspx error

New Here ,
May 15, 2018

Copy link to clipboard

Copied

Hey All,

I'm using Sharepoint Online, with the "Responsive HTML5" layout. I know that RoboHelp cannot publish directly to Sharepoint Online, so in the Sharepoint section, under Advanced Options, I have Generate SharePoint Native Output before Publishing checked. I have the result generating to a local folder, which I eventually upload to a document library on Sharepoint.  When I open index.aspx in Internet Explorer (from it's local location, not Sharepoint Online), I get the following error:

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


End tag 'head' does not match the start tag 'link'. Error processing resource 'file:///U:/sharepoint/index.aspx'. Line 42,...

</head> --^

I found that the following lines were not self-closing:

<link rel="stylesheet" type="text/css" href="template/styles/widgets.min.css">

<link rel="stylesheet" type="text/css" href="template/styles/layoutfix.min.css">

<link rel="stylesheet" type="text/css" href="template/styles/layout.min.css">

So I changed them to:

<link rel="stylesheet" type="text/css" href="template/styles/widgets.min.css" />

<link rel="stylesheet" type="text/css" href="template/styles/layoutfix.min.css" />

<link rel="stylesheet" type="text/css" href="template/styles/layout.min.css" />

I then got the following error:

This page contains the following errors:

error on line 50 at column 148: xmlParseEntityRef: no name

Below is a rendering of the page up to the first error.

Once I upload the exported contents to Sharepoint, almost everything loads corrects, except that the Table of Contents frame to the left is empty. Looking back at the error referring to line 50, I commented out the following code, and everything worked perfectly.

<div class="logo" data-attr="title:@KEY_LNG.HomeButton;href:rh.consts('DEFAULT_TOPIC')" data-click="!(@KEY_SCREEN_DESKTOP || @KEY_SCREEN_TABLET) && @KEY_ACTIVE_TAB(null)">

 

</div>

It's worth noting that the HTML version of the export (index.html) works perfectly fine with no modifications.

Any thoughts on the issues above and how to avoid them in the future?

Thanks,

Scott

Topics

HTML5 layout

Views

250

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 15, 2018

Copy link to clipboard

Copied

If you try one of the sample projects, do you get the same thing happening?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
May 15, 2018

Copy link to clipboard

Copied

"It's worth noting that the HTML version of the export (index.html) works perfectly fine with no modifications."

My question would be to ask exactly why you feel you must use the index.aspx page? I mean, since RoboHelp produces HTML and not ASPX, it would seem to be inviting hurdles by insisting upon ASPX.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 15, 2018

Copy link to clipboard

Copied

Honestly, I used ASPX mainly because that's the standard file format for Sharepoint. I can certainly be convinced, feature-wise, to not use it, however.

Thanks,

Scott

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 15, 2018

Copy link to clipboard

Copied

I actually haven't tried a sample project, so I will now.

Scott

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Captiv8r LATEST
LEGEND ,
May 15, 2018

Copy link to clipboard

Copied

I'd be willing to bet you see the exact same behavior with using one of the samples.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...