index topic keywords don't display in index pod

New Here ,
Mar 23, 2016

Copy link to clipboard

Copied

I'm using RH 2015 and importing files from a large project into a smaller project, these files use topic keywords for indexing. When looking at the index pod and/or hhk file you don't see the index keywords listed but when looking at the properties for a topic you do see the topic keywords also in the html code you see the topic keywords as <meta name="MS-HKWD" content="bill of material,obsolete" />. How do you get the topic keywords to show up in the index pod? I don't have time to add each of these again.

TOPICS
HTML

Views

468

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

index topic keywords don't display in index pod

New Here ,
Mar 23, 2016

Copy link to clipboard

Copied

I'm using RH 2015 and importing files from a large project into a smaller project, these files use topic keywords for indexing. When looking at the index pod and/or hhk file you don't see the index keywords listed but when looking at the properties for a topic you do see the topic keywords also in the html code you see the topic keywords as <meta name="MS-HKWD" content="bill of material,obsolete" />. How do you get the topic keywords to show up in the index pod? I don't have time to add each of these again.

TOPICS
HTML

Views

469

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 23, 2016 0
LEGEND ,
Mar 28, 2016

Copy link to clipboard

Copied

Your index is set to Topic Keywords. Try changing the index setting in Project > Project Settings, Index section to the other value.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2016 0
New Here ,
Mar 28, 2016

Copy link to clipboard

Copied

No that didn't do it either.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2016 0
LEGEND ,
Mar 28, 2016

Copy link to clipboard

Copied

Hi there

Perhaps try clearing the CPD?

Click here for information on how to do that

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2016 0
New Here ,
Mar 29, 2016

Copy link to clipboard

Copied

I have the "Clear project cache (.cpd file) before opening any project" already enabled and still no index. I can see the topic keywords in the html code just not in the index pod.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Enthusiast ,
Dec 20, 2016

Copy link to clipboard

Copied

We noticed this too in one of our long-standing projects today. Seems like a bug to me. I think you'd want to have the terms appear in the Index pod, regardless of where they're stored.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2016 0
LEGEND ,
Dec 20, 2016

Copy link to clipboard

Copied

Actually, that's the way it should work as far as I understand.

Wondering if anything would change if you configured the project just to store keywords in topics?

Open the Project tab and click Project Settings.

tmp1.jpg

From the dialog, choose Topics and click OK.

Any change?

I'd encourage others to report a bug to Adobe about this so it's on their radar.

Click here to report the bug.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2016 0
Amebr LATEST
Adobe Community Professional ,
Dec 20, 2016

Copy link to clipboard

Copied

If it's any help, the help says the topic keywords should appear in the index, but with a slightly different icon.

Adobe RoboHelp (2015 release)

Can you try manually adding a topic keyword in a Robohelp topic, just to see if it shows up? If it does, you know it's an import bug. If it doesn't, the whole feature is bugged.

1. Select a word in a topic.

2. Right-click and select Add To > Index Keyword > Topic Index Keyword

Adobe RoboHelp (2015 release)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2016 0