Insert Date Modified Field

Explorer ,
Mar 16, 2009 Mar 16, 2009

Copy link to clipboard

Copied

Hi all,

I am using RH7 and would like to insert the date that each topic was last modified into my global template for my project. I have seen that there is a Fields and Variables dialog that seems to do what I want, that is I can insert a Date field and it is automatically updated when the topic is opened. The problem is, I want the field to only update when a topic is saved, and it should not be the same date for every topic (I don't want Topic A's date to be updated when I save Topic B for example). Does anyone know if what I want to achieve is possible?

Regards,
darkagn
TOPICS
WebHelp

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Valorous Hero ,
Mar 17, 2009 Mar 17, 2009

Copy link to clipboard

Copied

Hi there

What I normally advise is to insert the field but be certain to turn off the automatic update feature. If you leave the auto-update feature enabled, simply opening the topic in the editor is normally sufficient to change the date (sometimes inadvertently - oops, didn't mean to open THAT topic!)

This does, however, place a certain onus on the help author to remember to update the field before saving the topic.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 17, 2009 Mar 17, 2009

Copy link to clipboard

Copied

Hi Rick,

Thankyou for the response, I think that is as close as I can get. Unfortunately it will be inaccurate for topics that haven't been touched for a while, but at least changes from now on will become apparent.

Thanks again,
darkagn

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

I've just been reading this old post, as I'm after the same behaviour as darkagn above. However, when I manually update a date/time field in a topic (by pressing F9 or right-clicking and choosing Field > Update Field) the change does not stick when I save the topic. It reverts to the original value when the topic is reopened or republished. Is this a bug or just a limitation?

Thanks

Jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

Hi there

You replied to a thread that is perhaps seven years old. What version of RoboHelp are you using?

Hard to say what may be going on without knowing that information.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

Hi Rick, I'm running RH 2015.

Cheers

Jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

Hello again

Okay, I think I see what is happening here. And I'd have to say it would appear to be a bug to me.

After you update the field, you need to make a minor change and issue a save command to commit the changes and update the topic. Unfortunately, simply updating the field doesn't seem to trigger a change in the topic.

I'm basing that off the topic tab behavior. When you make a change to the topic, perhaps by typing something different or removing something, the tab shows the topic as being "dirty". (Dirty means that what is inside the topic in memory is different than the topic file on disk)

tmp1.png

I might also encourage you to file a bug by clicking the link below:

Click here to file a bug

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

I raised this one a while back. Adding a space then deleting it will indeed allow the topic to be saved with the field update in place.

Bug#4089944 - Manually updating a field doesn't get detected as a change when publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

Hmmm, shouldn't that be amended?

Instead of:

Manually updating a field doesn't get detected as a change when publishing

Shouldn't it be:

Manually updating a field doesn't get detected as a change when editing

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

If you can tell me how, I will - I mis-typed another feature request yesterday.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 08, 2016 Apr 08, 2016

Copy link to clipboard

Copied

LATEST

Hi Rick

Yes that's exactly what's happening. I guess that makes sense because in practice you'd open a topic and edit something first, so the topic would be "dirty" at that point anyway.

Incidentally, there might be another bug relating to fields. The RoboHelp 2015 documentation states that selecting the Auto-Update This Field option will update the field upon opening the topic. However, in my experience this is not the case. Every topic is automatically updated when published, even those that haven't been opened.

So I think we may have 2 bugs here:

1) Fields updated manually don't get detected as a change without making an edit to the content first.

2) Fields with the Auto-Update This Field option selected are automatically updated when publishing, irrespective of whether the topic has been opened.

Please can you confirm that you see the behaviour in point 2 and then I'll raise a bug for each.

Thanks
Jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation