is there a difference in output between RH Classic and RH 2019?

Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Hello, I have to take over the job of a collegue. the person prepared written instruction and insisted on NOT using the new gui to maintain an existing project.

Is there any raison why you would like to keep the old way of working? (I'm new to both environments)

Is there any difference in output? we need to produce CHM files

 

best regards,

 

Olivier

TOPICS
Classic, New UI, Output presets

Views

234

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 09, 2020 Mar 09, 2020
At the end of your CSS there are additional brackets. } {}   Delete those and then the CSS parses.  

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

If you are only ever going to produce CHMs, then either will work. You need to be aware though that CHMs are decreasing in popularity so what you use depends on your audience and how your software is used.

 

A CHM has to be installed on the users PC as they no longer work when installed on networks. They were good in their time and still work within their limitations but they don't offer the functionality of the newer online outputs.

 

I don't know how much further RoboHelp Classic will be developed as focus seems to be on the new user interface. However, if you are only producing CHMs then the version you have should continue to work. If your company does change to another format or already uses them as well, then going the new UI route would be better as that will continue to be developed.

 

Early on the new UI had many issues and that may be why your colleague would not use it. It is now a lot better as there have been many updates, another one due soon.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Thank you Peter,

I'm challenging our developpers to look into new help output solutions, as we speak

i'm at least confident there won't be a difference in output between 'classic' and 2019 standard gui usage.

best regards

Olivier

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

I did import one subpart of the project with the new gui instead of classic and got immediately an error in the upgrade log

Failed patching and copying CSS Dependencies from /robohelp/All files 6.6 Frans_Restore - Copy/WhatsNew02/functies.css

what can I do to prevent this error?

I opened this stylesheet, it has been made with RH9. it is situated in the root of the projectfolder

best regards

Olivier

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Meanwhile imported the css manually in the project. Got another kind of error now

(failed to parse the style sheet)

I cannot attach a file, but if you want, I'm pasting the code here

best regards

Olivier

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

BTW. I think the reason you could not attach a file is maybe you were emailing your reply? If you go to the web page, you can attach files with some exclusions.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

There isn't any code pasted but the issue is almost certainly something in the CSS that the upgrade could not fix.

 

The first thing I would try is a complete upgrade of your project. It will be created in a new folder and it will not change your existing version in any way. I doubt it will make a difference but it is worth a try.

 

If that doesn't work, see the Contact page on my site and send me the CSS from your Classic project. I may not be able to spot the issue but I am happy to try.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

I didn't know if this was permitted. So i've send you an email via contactpage. with attachment and text pasted (two versions :-))

 

thanks for yout help.

 

There are 3 other css files in the project. But not in the subproject I tested

 

best regards

 

Olivier

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

At the end of your CSS there are additional brackets.

} {
}

 

Delete those and then the CSS parses.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Hello Peter, Indeed this did it. I'm very gratefull

thanky you very much

Olivier

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Content removed as it was sent in error after solution posted.

 

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation