Highlighted

IsInternal is undefined error in Preview mode after switching to auto-sizing popup

Participant ,
Mar 07, 2016

Copy link to clipboard

Copied

RoboHelp 2015.

  1. Selected a hyperlink that is currently displayed in a frame with Page Default (none) as the value.
  2. Selected "Display in auto-sizing popup".
  3. Saved the change.
  4. Previewed the topic and clicked the hyperlink. The following screen shows the Script Error. Is anyone familiar with this problem? After I undid the changes and open again in Preview mode, there was no error.

3-7-2016 11-43-40 AM.png

Thanks!

Carol Levine

Hi Carol

Is this by chance a project that was upgraded to 2015 from an earlier version? If so, perhaps you need to click the Tools tab and Update the DHTML.

tmp1.png

Cheers... Rick

Topics

HTML

Views

240

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

IsInternal is undefined error in Preview mode after switching to auto-sizing popup

Participant ,
Mar 07, 2016

Copy link to clipboard

Copied

RoboHelp 2015.

  1. Selected a hyperlink that is currently displayed in a frame with Page Default (none) as the value.
  2. Selected "Display in auto-sizing popup".
  3. Saved the change.
  4. Previewed the topic and clicked the hyperlink. The following screen shows the Script Error. Is anyone familiar with this problem? After I undid the changes and open again in Preview mode, there was no error.

3-7-2016 11-43-40 AM.png

Thanks!

Carol Levine

Hi Carol

Is this by chance a project that was upgraded to 2015 from an earlier version? If so, perhaps you need to click the Tools tab and Update the DHTML.

tmp1.png

Cheers... Rick

Topics

HTML

Views

241

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Mar 07, 2016

Copy link to clipboard

Copied

Hi Carol

Is this by chance a project that was upgraded to 2015 from an earlier version? If so, perhaps you need to click the Tools tab and Update the DHTML.

tmp1.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 07, 2016

Copy link to clipboard

Copied

Rick -- Yes, the project was converted from 2011 (and previously from 2010 and 2009!). Since we can't open the project in previous versions of RoboHep anyway, I'll update the DHTML.

Thanks.

Carol

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 07, 2016

Copy link to clipboard

Copied

I'm not sure whether the script error was limited to Preview mode. But having Updated the DHTML before generating a sample project, I can no longer tell.

Bottom line is that I changed a hyperlink to open in a popup, generated the project, opened the topic, clicked the hyperlink, and it opened in a popup window.

Btw, I didn't see any place to make your answer correct.

Carol

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 07, 2016

Copy link to clipboard

Copied

LOL, I can't tell from your answer whether this actually resolved the issue or if it still manifests when previewing, but it works in the output and that's all you are concerned with.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 07, 2016

Copy link to clipboard

Copied

Yes, it works fine when I open the generated project, but doesn't work in Preview mode.

I was able to mark your answer correct this time by following the link from the email. Previously, the link did not appear.

Thanks again.

Carol

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...