Highlighted

Issue with adding multiple .mp3 files

Community Beginner ,
Aug 08, 2019

Copy link to clipboard

Copied

I've never added audio files to a KB before. Scenario is we can no longer support .mp3 files where we currently have them, so I offered to host them. I am doing this for .pdf files as well. With PDF files, I just upload them as baggage files, then give them the URL, and they link to it. Works like a dream. I tried to do that with .mp3 files, but it didn't work. So I created a page "audio", loaded the .mp3 files and was going to share the URLs. Tested with one .mp3 and it worked perfectly.

After adding the next 8, when I published, it still only saw the first one. And when I viewed the audio file on my KB, it was simply named ".mp3" instead of "baseband1.mp3", etc. So, instead of following the process I found here - https://help.adobe.com/en_US/robohelp/2019/robohtml/robohelp_classic_2019_help.pdf , I wrote out each file name in my audio file and linked using the media option.

I figured out how to resolve as you can see, but can someone explain to me why this happens?

  1. cannot load a .mp3 as a baggage file and find it
  2. mp3 file names are not displayed. The file is only seen as ".mp3"

Thanks a million!

Anahid

Views

173

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Issue with adding multiple .mp3 files

Community Beginner ,
Aug 08, 2019

Copy link to clipboard

Copied

I've never added audio files to a KB before. Scenario is we can no longer support .mp3 files where we currently have them, so I offered to host them. I am doing this for .pdf files as well. With PDF files, I just upload them as baggage files, then give them the URL, and they link to it. Works like a dream. I tried to do that with .mp3 files, but it didn't work. So I created a page "audio", loaded the .mp3 files and was going to share the URLs. Tested with one .mp3 and it worked perfectly.

After adding the next 8, when I published, it still only saw the first one. And when I viewed the audio file on my KB, it was simply named ".mp3" instead of "baseband1.mp3", etc. So, instead of following the process I found here - https://help.adobe.com/en_US/robohelp/2019/robohtml/robohelp_classic_2019_help.pdf , I wrote out each file name in my audio file and linked using the media option.

I figured out how to resolve as you can see, but can someone explain to me why this happens?

  1. cannot load a .mp3 as a baggage file and find it
  2. mp3 file names are not displayed. The file is only seen as ".mp3"

Thanks a million!

Anahid

Views

174

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 08, 2019 0
Adobe Community Professional ,
Aug 09, 2019

Copy link to clipboard

Copied

You have created other posts about 2019 but here you are looking at the help for 2019 Classic. Which product are you asking about here?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2019 0
Community Beginner ,
Aug 09, 2019

Copy link to clipboard

Copied

I am using 2019 Classic, very sorry for confusion, Peter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2019 0
LEGEND ,
Aug 09, 2019

Copy link to clipboard

Copied

Okay, you mention "publishing" and that often means different things to different folks.

Some say they "publish" and they mean "generate".

So can you be a bit more explicit with what you mean?

Just describe the steps you follow as best as you can. For example: I click this button and things end up here.

Or even better. Can you record a video of your screen or maybe capture some screen shots to show us?

Thanks... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2019 0
Community Beginner ,
Aug 12, 2019

Copy link to clipboard

Copied

Hi Rick,

I'm prefacing this with I'm in IT. If a user said what I'm about to say to you, I'd put them on mute and either curse them or laugh at them. But, I actually had two people look at this and see the same thing I did, including a network guy who said there was nothing wrong on the server, it was Robohelp. (note - I showed him the files displayed in robo, then on the server and on the resulting webpage).

I created a topic - "audio"

I loaded 7 .mp3 files as baggage files and tried both dragging and dropping them onto audio, then after I got incorrect results removed them and added via the Insert > Multi-media option

Double clicked WebHelp (Primary Output) and generated my output

clicked the resulting "Publish" button to copy to the webserver

When I viewed the results, the page "audio.htm" only the first file was displayed, and the other six were not displayed on the page, although they were in Robohelp 2019 classic.

After playing around for a day, I gave up and created hyperlinks to the .mp3 files. After generating output and republishing, it worked.

I was replicating for you, and created a new topic, audio2, dragged and dropped the files and it worked perfectly.

Therefore, I give up. if this happens again I will take screenshots. It is frustrating and embarrassing and I wasted two days working on it

Anahid

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 12, 2019 0
LEGEND ,
Aug 13, 2019

Copy link to clipboard

Copied

LOL, I worked in call centers for more years than I care to count. So I totally understand what you mean by muting the phone.

Additionally, I've been participating in the RoboHelp support forums and facilitating RoboHelp classes for enough years to know that when I hear the term "publishing" used by RoboHelp users, I have to stop and ask as I did. Because for more users than you may imagine, that process simply means "I generated the output". And as you seem to realize (and good on you for doing so) in RoboHelp parlance, publishing means to use the tool that is built into RoboHelp to simply copy files from your output folder to the final destination.

So I offer my apologies if you felt by my asking about it you felt I was somehow speaking down to you. I never mean to do that with folks. It's only done to establish clear communication.

Unfortunately I have no suggestions or clues to offer as to why it failed when it did and why it seems to be working at this point. I guess we will just thank our lucky stars it's now working?

If you do notice it happening again, please do try and capture the steps or screens or whatever. As you likely know, in many cases these can be so very helpful.

Hope your day is awesome... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2019 0
AnahidMA LATEST
Community Beginner ,
Aug 13, 2019

Copy link to clipboard

Copied

Hey Rick,

Never felt like you were talking down to me, no worries! I was just extremely frustrated once I couldn't reproduce. I spent so much time going down the rabbit hole to try and figure out why, I never took the simple step of just starting from scratch. Lesson learned I guess!

I do learn so much from you and Peter, and am so very grateful you are here to guide and teach. Did you ever create that more advance online training?

Cheers! Anahid

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2019 0