Links between child projects in a Responsive HTML5 output opening in new tabs - why?

New Here ,
Jun 01, 2017

Copy link to clipboard

Copied

Hi,

I have a set of projects one parent and 9 children which have been merged and published as web help. I open the parent help and can see all the children, the children have links from one to another and these when clicked open within the parent tab keeping my TOC structure. So in WebHelp it all works fine

However I have gone through and republished all the projects as Responsive HTML Help using the Assure Blue skin, now:

1 I open the parent help and the TOC for all children is shown correctly

2. I click on a link to one of the child topics in the TOC it opens in the parent tab as expected

3. I click on a link in any of the child topics linking to a topic in a different child project - the 2nd child project opens in a new tab and displays the expected topic NOT what I want.

So how do I get the links in the child projects to open in the parent tab? I have looked at Peter Grainges explanation and cannot see anything I am doing wrong, I tried looking at William van Weeldens site and he does say something about it but I dont understand it. I have looked in the archives here and cant see anything to help becuase when published as WebHelp the behaviour is correct, it is just swapping to Responsive HTML5 which is breaking it.

Thanks for the help

Erika

TOPICS
HTML5 layout

Views

269

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Links between child projects in a Responsive HTML5 output opening in new tabs - why?

New Here ,
Jun 01, 2017

Copy link to clipboard

Copied

Hi,

I have a set of projects one parent and 9 children which have been merged and published as web help. I open the parent help and can see all the children, the children have links from one to another and these when clicked open within the parent tab keeping my TOC structure. So in WebHelp it all works fine

However I have gone through and republished all the projects as Responsive HTML Help using the Assure Blue skin, now:

1 I open the parent help and the TOC for all children is shown correctly

2. I click on a link to one of the child topics in the TOC it opens in the parent tab as expected

3. I click on a link in any of the child topics linking to a topic in a different child project - the 2nd child project opens in a new tab and displays the expected topic NOT what I want.

So how do I get the links in the child projects to open in the parent tab? I have looked at Peter Grainges explanation and cannot see anything I am doing wrong, I tried looking at William van Weeldens site and he does say something about it but I dont understand it. I have looked in the archives here and cant see anything to help becuase when published as WebHelp the behaviour is correct, it is just swapping to Responsive HTML5 which is breaking it.

Thanks for the help

Erika

TOPICS
HTML5 layout

Views

270

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 01, 2017 0
Adobe Community Professional ,
Jun 02, 2017

Copy link to clipboard

Copied

Double click one of the links in the source topic to open the dialog. What does it say in Display Frame? Try Default.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0
New Here ,
Jun 02, 2017

Copy link to clipboard

Copied

Hi Peter,

They do say Page default (none), I found by changing the Display Frame to Same Frame I could get it to work correctly. However its a pain to have to go into all the projects and do that, I was wondering if I was missing something obvious

If there isn't an easier option I will just do a find and replace in the code view it just seems odd that it works correctly (in my mind) for merged WebHelp but not for Responsive HTML Help.

Thanks

Erika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0
Adobe Community Professional ,
Jun 02, 2017

Copy link to clipboard

Copied

Download the demo merge from my site and upgrade it to RoboHelp 2017. For me that worked fine. If it does for you, then you could compare the settings with your own project.

Am I right in thinking I know you on the forums from way back? Ladbrokes in those days?


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0
New Here ,
Jun 02, 2017

Copy link to clipboard

Copied

Hi Peter,

Yes you do know me from Ladbrokes I have moved back to a RoboHelp job   and back onto the forums - 4 years of Flare have made this slightly harder as I keep thinking well its there in Flare where have they hidden that setting in RH?

The files are based on your merged help instructions and for all but Responsive HTML5 help work fine. It is just that we are trying to move forwards and use the new formats. I got the job of testing the new format to see if it would work and this is the first problem that I have hit. The changing the display field will fix it BUT I now have the problem that it is not syncing in the TOC and I cannot find the sync TOC option

Thanks as always for the help

Erika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0
Adobe Community Professional ,
Jun 02, 2017

Copy link to clipboard

Copied

Something is odd in that your links are working in a different way to the demo and the syncing works just fine. Take a look at the RoboHelp Tour on my site and see if it works for you there. I am seeing the behaviour you want and I am using Azure Blue out of the box.

Have you got all the Updates applied?

Also try selecting Azure Blue again from the Gallery. I am assuming you haven't applied any customisation.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0
New Here ,
Jun 02, 2017

Copy link to clipboard

Copied

Thanks will start again and have another go on Monday morning with a totally new set of projects. Then I can do the compare and contrast, I think something has been changed in the skin but I need to check with my collegue on Mon. May try with all "vannilla" sets to see if it will work before having another go at my sand box copies of real projects.

Erika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0
Adobe Community Professional ,
Jun 02, 2017

Copy link to clipboard

Copied

One of RoboHelp's endearing features is something that doesn't work on Friday and annoys you over the weekend, works perfectly on Monday.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2017 0