Highlighted

Links to topics at the folder level unresponsive in CHM

Explorer ,
Jun 01, 2020

Copy link to clipboard

Copied

RoboHelp 2019 New UI

 

I have set up topic links to folders in my project TOC and when output to ResponsiveHTML5, the links work fine.  But, when I produce a CHM of the same TOC, two of the folders are unresponsive and do not show the topic. All of the linked topics just consist of a single JPG.  I don't see any difference in the topics such that only 2 would not display (see image).

 

TechWriter57_0-1591026720669.png

 

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

I have since learned that the & in the file name causing the problem is a bug that will be fixed in an update. Nonetheless, I still recommend sticking with alphnumeric characters, hyphens and underscores in file names generally.

 

Views

218

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Links to topics at the folder level unresponsive in CHM

Explorer ,
Jun 01, 2020

Copy link to clipboard

Copied

RoboHelp 2019 New UI

 

I have set up topic links to folders in my project TOC and when output to ResponsiveHTML5, the links work fine.  But, when I produce a CHM of the same TOC, two of the folders are unresponsive and do not show the topic. All of the linked topics just consist of a single JPG.  I don't see any difference in the topics such that only 2 would not display (see image).

 

TechWriter57_0-1591026720669.png

 

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

I have since learned that the & in the file name causing the problem is a bug that will be fixed in an update. Nonetheless, I still recommend sticking with alphnumeric characters, hyphens and underscores in file names generally.

 

Views

219

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 01, 2020 0
Explorer ,
Jun 01, 2020

Copy link to clipboard

Copied

Upon checking the two "nondisplayable" HTML files in explorer, I get this message. So, I guess this is not a RoboHelp issue. I don't remember doing anything different with these images.  

TechWriter57_0-1591027890855.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Explorer ,
Jun 01, 2020

Copy link to clipboard

Copied

After futher troubleshooting, I found the issue.  The topics that were not showing had JPGs that had an "&" in the title.  It looks like the CHM has a problem with those, but not HTML5.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 1
Adobe Community Professional ,
Jun 01, 2020

Copy link to clipboard

Copied

The CHM compiler was last updated by Microsoft in 2004. In those days only alphanumeric characters and a few others such as underscores were permitted, so no surprise with that. Generally I stick with those characters as it is always safer.

 

Well done on the detective work.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Adobe Community Professional ,
Jun 02, 2020

Copy link to clipboard

Copied

I have since learned that the & in the file name causing the problem is a bug that will be fixed in an update. Nonetheless, I still recommend sticking with alphnumeric characters, hyphens and underscores in file names generally.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2020 0