Highlighted

Local Path in TFS dialog either defaults uneditable to different folder or can't connect in Win 10

New Here ,
Feb 09, 2016

Copy link to clipboard

Copied

I was running TFS MSSCCI Provider v11 to integrate with RoboHelp 10 on Windows 7. I would open an RH project by selecting the TFS version control option, which would eventually open the Choose Folder in Team Foundation Server dialog. Then I would drill down to the relevant project folder on the server side. When I selected a folder, the proper Local Path was populated (as defined in the workspace via VS Team Explorer (2013)).

Now in Windows 10, I have two major problems:

  • I can map a local path with Source Control Explorer, but then when I try to open a RH project by selecting a folder, the Local Path is empty so I have to type or browse to the path. When I click OK, it says the path is already mapped in the workspace.
  • If I don't map the folder with Source Control Explorer beforehand, I can manually assign a local path and successfully open a RH project with a TFS connection. When I check out a file in RH, it is shown as locked in Source Control Explorer but the red check symbol is not there, and of course the local path remains Not mapped. And if I try to map it, it is "already mapped." So essentially, the two components are out of sync.

But in this case, no folders are mapped in Source Control.

proper_local_path.gif

edit_workspace_no_folders.gif

The other problem is that in other cases when I map a folder with Source Control Explorer and open a project with RH, the Local Path either defaults to C:\ or C:\WINDOWS\system32 instead of what I defined in the workspace. Plus this path is uneditable. However, it also creates a new workspace with a _1 extension to my existing workspace, in which I can edit the path, but I don't want an extra workspace.

local_path_fixed_mult_workspaces.gif

So how do I get the Visual Studio interface and RoboHelp back in synch?

Topics

Source control

Views

510

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Local Path in TFS dialog either defaults uneditable to different folder or can't connect in Win 10

New Here ,
Feb 09, 2016

Copy link to clipboard

Copied

I was running TFS MSSCCI Provider v11 to integrate with RoboHelp 10 on Windows 7. I would open an RH project by selecting the TFS version control option, which would eventually open the Choose Folder in Team Foundation Server dialog. Then I would drill down to the relevant project folder on the server side. When I selected a folder, the proper Local Path was populated (as defined in the workspace via VS Team Explorer (2013)).

Now in Windows 10, I have two major problems:

  • I can map a local path with Source Control Explorer, but then when I try to open a RH project by selecting a folder, the Local Path is empty so I have to type or browse to the path. When I click OK, it says the path is already mapped in the workspace.
  • If I don't map the folder with Source Control Explorer beforehand, I can manually assign a local path and successfully open a RH project with a TFS connection. When I check out a file in RH, it is shown as locked in Source Control Explorer but the red check symbol is not there, and of course the local path remains Not mapped. And if I try to map it, it is "already mapped." So essentially, the two components are out of sync.

But in this case, no folders are mapped in Source Control.

proper_local_path.gif

edit_workspace_no_folders.gif

The other problem is that in other cases when I map a folder with Source Control Explorer and open a project with RH, the Local Path either defaults to C:\ or C:\WINDOWS\system32 instead of what I defined in the workspace. Plus this path is uneditable. However, it also creates a new workspace with a _1 extension to my existing workspace, in which I can edit the path, but I don't want an extra workspace.

local_path_fixed_mult_workspaces.gif

So how do I get the Visual Studio interface and RoboHelp back in synch?

Topics

Source control

Views

511

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Feb 09, 2016

Copy link to clipboard

Copied

I always avoid the open from version control option. I always set the paths in VS and do a get to my local disk. I then open the project from the local disk and RH recognises the project's source control status. I have used this way of working for different client and I never had issues like you describe.

To fix it in your case: Remove all local projects. Set up the workspace and do a get. Then open the project from the local disk.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...