Missing TOC in RH 2020.3

New Here ,
Jan 18, 2021

Copy link to clipboard

Copied

My output from RoboHelp 2020.3.32 shows no TOC. What have I done to remove it, and how do I get it back?

 

The RoboHelp states: "Table Of Contents Use the drop-down list to select a Table of Contents to be included in the output. This drop-down list displays the Tables of Contents available in your project. The first Table of Contents in this drop-down list is selected by default.

The set of files and their references present in the selected Table of Contents appear in the generated output."

Views

100

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 18, 2021

Copy link to clipboard

Copied

Please add a screenshot so that we can see what it does show. Is the window full size?

 

Please use the photo icon to insert images within the post. Some supporters will not open attachments for security reasons and if you do download, you are then not seeing the image inline with the text. Then thanks to a quirk of this forum you have to close the thread and reopen it before you can reply. Crazy but that's the way it is.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 18, 2021

Copy link to clipboard

Copied

The output looks like this. Full screen on a laptop.

2021-01-18 22_26_55-Inbox - ninla@eg.dk - Outlook.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 18, 2021

Copy link to clipboard

Copied

Open the table of contents file in Robohelp and check there are actually topics in the toc file. I can get something similar in RH2019 using an empty toc file and specifying a default topic.

 

I also edited the skin to hide Topic Page > Left Panel > tab-box to get rid of the usual "Contents", "Index" etc buttons, so if you've done that you may need to reverse it, depending on what you're trying to achieve.

 

Amebr_0-1611012391359.png

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 18, 2021

Copy link to clipboard

Copied

Also, ff there are entries in the toc file, make sure they aren't excluded from the output by a condition expression.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 18, 2021

Copy link to clipboard

Copied

Huh. That was weird. I was just playing with something and didn't include the default topic in the TOC. Generating failed to show anything in the toc when I viewed the output. Adding the default topic to the toc then corrected the issue.

 

Check if the default topic is in your toc and if not, does adding it fix the issue?

 

Seems a bit odd to me that the toc doesn't work when the default topic isn't in the toc, but the default topic does display correctly in the output.

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 18, 2021

Copy link to clipboard

Copied

Thanks for your suggestions, Amebr

 

The TOC is not empty, and it contains default topic (which is not excluded). However, the default topic is marked as a chapter. Therefore I tried choosig a default topic that was not marked that way, but still no TOC. 

 

When I look closely, there seems to be shown something in the TOC area for just a short glimpse. Maybe it IS generated but not shown? Can the text be white?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 19, 2021

Copy link to clipboard

Copied

It can be. If try to select text within the toc area, it should highlight to confirm if this is the case.

 

You can also try to add a new skin with a slightly different name from your current one and generate with that. Assuming you've customised your current skin, this will generate with the defaults so we can confirm if it's a customisation you've made.

 

Also check if it's the same problem in other browsers.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 19, 2021

Copy link to clipboard

Copied

There seems to be no content to select in the left panel!

I changed the skin with no effect on the problem.

The area is empty in both Chrome, Firefox, Opera and Internet Explorer. When I open IE in developer mode I can see that the text clor is actually black:

2021-01-19 10_29_56-Sent Items - ninla@eg.dk - Outlook.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 19, 2021

Copy link to clipboard

Copied

Do you have this problem if you generate the About RoboHelp sample project? I just want to establish beyond doubt that this is a project specific issue.

 

Assuming you do then see a TOC, create a new project and import a few topics and your CSS. Create a TOC for those topics and generate using a new skin. Hopefully you will then see a TOC.

 

If that works, then export the skin being used in your main project and import it into the new one. What happens then?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 19, 2021

Copy link to clipboard

Copied

Okay, that div doesn't have a little expand arrow, which means no content has been generated.

 

You definitely added a new skin from scratch and didn't use one you might have already modified?

 

My only other suggestion is to look through the skin > Topic Page > Left Panel options and see if any of the styles have Display set to "none" (in the Layout section). If any do, set them to (default) and see what happens.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 19, 2021

Copy link to clipboard

Copied

When I generate the Compass sample project I get the tiles instead of a TOC. For my project which has about 80 or 100 chapters, this is a crazy design. How would I get a proper TOC in the samle project which I have not touched at all so far?

 

2021-01-19 11_31_06-Inbox - ninla@eg.dk - Outlook.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 19, 2021

Copy link to clipboard

Copied

I went through the skin > Topic Page > Left Panel options and changed the few of them that were set to 'flex' so that they are now all 'default'. This does not change the output.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 19, 2021

Copy link to clipboard

Copied

In the preset deselect the Use Skin Home Page check box.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 19, 2021

Copy link to clipboard

Copied

Deselecting the Use Skin Home Page check box made a TOC appear in sample project, just like I want it in my own.

 

Is there a point in sending the entire project to either of you guys helping out? Maybe more efficient than trying to guess at a distance?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 19, 2021

Copy link to clipboard

Copied

You have a working skin in Compass Travel so export it somewhere and import into your project as requested and let us know what happens then.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 19, 2021

Copy link to clipboard

Copied

I imported the skin from the Compass project, and the output looks like the original one - except for the missing TOC! Shortly I could see an orange rectangle appearing at the top of the left panel, but it disappeared again after a few seconds.

2021-01-19 16_25_12-Aktuelt.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 19, 2021

Copy link to clipboard

Copied

See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more