Highlighted

Moving topics to folders does not update Map ID paths?

New Here ,
Apr 22, 2015

Copy link to clipboard

Copied

I thought I tested this carefully before doing the moves but apparently not. I just reorganized a huge help project so that content is finally organized into a set of folders. I did this using the GUI -- dragging blocks of content from the Topic List pod into folders in the Project Manager pod.  All the links/cross references updated beautifully.  It now appears that NONE of the map ID links in the project.ali file inherited the folder references.  It seems incomprehensible to me that RH would biff that step. I must have done something wrong but wanted to check here to see if I've made a mistake somehow.

Here are my two questions:

1. Not critical but should I file a bug: Shouldn't RH update the map ID paths the same way it updates changing a filename for a topic?

2. Critical: I can fix this by hand editing the project.ali, but wanted to know whether anyone has had issues doing this. I'm comfy editing files but never know what RH will be upset about if I hand edit.

Diana

Topics

WebHelp

Views

241

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Moving topics to folders does not update Map ID paths?

New Here ,
Apr 22, 2015

Copy link to clipboard

Copied

I thought I tested this carefully before doing the moves but apparently not. I just reorganized a huge help project so that content is finally organized into a set of folders. I did this using the GUI -- dragging blocks of content from the Topic List pod into folders in the Project Manager pod.  All the links/cross references updated beautifully.  It now appears that NONE of the map ID links in the project.ali file inherited the folder references.  It seems incomprehensible to me that RH would biff that step. I must have done something wrong but wanted to check here to see if I've made a mistake somehow.

Here are my two questions:

1. Not critical but should I file a bug: Shouldn't RH update the map ID paths the same way it updates changing a filename for a topic?

2. Critical: I can fix this by hand editing the project.ali, but wanted to know whether anyone has had issues doing this. I'm comfy editing files but never know what RH will be upset about if I hand edit.

Diana

Topics

WebHelp

Views

242

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 23, 2015

Copy link to clipboard

Copied

Have you tried generating the output to see if it updates then? Doubt it but worth a try.

Similarly, have you deleted the CPD and reopened the project?

Finally, test to see if the map ids work regardless.

... and people wonder why I prefer using URLs to call help. 🙂


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 23, 2015

Copy link to clipboard

Copied

Hi Peter

The output definitely failed.

CPD i think is deleted automatically now when projects are opened.

The map IDs do not work, hence the posting.

I did an explicit test to see if moving a file updated the .ali path and it does not. Methinks that's a fatal flaw.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 23, 2015

Copy link to clipboard

Copied

Retraction -

I had not saved the project when i did the explicit test, so the move does actually update the path. I guess I need to close this thread as user error. I must have done *something* to the .ali file after I'd done all the original moves.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Apr 30, 2015

Copy link to clipboard

Copied

Don't close this issue so fast - it does happen, that the ali file loses detail for topic / map ID links when you move topics around. Not all the time, but it happens. I just had to do some project reorganization and moved topics to new folders. And was expecting the worst, since this has indeed happened before. Sure enough, when I opened the Edit Map IDs window and sorted the project's IDs by topic, there were all these  map IDs with no topic entry - they were just blank.

You can edit the ali if you want, but you can also just reassign the map IDs in this window. Sometimes, you have to click on the Unassign button to be able to reassign the ID to the correct topic. But once you match them back up again, the ali is updated and you can carry on.

I strongly recommend that if you are doing major reorg, make a backup of your project first, then do the work. RH can be a finicky twit sometimes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
starrd LATEST
New Here ,
Apr 30, 2015

Copy link to clipboard

Copied

Hey! Thanks for making not feel so dorky

I do always have backups, I was just not expecting it. Given that most of the links were incorrect, I'm inclined to think I copied it by accident when I was merging files from another project.  I will say that I agree with you generally though. Yesterday, I found after renaming files that the *index* did not get all the changes...I am beginning to wonder whether I'm saving and exiting the project too fast for RH and it's got background processing that's not caught up.  I tend to save, exit and reopen a few times because RH inevitably shows broken links after a couple of times. I think I'd best go get coffee instead so it can button up -- seems a checkpoint should be in the code, tho, to prevent exiting the project if backend work is still in progress. 😕

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...