Highlighted

No buttons for content, index search etc. appear on F1 key

New Here ,
Mar 08, 2018

Copy link to clipboard

Copied

When I press F1 in the application, the buttons for content, index, search etc. do not appear, but only the linked topic.

The title bar has smaller font and a note.

The URL is in this case: 

file:///C:/ProgramData/AV%20Stumpfl/Help/German/WingsHDAV_DE/Allgemeines/Programmfenster/themen_hauptfenster.htm

After clicking in the title bar, view is normal and the URL:

file:///C:/ProgramData/AV%20Stumpfl/Help/German/WingsHDAV_DE/index.htm#t=Allgemeines%2FProgrammfenster%2Fthemen_hauptfenster.htm

The phenomenon occurs with different browsers and is not caused by the context call by the application, because if I use an old help, the display is normal again when I call it with F1. If I double-click the "Index.htm" the help will appear normal. I have checked all settings in the SSL, but I haven't detected any errors. I've emptied the browser cache too, but without success.

Somehow a script does not seem to be executed correctly when the context is called with F1.

Do you have an idea to solve the problem?

Many thanks and greetings

Dieter

TOPICS
HTML5 layout

Views

486

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

No buttons for content, index search etc. appear on F1 key

New Here ,
Mar 08, 2018

Copy link to clipboard

Copied

When I press F1 in the application, the buttons for content, index, search etc. do not appear, but only the linked topic.

The title bar has smaller font and a note.

The URL is in this case: 

file:///C:/ProgramData/AV%20Stumpfl/Help/German/WingsHDAV_DE/Allgemeines/Programmfenster/themen_hauptfenster.htm

After clicking in the title bar, view is normal and the URL:

file:///C:/ProgramData/AV%20Stumpfl/Help/German/WingsHDAV_DE/index.htm#t=Allgemeines%2FProgrammfenster%2Fthemen_hauptfenster.htm

The phenomenon occurs with different browsers and is not caused by the context call by the application, because if I use an old help, the display is normal again when I call it with F1. If I double-click the "Index.htm" the help will appear normal. I have checked all settings in the SSL, but I haven't detected any errors. I've emptied the browser cache too, but without success.

Somehow a script does not seem to be executed correctly when the context is called with F1.

Do you have an idea to solve the problem?

Many thanks and greetings

Dieter

TOPICS
HTML5 layout

Views

487

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 08, 2018 0
Adobe Community Professional ,
Mar 08, 2018

Copy link to clipboard

Copied

What version of RH are you using? The description of the CSH content appearing without any TOC. Index, etc. appearing is the "normal" mode of presenting CSH topics, but there were some flip-flops on how that was being presented in newer versions of RH because of issues with Google Search findability IIRC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
New Here ,
Mar 08, 2018

Copy link to clipboard

Copied

I am using RH 2017.

In the current state, the user must always click in the title bar after a context call to use content, index, search. That wasn't necessary until two weeks ago - but why, what's wrong?

Many greetings

Dieter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
Adobe Community Professional ,
Mar 08, 2018

Copy link to clipboard

Copied

Make sure you're all patched up & try regenerating your help again. The "headless" behaviour you describe has traditionally been the form that CSH topics are launched from F1 calls to specific pages in the output. The user has to select a "Show" link to reveal the "full" help with its TOC, Index, Glossary and Search. Back in some version of RH2015 they found that content wasn't being indexed anymore by Google and they changed how CSH was shown - but of course this set off everyone who had been used to it being shown the "old" way, so it got changed back. There is some workaround to change the way the call to the topic is made that can put back this "full-view" CSH call if desired (IIRC).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
New Here ,
Mar 08, 2018

Copy link to clipboard

Copied

Thanks for the info.

Is this workaround for "full view" described anywhere?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
Adobe Community Professional ,
Mar 08, 2018

Copy link to clipboard

Copied

Yes, but I can't point you at a specific thread at the moment - search around in this HTML5 forum & in the WebHelp one too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
Adobe Community Professional ,
Mar 08, 2018

Copy link to clipboard

Copied

I posted in another thread the difference between two URLs. See Display Navigation Pane when linking topics Between Different Outputs

What's different here is it was working for you until two weeks ago. The change in the call is something that happened in RoboHelp 2015 and was reverted in that version. You are using RoboHelp 2017.

There have been two updates to RoboHelp 2017 but they were some months back. Logically therefore any change must be at your end, unless you applied those updates late but even then, I don't think they would have caused this issue.

Have you changed your output, whatever it is? (Responsive I think)

Otherwise I'm a bit stumped.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
Adobe Community Professional ,
Mar 08, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
New Here ,
Mar 09, 2018

Copy link to clipboard

Copied

The problem with the context call of the help is now solved.

I recently purchased a new computer and then downloaded and installed Robohelp with my Adobe ID. I had firmly assumed that I now have the current version of RH.

Far from it - there were two updates from June and September 2017, after which it seems to work now. I don't understand at all that Adobe did not update its RH download half a year after the release of updates.

But now everything works as it should. Thank you for your support.

Many greetings

Dieter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2018 0
Adobe Community Professional ,
Mar 09, 2018

Copy link to clipboard

Copied

Unfortunately the downloads are not automatically updated and you are not the first to be caught. Let's just say representations have been made.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2018 0
Adobe Community Professional ,
Mar 09, 2018

Copy link to clipboard

Copied

Hmmm...didn't someone in post#3 say "Make sure you're all patched up & try regenerating your help again." - such wise advice ;>)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2018 0