Highlighted

NO output from RH2019 v 2019.0.13

Explorer ,
Jun 09, 2020

Copy link to clipboard

Copied

I recently got RH2019 and updated it to version 2019.0.13. I've tried to upgrade my RH2015 projects (two of them for a total of some 2000 files, some 500 .HTML topics, and a lot of supporting .docx and .pdf) and could not generate Responsive HTML output (the only output I'm interested in) in RH2019. NO broken links in the existing projects. After much reading, I generated the Broken Links report, and was dismayed at the number of them in the 2019 version. SO I moved the projects to the 2019 Classic version, NO ISSUES, NO Broken links, Responsive HTML output came out fine, even when the program reorganized my project file structure. Move that to RH2019, same problem: hundreds of broken links.

After much thought, I convinced myself that I would, in the long run, benefit from reconstructing the projects file by file, that way we (myself and the other editors) could go over them and check everything for relevance and timeliness.

So I started a new project by importing the company logo to use as a favicon (.gif format, 31x38px) for use in the Charcoal Grey skin. I also added the title of the project (straight text, no variables) to the Tilte. To test, I generated output and got the "Failed to generate Responsive HTML5" message. Suspecting a broken link even though there is only ONE picture file in the totally new project, I got a report about a broken link:

66822_0-1591730384131.png

Of course, try as you might to fix the broken link, nothing works. 

At this point I am so angry at RH 2019, I can't think straight - this is probably the worst program I've ever acquired since buying WordPerfect for Windows back in the 90's. Is there any way of generating output from this abomination?

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

When you upgrade your old Classic project is not touched, the upgrade is a new project. My suggestion would be that you upgrade again and confirm that the broken links are still there. Assuming that they are, then delete all the presets (SSLs in old language). I think that will get rid of most if not all.

 

With the broken links gone, hopefully, create a new TOC with just a couple of topics in it and using a skin as supplied. No favicons or anything else at this point.

 

See if that generates OK and then post back. 

 

Views

204

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

NO output from RH2019 v 2019.0.13

Explorer ,
Jun 09, 2020

Copy link to clipboard

Copied

I recently got RH2019 and updated it to version 2019.0.13. I've tried to upgrade my RH2015 projects (two of them for a total of some 2000 files, some 500 .HTML topics, and a lot of supporting .docx and .pdf) and could not generate Responsive HTML output (the only output I'm interested in) in RH2019. NO broken links in the existing projects. After much reading, I generated the Broken Links report, and was dismayed at the number of them in the 2019 version. SO I moved the projects to the 2019 Classic version, NO ISSUES, NO Broken links, Responsive HTML output came out fine, even when the program reorganized my project file structure. Move that to RH2019, same problem: hundreds of broken links.

After much thought, I convinced myself that I would, in the long run, benefit from reconstructing the projects file by file, that way we (myself and the other editors) could go over them and check everything for relevance and timeliness.

So I started a new project by importing the company logo to use as a favicon (.gif format, 31x38px) for use in the Charcoal Grey skin. I also added the title of the project (straight text, no variables) to the Tilte. To test, I generated output and got the "Failed to generate Responsive HTML5" message. Suspecting a broken link even though there is only ONE picture file in the totally new project, I got a report about a broken link:

66822_0-1591730384131.png

Of course, try as you might to fix the broken link, nothing works. 

At this point I am so angry at RH 2019, I can't think straight - this is probably the worst program I've ever acquired since buying WordPerfect for Windows back in the 90's. Is there any way of generating output from this abomination?

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

When you upgrade your old Classic project is not touched, the upgrade is a new project. My suggestion would be that you upgrade again and confirm that the broken links are still there. Assuming that they are, then delete all the presets (SSLs in old language). I think that will get rid of most if not all.

 

With the broken links gone, hopefully, create a new TOC with just a couple of topics in it and using a skin as supplied. No favicons or anything else at this point.

 

See if that generates OK and then post back. 

 

Views

205

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 09, 2020

Copy link to clipboard

Copied

Stay calm. ☺️ I'm sure we can sort things out. It's late here so I'll look more thoroughly in the morning. Meantime though, are generating mobile apps? If not delete the preset and I think that will fix the broken link.

 

Let us know if that works. I'll look in again in the morning.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 10, 2020

Copy link to clipboard

Copied

When you upgrade your old Classic project is not touched, the upgrade is a new project. My suggestion would be that you upgrade again and confirm that the broken links are still there. Assuming that they are, then delete all the presets (SSLs in old language). I think that will get rid of most if not all.

 

With the broken links gone, hopefully, create a new TOC with just a couple of topics in it and using a skin as supplied. No favicons or anything else at this point.

 

See if that generates OK and then post back. 

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 10, 2020

Copy link to clipboard

Copied

Thanks for your replies Peter! Keeping Calm and RoboHelping on. 

I tried deleting the Mobile App preset and that worked fine, even using the image for the favicon. I will spend the rest of the morning testing your other suggestions, work permitting. Will let you know my results as soon as I get them.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 10, 2020

Copy link to clipboard

Copied

OK. Come back when you are ready and I'm sure we can fix things somehow. If you haven't looked at the RoboHelp Reimagined sample project, there is a lot of How To information about this new version.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 11, 2020

Copy link to clipboard

Copied

By marking one of my posts as Correct Answer, are you saying it's all working OK and the upgrade is good to go?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...