No paragraph styles listed to create TOC when import from Word

New Here ,
Jun 05, 2019 Jun 05, 2019

Copy link to clipboard

Copied

Hi, I just upgraded to RH 2019 (just upgraded a week ago so all updates should be included I assume), and I'm having trouble with the import of a word doc - no paragraph styles are listed in the "Start new topic from style" dropdown. I've been using RH for years, and my word document is constructed correctly using proper styles.

TOPICS
HTML

Views

463

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 05, 2019 Jun 05, 2019

Copy link to clipboard

Copied

Historically the installation file for Robohelp hasn't included the patches. I'm not sure if that has changed so it would be worth checking for updates. It should be under Help > Updates or similar, but I don't have a copy of RH2019 New in front of me to confirm. (I assume you are use RH2019 New?)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 05, 2019 Jun 05, 2019

Copy link to clipboard

Copied

2019 downloads do include the updates so if you downloaded just a week ago, you should have Update 7,

Help > About should show 2019.0.7.

What CSS have you set for the import?

See the RoboHelp Reimagined sample project for some information on the import process in 2019.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

Hi,

Thanks for your reply. I actually have two problems. One that in some projects that I try to import, I'm not able to break the topics according to style. I'm using the default CSS. My word doc is structured properly using heading styles.

The second problem is regarding the TOC. I created a new very simple word doc with TOC. For some reason, for this doc, I had the option in RH to break according to style. But when it imported, no TOC was automatically imported. Where is the option to do this,  or does it somehow not exist? Is this related perhaps to https://forums.adobe.com/thread/2613435​, and if this so could this problem still have not been solved? Perhaps the fault is in my workflow. Am I supposed to create a project and then import the word doc? It seems to me that this is my only option, since when I tried selecting the Import Word doc option before creating a new project, no dialog opened. But perhaps I'm mistaken.

Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

Sorry, I didn't mention that yes, I do in fact have the latest updates.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

In this context "import" means import into an open project. Without a project being open, the import option will do nothing.

TOCs will not import at the moment so nothing you can do about that.

Please post an image of the dialog with the page break selected. Maybe I can see what's wrong from that.

Also please confirm you are using the new UI version rather than Classic.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

TBH, if the latest version of RH doesn't support import of the Word TOC, it's rather useless to me. So I won't waste your time with solving other semi-related issues. Any idea when Adobe is going to fix this? It's a rather significant feature to lose.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

Yes, I am using the new UI version

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

Who said 2019 does not support the import of Word documents? All I said was it does not support importing the TOC and I expect that to be fixed soon.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

I know that, and that's exactly what I wrote above: "...the import of the Word TOC". I'm glad Adobe will be fixing it soon - it's just already been a while.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

Sorry. Read your post too quickly while more focussed on something else.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Hi, I wanted to know if the import word toc issue was ever resolved? Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Sorry, I saw I used the black reply button as opposed to the blue one (as you requested) - so reposting:

Hi, I wanted to know if the import word toc issue was ever resolved? Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

No worries re wrong button, it helps but one omission doesn't affect things usually.

 

I don't think it is something that Adobe can resolve. It happens when the CSS parser cannot parse the file. The fact that it has been used in earlier versions does not necessarily mean it is well constructed by CSS3 standards. Also it could just be an issue with the parser. Either way though if it cannot parse the file, you will have the problem. It is nothing to do with Word import, the key issue is you are not seeing the styles in the Styles tab.

 

Create a copy of your project and in that remove the link to your CSS and link all topics to the default.css. It will look wrong but you should see the styles in that CSS to confirm what I have said.

 

After that I would try commenting out a block of styles in your CSS using /* before what you want to block out and */ at the end of what you want to block. At some point you should see your styles and your issue will be within what you commented out.

 

@media styles is a good place to start if you see any.

 

Alternatively see https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your Adobe Support options. The email link tcssup@adobe.com is recommended as it reaches a team dedicated to Technical Communication Suite products including RoboHelp.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Have a look at the Advanced tab in the Word Import settings dialog box.

 

I think there's a couple of settings there that will add the new topics to either an existing or a new table of contents. I haven't used them though, so not sure exactly how they work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

LATEST

Seeing Amber's post made me realise I had misread where you are not seeing any styles. Although you have said 2019, you haven't said whether it is 2019 Classic or 2019 New UI. Which is it. 

 

Also please look at the Help menu and see exactly which update version you are running. It should be 2019.0.14 for both Classic and New UI.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation