Highlighted

One topic not appearing in PDF/Word output (RH2020)

Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

Hi,

I recently upgraded a project from RoboHelp 2019 Classic to RoboHelp 2020 (v2020.1.54). I have a topic called Appendix B that displays when I output to HTML, but does not appear when I output to Word/PDF. I duplicated the Online TOC and switch the duplicate TOC to a Book TOC format so that I could add a "front matter" Table of Contents in the Word/PDF. Appendix B is in the new Book TOC, hide in output is not selected, and for some reason when I output a document, Appendix B does not appear there. It skips right from Appendix A to Appendix C. 

Appendix B in TOC in RoboHelp.jpgAppendix B missing in PDF.jpg

Any ideas why this might be happening? The only way Appendix B is different is that it has several lengthy tables on it, but that shouldn't make the page disappear entirely. 

TOPICS
New UI, Output presets

Views

21

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

One topic not appearing in PDF/Word output (RH2020)

Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

Hi,

I recently upgraded a project from RoboHelp 2019 Classic to RoboHelp 2020 (v2020.1.54). I have a topic called Appendix B that displays when I output to HTML, but does not appear when I output to Word/PDF. I duplicated the Online TOC and switch the duplicate TOC to a Book TOC format so that I could add a "front matter" Table of Contents in the Word/PDF. Appendix B is in the new Book TOC, hide in output is not selected, and for some reason when I output a document, Appendix B does not appear there. It skips right from Appendix A to Appendix C. 

Appendix B in TOC in RoboHelp.jpgAppendix B missing in PDF.jpg

Any ideas why this might be happening? The only way Appendix B is different is that it has several lengthy tables on it, but that shouldn't make the page disappear entirely. 

TOPICS
New UI, Output presets

Views

22

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 12, 2020 0
Adobe Community Professional ,
Oct 12, 2020

Copy link to clipboard

Copied

Are you using conditional tags? Perhaps the Appendix B topic has a condition applied that is excluded from the PDF output?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 1
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

It's a good thought, but I don't think it's causing the issue. I have one conditional tag that I use ("online") for sections of the project that should only be in the online version. I do have "online" excluded in the output, but almost every page has a small section that is tagged online (javascript feedback buttons that sends data to Google Analytics) so the Appendix B page isn't tagged differently than the others.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0