Pasted Word Images Overwrite File Names

Participant ,
Jan 16, 2012 Jan 16, 2012

Copy link to clipboard

Copied

My workflow for WebHelp 9.0.2 systems involves outputting Word docs to be used for review and revisions by the SMEs. Those docs are returned to me, I copy and paste and tweak changes, compile a new WebHelp system, and produce a new set of Word docs and the process continues anew. These projects include a lot of use-cases with a lot of screen captures.

To my horror, I just recently discovered that when I copy a large section of Word text which includes images and paste that into a RoboHelp topic, RoboHelp overwrites existing image file names instead of incrementing the file names. Many of the images are new and have not been used in the WebHelp project previously. If I explicitly select just one image in Word, copy and paste that, the image file name is usually properly incremented and does not overwrite an existing file name (there were some exceptions which I haven't had time to explore yet).

I’m working around that by removing all the images from the Word doc first, but this is not an ideal solution. Any suggestions? Is this a bug or am I nuts?...<G>

Is there a schema used by RoboHelp for naming placed image files? Thanks for any help.

TOPICS
WebHelp

Views

4.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jan 17, 2012 Jan 17, 2012
I see the problem when I follow your steps of pasting one section of the Word document and then another. There is a very simple solution, after pasting in the first time, save the topic and then paste in the next section. It works just fine.Reading the thread earlier I thought what was happening was that existing images saved in topics were being trashed, however it is "only" images that have been pasted in since the topic was last saved.Whilst there is a solution, this is still a bug that shoul...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 16, 2012 Jan 16, 2012

Copy link to clipboard

Copied

Images in Word don't have a filename. Can you give some examples with filenames of what was in a topic and what is there after pasting?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 16, 2012 Jan 16, 2012

Copy link to clipboard

Copied

Thanks, Peter. I realize Word images don't maintain filenames. When a Word image is pasted into a WebHelp topic, RoboHelp assigns it a filename (e.g., "image113.jpg"). With hundreds of topics, there may be hundreds of image file names in the project--mostly incremented.

What I discovered with RoboHelp 9 (and which was not an issue with RoboHelp 8) is that if I copy and paste large sections of Word into a topic in RoboHelp -- it can be a newly created topic or existing -- many of those image file names in the project get overwritten with the newly pasted image. So, if "image113.jpg" was a logomark, for example, it is now a dialog screen. So, of course, the topic elsewhere that used to display the logomark now displays a completely incongruous dialog.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 16, 2012 Jan 16, 2012

Copy link to clipboard

Copied

Can you create a single topic project where if you then paste in something from Word this problem will then occur?

Save a copy of the project before you paste in.

If you can do that, then send me the copy before you pasted in plus the document that will recreate this. If I can recreate it, I will take this up with Adobe.

Please send the files as set out on the Contact page of my site.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 16, 2012 Jan 16, 2012

Copy link to clipboard

Copied

I'll give it a shot, Peter, later tonight my time. Thanks.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2012 Jan 17, 2012

Copy link to clipboard

Copied

I see the problem when I follow your steps of pasting one section of the Word document and then another.

There is a very simple solution, after pasting in the first time, save the topic and then paste in the next section. It works just fine.

Reading the thread earlier I thought what was happening was that existing images saved in topics were being trashed, however it is "only" images that have been pasted in since the topic was last saved.

Whilst there is a solution, this is still a bug that should be reported.  Please follow this link and be clear the problem is with unsaved images.

http://www.Adobe.com/cfusion/mmform/index.cfm?name=wishform&product=38


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 17, 2012 Jan 17, 2012

Copy link to clipboard

Copied

Excellent, Peter! That’s likely why—with hundreds of topics and a frantic pace—I hadn’t caught what was going on. I’ll do some additional testing to get my confidence level back up and report the bug.

Regards...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 18, 2012 Jan 18, 2012

Copy link to clipboard

Copied

Here is the response I received from Adobe:

"Thanks for reporting the issue. The basic problem lies in the way you are selecting the image to paste it in the RoboHelp. If you click on the image and copy it when the selection box appears around the image then copying the image won't replace the earlier image. However if don't copy it via selection box and treat the image just as the normal data then this issue will occur. Because in this scenario the image is copied via Operating system's clipboard and its not added to project location until user saves the topic. However our engineering team is looking into the issue so that user can copy image/data from anywhere into RoboHelp without any loss in any scenario."

Sounds like a feature, eh?

Since it's not reported anywhere in the help system as an issue or distinction, I strongly support Adobe making RoboHelp as bullet-proof as possible.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

Update:

This is a huge, huge bug: even saving all topics and the project, cutting and pasting Word text with images still overwrites existing images in the WebHelp project. There is no way this can be considered a "feature" — I just lost over a day's work because this clobbered several dozen images in a topic that wasn't even open by over-writing image files in the project directory.

Adobe Support's solution for this feature? Copy the images one-by-one, which sort of defeats the purpose of Word's rich text pasting.

Just a heads-up: if you've been doing a lot of Word cutting-and-pasting, and your doc contains images--you'd better double-check your topics.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

Hi there

I can easily see how RoboHelp could become confused with working this way. I'm going to have to disagree with you on the perception that it's a bug. To me, it's quite logical.

If you have a topic open in the editor, select an image and text, then paste back in with a different image and text, it seems logical to me that RoboHelp would assume the image you pasted would replace the one you copied.

I'm thinking that you could easily avoid the whole issue by working as follows: (Assuming you are insistent on working in the "copy and paste" way - I'm not sure I'd ever recommend that anyone work that way as it seems very error prone to me)

Before you paste, position your cursor at the end of the text on the topic. Then paste as a totally new block of text and images. Then select the original block of text and images and delete it.

My thought here is that RoboHelp will see the added text and images as new information and will appropriately name the new images accordingly so nothing existing is actually overwritten.

Just a thought... Rick

Helpful and Handy Links

RoboHelp Wish Form/Bug Reporting Form

Begin learning RoboHelp HTML 7, 8 or 9 within the day!

Adobe Certified RoboHelp HTML Training

SorcerStone Blog

RoboHelp eBooks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

Thanks for the response, Rick ...

However, I am insistent on using cut'n'paste: I'm working with hundreds of technical and user docs with literally thousands of images likely to get updated and revised daily. I don't have the leisure or resource to do otherwise. Your procedure does not work with a selection of several pages of Word test/image mix: pasting that into a new naked topic, at the beigninning of an existing topic, at the end of a topic -- has the same net result of over-writing existing image filenames.

  • If I paste in one image at a time, no filenames are over-written.
  • If I select an image in a topic and paste an image from Word, no filename gets over-written.
  • If I select a block of text in Word, which includes one or more images, and paste it into a topic -- even a totally blank topic -- one or more filenames in the project get over-written.

If that's logical, I'll be whipped...

When Peter and I validated this bug (and really, it is a bug), we both thought that saving all unsaved topics would prevent filenames from getting over-written. Today I've discovered that is not necessarily true. Thus, the warning to double-check if anyone is also doing a lot of cutting'n'pasting (and also, report it to Adobe).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

Hello again

Okay, curiosity question here. RoboHelp 8 introduced a new way of working with Word documents. What you do is link to them. When updates occur, you update the Word documents and RoboHelp sucks in the updates when you tell it to.

Have you entertained this idea at all? If not, why not? Were you aware it existed?

Cheers... Rick

Helpful and Handy Links

RoboHelp Wish Form/Bug Reporting Form

Begin learning RoboHelp HTML 7, 8 or 9 within the day!

Adobe Certified RoboHelp HTML Training

SorcerStone Blog

RoboHelp eBooks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

Yes, I'm aware of linking (I've been using RoboHelp since it was in Solana Beach and just a blue-sky effort...<G>). Linking does not fit my workflow: I output Word docs for review and they're returned with Track Changes on after being batted from St. Louis to Baltimore and back. Not all source docs are formatted appropriately for the WebHelp projects, either.

Now, if Adobe fixed the image issue, everything would be perfect.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

LOL, you may have been using RoboHelp since Blue Sky days (as was I) but only Adobe added the linking bit in the last couple of years. (lest folks later reading this thread think it's a feature that has long been a part of RoboHelp)

Oh well, I was just trying to help you find a way that would work for the copy and paste workflow. Sorry I was unable to help. I guess at this point all you can do is report to Adobe and hope for either a fix at some later point or a change in behavior with the next version whenever it becomes available and if you choose to upgrade.

Cheers... Rick

Helpful and Handy Links

RoboHelp Wish Form/Bug Reporting Form

Begin learning RoboHelp HTML 7, 8 or 9 within the day!

Adobe Certified RoboHelp HTML Training

SorcerStone Blog

RoboHelp eBooks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

One other thing.

I'm doubtful you will think it will help, but RoboHelp 9 introduces a way of creating a PDF for review. You share the PDF, folks open it up in the PDF reader, mark it up and you track changes and accept or reject from inside RoboHelp. Might be worth checking out and could possibly save you some frustration.

Cheers... Rick

Helpful and Handy Links

RoboHelp Wish Form/Bug Reporting Form

Begin learning RoboHelp HTML 7, 8 or 9 within the day!

Adobe Certified RoboHelp HTML Training

SorcerStone Blog

RoboHelp eBooks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 07, 2012 Feb 07, 2012

Copy link to clipboard

Copied

Ross

You said "If I select a block of text in Word, which includes one or more images, and paste it into a topic -- even a totally blank topic -- one or more filenames in the project get over-written."

You know how to send projects to me, it's on the Contact page of my site. Create a new project and set it up so that when I cut and paste into it, images will get overwritten. Send me document as well with instructions as to what to copy and where to. In short, spell it out for me. Then zip the whole lot up and I will take another look.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 10, 2012 Feb 10, 2012

Copy link to clipboard

Copied

Here's a follow-up on the issue: Peter was able to validate it with a project I sent him. I'm beginning to suspect the 9.0.2 update as introducing or at least aggravating the problem and will investigate that thoroughly when I come up for air.

Anyone who has cut-and-pasted Word documents or pages containing images should double-check their projects: you'll likely have some surprises.

Thank you, again, Peter, for your help and support. I really appreciate it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

Surprisingly and disappointedly, RH10 contains the same bug. Use cut-and-paste with caution.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 24, 2012 Jul 24, 2012

Copy link to clipboard

Copied

@Ross Yes I was disappointed to see that problem remained as I thought it was going to be fixed.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 04, 2015 Sep 04, 2015

Copy link to clipboard

Copied

Bump: Surprisingly and disappointingly, RH12.0.1.338 contains the same bug. Use cut-and-paste with caution.

...but then, it's only been 3-1/2 years and several expensive upgrades...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 30, 2015 Nov 30, 2015

Copy link to clipboard

Copied

Bump: Surprisingly and disappointingly, RH12.0.2.384 contains the same bug. Use cut-and-paste with caution.

...but then, it's only been 3-3/4 years and several expensive upgrades...

To their credit, RH now works fine with Word 2016 -- without charging for it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 22, 2016 Sep 22, 2016

Copy link to clipboard

Copied

A brief update: the original bug report has disappeared from my list, with no explanation. It has been re-reported (Bug 4192060) along with a related bug (Bug 4192057, whereby imported Word documents with cropped images lose the cropping, but keeps the cropped image dimensions, with disastrous results).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 17, 2017 Feb 17, 2017

Copy link to clipboard

Copied

I am thrilled to report that after five years since I reported it, this critical bug has--in RoboHelp 2017 (13.0.0.257)--still not been fixed.

Five frickin' years. And at least four expensive upgrades. Still not fixed.

Good grief. Five years!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2017 Feb 18, 2017

Copy link to clipboard

Copied

I feel your pain and am sorry that my efforts to get this fixed have failed so spectacularly. For what it is worth to you, I have just reminded Adobe of the problems this causes you.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

13.0.1.279 update...nah, still no resolution (though I noticed there was great exaltation about waxing the paint)...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation