Highlighted

PDF - How to exclude Books topics from TOC

Explorer ,
Feb 27, 2020

Copy link to clipboard

Copied

Hi Folks, 

I used to know how to do this but have forgotten....

When I create a PDF, I only want it to show H1 headings. Right now that works.

 

BUT, if I add a BOOK to the TOC, the topics within the book are added to the PDFs TOC. 

 

How do I EXCLUDE the topcis inside the books?

 

I suspect it's a settings in the pdf.css but can't see it.

 

Ivan

 

PS - using new version of RH with patches etc

Topics

New UI

Views

110

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PDF - How to exclude Books topics from TOC

Explorer ,
Feb 27, 2020

Copy link to clipboard

Copied

Hi Folks, 

I used to know how to do this but have forgotten....

When I create a PDF, I only want it to show H1 headings. Right now that works.

 

BUT, if I add a BOOK to the TOC, the topics within the book are added to the PDFs TOC. 

 

How do I EXCLUDE the topcis inside the books?

 

I suspect it's a settings in the pdf.css but can't see it.

 

Ivan

 

PS - using new version of RH with patches etc

Topics

New UI

Views

111

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 27, 2020

Copy link to clipboard

Copied

I'm not sure if for the book going to its Properties and selecting Hide In Output will do what you want.

 

If not then it might be easier to copy the TOC and then remove the books so that only topics are listed. You can then hide any of those as required. Select the copy TOC when you generate PDFs.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 27, 2020

Copy link to clipboard

Copied

sorry, i didnt express myself clearly. 

In the Alerts book, I have several topics, all H1. that's fine.

I also have two books in the toc, Alert Types and Alert Status. 

I DON'T want these to appear in the PDF TOC, 

I want the content to appear, but not listed in the TOC. 

toc1.png

This is the PDF.

You can see that it includes all the items listed in these books, a mix of H1 and H2.

How do I EXCLUDE these from the TOC?

toc2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 27, 2020

Copy link to clipboard

Copied

Re: if your topic has a heading style, that heading will be in the PDF TOC

 

I thought there was a way to EXCLUDE heading styles from the TOC? eg exclude H2, and H3.

 

Some setting in the pdf.css? Pretty sure it's there, just can't find it...

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 27, 2020

Copy link to clipboard

Copied

Without setting up a test, I don't think that can be done. The topic headings are what creates the PDF TOC so if your topic has a heading style, that heading will be in the PDF TOC.

 

If it is text that looks like a heading but isn't, it should still appear in the output as long as it is in the TOC used for generating. 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 27, 2020

Copy link to clipboard

Copied

In Classic, for Word/PDF, there's an option under Advanced to limit TOC depth. I can't see a corresponding setting in the preset for either PDF or Word.

 

I looked at the pdf.css in a fresh topic, and I wonder if the p.pdf-toc-level1 to 6 styles might affect the display.

 

Try setting p-pdf-toc-level3 to display: none and see what happens. (Your screenshot seems to indicate you want to exclude the third level of the toc, hence my suggestion. If it's a different level, change that level instead.)

 

Note I haven't tried this myself, but I feel the theory is sound.

 

image.png

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 28, 2020

Copy link to clipboard

Copied

Re: Try setting p-pdf-toc-level3 to display: none and see what happens. 

I've tried this but it doesn't work. will keep investigting.

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...