Highlighted

Popup Image

Community Beginner ,
Feb 06, 2017

Copy link to clipboard

Copied

Hi all,

I am trying to add popup to my images in my project. The first solution that came to my mind was insert a hyperlink on the images and linked it to a new topic which contains that picture. The problem with this solution is I do not want my clients see the topics that only include picture (which I use for "link to" in hyperlink properties)!!! I started to use conditional tags and applied it to all topics that I wanted to hide in my output. I set conditional build expression and save and generated the project. The issue is the topics that I wanted to hide from clients are hidden now but I lost popup functionality which I guess related to the tags that I used on topics for hiding them.

Is there any way that I fix this and go through it or you guys have any idea in your minds for building popup images? I have more than 50 topics and each topics have at least 5 images so in general I have to create large amount of topics with only pictures (for link to purpose) and then hide them from output. Not sure if this is a good and efficient way to doing it.

Could you please help me about it.

THANK YOU

Okay, but if you did it in the manner I showed in the video, where you just copied the image file name and pasted into the dialog, that won't work if say the image exists at root level and the actual topic where the link exists is inside a folder.

So in a simplified world, both the topic and the image are in the root folder. And the link to the image would be ImageFileName.PNG.

But if the topic is actually inside a folder named FolderOne, that link to the image would have to look like this: ../ImageFileName.PNG.

And if the topic was inside a subfolder of FolderOne, it would look like this: ../../ImageFileName.PNG.

My guess is that this is what is happening. You have a topic inside a folder and you need to amend the relative pathing so RoboHelp can properly find the image.

Cheers... Rick

Topics

HTML

Views

402

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Popup Image

Community Beginner ,
Feb 06, 2017

Copy link to clipboard

Copied

Hi all,

I am trying to add popup to my images in my project. The first solution that came to my mind was insert a hyperlink on the images and linked it to a new topic which contains that picture. The problem with this solution is I do not want my clients see the topics that only include picture (which I use for "link to" in hyperlink properties)!!! I started to use conditional tags and applied it to all topics that I wanted to hide in my output. I set conditional build expression and save and generated the project. The issue is the topics that I wanted to hide from clients are hidden now but I lost popup functionality which I guess related to the tags that I used on topics for hiding them.

Is there any way that I fix this and go through it or you guys have any idea in your minds for building popup images? I have more than 50 topics and each topics have at least 5 images so in general I have to create large amount of topics with only pictures (for link to purpose) and then hide them from output. Not sure if this is a good and efficient way to doing it.

Could you please help me about it.

THANK YOU

Okay, but if you did it in the manner I showed in the video, where you just copied the image file name and pasted into the dialog, that won't work if say the image exists at root level and the actual topic where the link exists is inside a folder.

So in a simplified world, both the topic and the image are in the root folder. And the link to the image would be ImageFileName.PNG.

But if the topic is actually inside a folder named FolderOne, that link to the image would have to look like this: ../ImageFileName.PNG.

And if the topic was inside a subfolder of FolderOne, it would look like this: ../../ImageFileName.PNG.

My guess is that this is what is happening. You have a topic inside a folder and you need to amend the relative pathing so RoboHelp can properly find the image.

Cheers... Rick

Topics

HTML

Views

403

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Feb 06, 2017

Copy link to clipboard

Copied

One possibility is to edit the properties of the topics with the images so they aren't found by the search engine. If you have all the popup topics in a single folder, it would be vastly easier to select them all and view their properties.

From the General tab in the properties dialog, enable the option to Exclude the topics from search.

tmp5.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 06, 2017

Copy link to clipboard

Copied

I did what you said but it's still showing the topics with only pictures in my output when I'm removing the tags.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 06, 2017

Copy link to clipboard

Copied

Sorry about that. Looks like I misunderstood what you were wanting to achieve.

I thought what you were saying was that you didn't want your end users to find those image topics when searching.

So there actually is another way to approach this. And rather than type it all out, it's likely a simpler process to show you in a video.

Soon I'll have a link to a video to show you another way.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 06, 2017

Copy link to clipboard

Copied

Thank you so much Rick. I'm looking forward for it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 06, 2017

Copy link to clipboard

Copied

Still in the upload process but at least there's a link. According to the page, there is still about five minutes to go.

Click here to view

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 07, 2017

Copy link to clipboard

Copied

Hey Rick,

Thank you so much for the video.I choose second option since it's not creating new topic and then getting worried how to hide that topic from clients

First let me mention that I am using small pics in my core topic and when user click on this picture it popups as a bigger one (basically showing pics bigger). For gaining this goal I simply added all pictures that I need for one of my core topics in Baggage Files and then inserted Hyperlink on small pics in my core topic and "link to" it to the .png pics in Baggage Files.

It seems it's not working, when I am clicking on the picture, below error pops up

Do you have any idea why it should be?

Thanks again for your help!

Capture.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 07, 2017

Copy link to clipboard

Copied

Hmmm, I've seen many instances where things fail in preview but work just fine when you output.

Have you tried generating the output and testing from there?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 07, 2017

Copy link to clipboard

Copied

after generating it's not even showing the small picture is clickable. Looks like there is no hyperlink assigned to it

Super Wired!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 07, 2017

Copy link to clipboard

Copied

Can you please shoot me a private email message?

RickStone1975 (at) gmail (dot) com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 07, 2017

Copy link to clipboard

Copied

I just did!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 07, 2017

Copy link to clipboard

Copied

Okay then.

When you added the image to Baggage, did you add it to the root level or was it inside a folder?

What is the relationship between the topic HTM file and the image? Are they both in the same folder or are they in different folders?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 07, 2017

Copy link to clipboard

Copied

I added them to the root level.

For instance, I have a HTM page inserting some images to it, then I linked these images to the ones that are in Baggage Files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 07, 2017

Copy link to clipboard

Copied

Okay, but if you did it in the manner I showed in the video, where you just copied the image file name and pasted into the dialog, that won't work if say the image exists at root level and the actual topic where the link exists is inside a folder.

So in a simplified world, both the topic and the image are in the root folder. And the link to the image would be ImageFileName.PNG.

But if the topic is actually inside a folder named FolderOne, that link to the image would have to look like this: ../ImageFileName.PNG.

And if the topic was inside a subfolder of FolderOne, it would look like this: ../../ImageFileName.PNG.

My guess is that this is what is happening. You have a topic inside a folder and you need to amend the relative pathing so RoboHelp can properly find the image.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 07, 2017

Copy link to clipboard

Copied

You are amazing Rick, that was the issue it could't find the image path so I added ../ and it solved.

Thank you so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Amebr LATEST
Adobe Community Professional ,
Feb 07, 2017

Copy link to clipboard

Copied

Also keep in mind the new thumbnails feature I read about in the RH2017 marketing material. This might achieve what you need, if you can upgrade.

(<blocks out time to try the trial version>)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...