Highlighted

Preview does not pay attention to conditional text definitions (RoboHelp HTML)

Community Beginner ,
Mar 14, 2016

Copy link to clipboard

Copied

In RBH 11.04.291, I am previewing a topic with two type of conditional text using the binoculars. I set the Conditional Build Tag Expression to one or the other, but regardless of my selection, the other conditional text remains.

testtopic.gif

BuildExp.gif

I've also tried using the Advanced build expression (instead of Not Condition_2, using Condition_1) with the same results.

BuildExp2.gif

I previewed in Chrome, IE, and Firefox. Also the same results.

Topics

HTML

Views

211

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Preview does not pay attention to conditional text definitions (RoboHelp HTML)

Community Beginner ,
Mar 14, 2016

Copy link to clipboard

Copied

In RBH 11.04.291, I am previewing a topic with two type of conditional text using the binoculars. I set the Conditional Build Tag Expression to one or the other, but regardless of my selection, the other conditional text remains.

testtopic.gif

BuildExp.gif

I've also tried using the Advanced build expression (instead of Not Condition_2, using Condition_1) with the same results.

BuildExp2.gif

I previewed in Chrome, IE, and Firefox. Also the same results.

Topics

HTML

Views

212

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Mar 14, 2016

Copy link to clipboard

Copied

Can you also share screen captures of what your expressions look like?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 14, 2016

Copy link to clipboard

Copied

The conditions are merely Condition_1 and a color and Condition_2 and another color.

ConditionalBT1.gifConditionalBT2.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 14, 2016

Copy link to clipboard

Copied

In the actual help topics, the conditions reflect the two modes of the application.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 14, 2016

Copy link to clipboard

Copied

You show the properties. Not the expressions.

Let's try again. When you are previewing your topic, click the Define button and show us what the dialog looks like where things aren't working.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 14, 2016

Copy link to clipboard

Copied

I thought that was odd. Sorry, I misunderstood you.

DefineBuildCondition1.gif

DefineBuildCondition2.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 14, 2016

Copy link to clipboard

Copied

Wow, this one is weird. From all I have seen it would appear that it *SHOULD* be working.

I think if I were in your shoes, I'd begin with a brief "sanity check". Create a totally new and fresh topic. Select a word or perhaps an entire sentence and apply only one tag. Then preview the topic and choose the expression that excludes the tag. If all is working as it should be, the tagged content should perform a disappearing act.

So give that a go and see if it works. If so, it means the entire conditional feature is working and you have something going on with that single topic.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 15, 2016

Copy link to clipboard

Copied

Good idea. I made a completely new project and tested it - worked fine. Something's off with my project. I'll poke around and see what I can find. Thanks Rick and Captiv8r.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...