Problem with multiple master pages for PDF output

Explorer ,
Apr 30, 2021 Apr 30, 2021

Copy link to clipboard

Copied

Hi y'all,

Using RoboHelp 2020.4.173 (up-to-date as of this posting).

I want to create a PDF output preset such that the cover page (first topic in the ToC's Front Matter) uses one master page (PDF_Cover_Page), and the rest of the book uses another (book).

Some strange behavior I'm seeing in the Master Pages tab in the desired Output Preset:

  • When I select a master page for the First Page field in either Chapters & Topics or Front Matter Topics, it does NOT signal that the preset has been changed (there's no * in the tab's title).
  • When I make a change and hit <ctrl><s> to save, then close the preset and reopen, my change is lost.

These could explain why, when I generate the PDF, the master pages are not being applied as I instruct, but I'm guessing. Here's the process I used to specify the master pages:

  • On Master Pages tab, I clicked Specify separate master pages, leaving Master page at the top blank.
  • In Chapters & Topics, I picked the book master page for the First Page field and enable the Apply to all pages option.
  • In Front Matter Topics, I chose PDF_Cover_Page master page for the first page and the book master page for even pages and odd pages.

When I generate the PDF, the PDF_Cover_Page master page is applied to the cover AND to the first topic in each section. I want the book master page applied to ALL other pages after the cover.

At the very top of the Master Pages tab is a drop-down for Master Page. Below that is a checkbox Specify separate master pages. I have the checkbox enabled, of course, but it doesn't seem to matter whether I have nothing in that first Master Page field or either of the two master pages I want to use. The PDF looks the same regardless.

What am I doing wrong?

TOPICS
Output presets

Views

286

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2021 May 02, 2021

Copy link to clipboard

Copied

You need to select a master page in the first field.

 

That applies to everything if you do not select the checkbox. With that checkbox selected, the master page above applies to everything except those sections where you select a different master page.

 

As soon as you select a master page in the first field, you will see the asterisk appear to show there are unsaved changes.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

Thanks for the replies! Unfortunately, no matter which master page I set in the first Master Page field, the result is the same: the cover has the correct master page applied, but the first topic of each chapter has the wrong master page. I made sure that First Page, Even Pages, and Odd Pages for Chapters & Topics have the desired master page (book), but my setting is seemingly ignored.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

The need to set a master page in the first field is in fact a bug that I have reported. Meantime follow my steps and you should get the PDF you want.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

I did test what I posted and it worked fine.

 

The cover page uses whichever master page is applied to it.

 

For topics it looks as if you have set things up correctly so I am not sure what is wrong here. Have you got the first topic attached to the section rather than as an item in the list of topics?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

Thanks for the reply. Yes, I have the cover within the Front Matter section, and the topic in a Section below that.

Here's a screenshot of my ToC. (The project will be a template project when I get it fixed, which is why there aren't many topics yet!)

I've tried creating the PDF where the section has a source file and also where the section does not. The result is the same. I also tried setting the book master page on the topic itself, trying to FORCE it. Doesn't matter. The PDF_Cover_Page master page is always being used for that First Topic's first page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

Please use the photo icon to insert images within the post. Seeing an image inline with the text makes it easier for anyone answering or viewing the post.

 

Can you share the project? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Did you ever resolve this issue? I think I am having the saving problem, where I can only get on master page to apply. I want a different master page for my odd pages but even though I have specified a separate master page for the odd pages, the pdf output only uses the even master page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Hi JoannaH,

I've not found a solution yet, but thank you Peter for mentioning the bug. I'll keep my fingers crossed that Adobe also fixes the problem with incorrect fonts being used in the PDF! Can't ship until they do...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

@joannah98656944 As stated in the thread, this is a bug that will be fixed in the next update.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

@KarenMinOR I am not seeing you mention fonts in this thread.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

I haven't yet. 🙂 I was searching for other threads mentioning the same problem, but no matter what I do (Embed used fonts vs not), RoboHelp substitutes fonts I never used or referenced anywhere in the project. I was going to search bug reports, but time is a monster I must wrestle into submission.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

You will need to identify that font and I believe there are sites with ways of doing that. Then using Find and Replace to search at code level through the project for that file name. If that doesn't work, start a new thread when you are ready.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 09, 2021 May 09, 2021

Copy link to clipboard

Copied

One thing you could try is make sure your windows font scaling is set to 100%. In other tools (not Robohelp, admittedly) I've seen the font mangled if the windows font scaling is set to anything besides 100%. Search in the settings app for 'Make everything bigger'.

 

While it might not affect RH, it's something easy to test.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the suggestion. I already had my Windows system set to display at 100%, and I didn't see any setting that affected only fonts aside from that. Still, my master pages are not being applied correctly (and the font issue remains as well, but I started a new thread for that: RoboHelp substitutes alien fonts during PDF genera... - Adobe Support Community - 12022339.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation