Problem with substring search with German umlauts RH2019.0.12 new UI HTML5 output

Engaged ,
Apr 30, 2020

Copy link to clipboard

Copied

Hi all,

I have a problem with the substring search in the HTML5 output. I am using RH2019.0.12 new UI, but the problem also occured with update 11. The search settings for my output are as follows:

Use topic description = true

Enable auto complete = true

Auto correct search query = false

Show definitions from glossary = true

Enable substring search = true

Add special characters for search = false

Generate XML sitemap = false

 

In my output, I have several topics containing the word "Primäreinzelkosten". If I search for "primär", I only get results containing exactly the word "primär", but not the "primäreinzelkosten". If I search for "primä", I get no results at all. If I search for "prim", I get all topics containing "primär", "primäreinzelkosten" and "primrose" or whatever. So the substring search seems to have a problem with the "ä". The substring search works as expected for example when searching for topics containing the word "Kostenblock". They are found whether I search for "koste", "kosten", or "kostenb".

 

My project language is set to German, my output language is also set to German. I tried outputs with the following Encoding settings: Default Encoding, Westeurope(ISO), UTF-16, UTF-8 without BOM. I also tried the outputs in different browsers (Chrome, Edge, Firefox). No matter what, I do not get any results when searching for "primä".

 

Does anyone know if there are further settings that I can check in order to make this work? Or is this a bug? In this case, I will create a bug regort.

 

Thanks and regards
Karin

Views

172

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 30, 2020

Copy link to clipboard

Copied

I'm thinking of the old CHM format that has issues if not used on a machine with the same language operating system.

 

Are you testing on a machine with German as the OS. I'm doubtful with this format but worth a try.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
Apr 30, 2020

Copy link to clipboard

Copied

Hi Peter, 

yes, my machine runs a German OS.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 30, 2020

Copy link to clipboard

Copied

Try techcomm@adobe.com first. 

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 30, 2020

Copy link to clipboard

Copied

I just tried putting both the words below in separate topics and generated with both a frameless and a responsive skin. Worked both times.

 

image.png

 

Try in a test project and see what you get.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
May 03, 2020

Copy link to clipboard

Copied

Hi Peter,

I just ran the test, same issue with a brand new project and default skin Azure Blue:

 

 Umlaut1.pngUmlaut2.pngUmlaut3.png

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 04, 2020

Copy link to clipboard

Copied

Karin

 

I have sent you a project where it seems to be working. Test that as a first step.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 04, 2020

Copy link to clipboard

Copied

The email bounced so sending it via WeTransfer. Meantime this is what I get with your settings.

 

image.png

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
May 04, 2020

Copy link to clipboard

Copied

Thanks Peter, file came through now. Could you please run a test with your project searching for "primä"? "Prim" has been working for me as well. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
May 04, 2020

Copy link to clipboard

Copied

Peter, it is working with your sample. However, there is a difference in the settings. You are using Project Lanuage EN (UK), I am using German as project language and output language. With these settings, it is not working. I just ran another test with project language German and output language Default. This seems to be working. The problem with this setting is, that the RH-texts like "inlcude all words in search" etc. are not displayed in German but in English. 

I will wait for feedback from the techcomm guys and then possibly raise a bug. 

Thank you very much for your support!

 

Kind regards

Karin

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 04, 2020

Copy link to clipboard

Copied

So a character that is used in the German language breaks the search when on a German language system. 🙂

 

Let us know what Adobe come back with.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 04, 2020

Copy link to clipboard

Copied

With primä I get two results, which is correct.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 04, 2020

Copy link to clipboard

Copied

Try generating my project set to German. I just attempted that and it is hanging at Starting Generation. Before changing the language it was fine.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
May 04, 2020

Copy link to clipboard

Copied

Yes, this is another problem. You have to create a synonyms file for German to make the output work. Just write "a - a" or something in it.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 04, 2020

Copy link to clipboard

Copied

Searching on primär with language to German, I get only one result like you. Unless Adobe come back with something, I suggest you add my project to any bug report as it is a simple example of the issue.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Karin Albrecht AUTHOR LATEST
Engaged ,
May 06, 2020

Copy link to clipboard

Copied

I have created a bug for this now, including the test project showing the issue. 

https://tracker.adobe.com/#/view/RH-7221

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more