Highlighted

Project does not open after updating RoboHelp 2019 to current updated version

New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

I just updated RoboHelp 2019 to the latest version (14.0.8) and now I cannot open any of the projects I was working on with a version of RoboHelp 2019 I installed in February 2019 and I had just been working on prior to doing the update.

When I open the project it shows a message that it is "updating files", and then it shows "reading files" but it never finishes.  I've waited half an hour and it doesn't do anything.  I clic dismiss and the project is not opened.

The PC is running Windows 10 Pro

Hi,

The issue is that there are some hyperlinks in project which are starting with slash (/). RH is failing to parse them while opening the project. Please remove these slash from href and project will start opening in RH. You can continue working on your project then.

For your project shared with us, I have fixed this and shared the project with you over email.

Hopefully you will be unblocked for now. We will fix this issue in Update 9.

Thanks and Regards,
Surbhi Maheshwari

Topics

New UI

Views

484

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Project does not open after updating RoboHelp 2019 to current updated version

New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

I just updated RoboHelp 2019 to the latest version (14.0.8) and now I cannot open any of the projects I was working on with a version of RoboHelp 2019 I installed in February 2019 and I had just been working on prior to doing the update.

When I open the project it shows a message that it is "updating files", and then it shows "reading files" but it never finishes.  I've waited half an hour and it doesn't do anything.  I clic dismiss and the project is not opened.

The PC is running Windows 10 Pro

Hi,

The issue is that there are some hyperlinks in project which are starting with slash (/). RH is failing to parse them while opening the project. Please remove these slash from href and project will start opening in RH. You can continue working on your project then.

For your project shared with us, I have fixed this and shared the project with you over email.

Hopefully you will be unblocked for now. We will fix this issue in Update 9.

Thanks and Regards,
Surbhi Maheshwari

Topics

New UI

Views

485

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 25, 2019

Copy link to clipboard

Copied

If you open 2019 and click the RoboHelp Reimagined sample project, does that open OK?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

I am able to open the Reimagined sample project

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 25, 2019

Copy link to clipboard

Copied

Create a copy of one project. In File Explorer delete the rh folder, then

open the project. Does that work?

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

I appreciate your help.  I tried removing the rh folder, opened the project, and it still does not work.  It stays reading files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 25, 2019

Copy link to clipboard

Copied

It's early days with Update 8 but I'm not having this problem and not seeing anyone else with it yet. Thus we have to figure out what else to look at in your environment.

Any source control involved?

Where are the projects stored?

Do you have any backups that you could try? (Create copies of the backups before you try)

Post back if none of that helps.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

I have exactly the same problem. Each upgraded project is not loading. There is the loading panle forever.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

Same questions as above.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

Any source control involved?

no source control

Where are the projects stored?

local drive

Do you have any backups that you could try? (Create copies of the backups before you try)

They are fresh converted from rh clasic

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

Which version of Classic?

If less than 2019 Classic, try opening in 2019 Classic first, then upgrading that.

Do keep a copy of your old version.

If that doesn't work can you share one the old version projects? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

Hi, sended you a link to new and old project.

Thanks for your help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jul 26, 2019

Copy link to clipboard

Copied

I have not received any email. Please check and send again.

Thanks and Regards,
Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

OK to send it on to Adobe?

Please send direct the log files requested.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

It is OK

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jul 26, 2019

Copy link to clipboard

Copied

Hi,

You said that "I was working on with a version of RoboHelp 2019 I installed in February 2019 and I had just been working on prior to doing the update." Which version of RH 2019 update you were using then?

Also can you please share the log file which is kept at ..\AppData\Local\Temp\RHTMP" folder. If you are upgrading form RH classic versions the log file name will have upgrade in it. A log file is created whenever RH is launched. Please try to open/upgrade the project and close RH once you are done. Please share the log file with us at sumahesh@adobe.com

Thanks for your help.

Regards,

Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

Hello,

 

here is the log file.

 

Thank you for your help.

 

 

Thomas

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jul 26, 2019

Copy link to clipboard

Copied

Hi,

The issue is that there are some hyperlinks in project which are starting with slash (/). RH is failing to parse them while opening the project. Please remove these slash from href and project will start opening in RH. You can continue working on your project then.

For your project shared with us, I have fixed this and shared the project with you over email.

Hopefully you will be unblocked for now. We will fix this issue in Update 9.

Thanks and Regards,
Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

I changed the hyperlinks in project which were starting with slash "/" and that solved the problem.

Thank you for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 31, 2019

Copy link to clipboard

Copied

Sorry for silly question, but how do I find the href file? or where in the new 2019 file structure do I locate these hyperlinks that begin with a slash / ?

My project stopped opening after Update 8.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 31, 2019

Copy link to clipboard

Copied

It is not a single file, it is the "a hrefs"in your topics so it could be a pretty big job. Adobe are working on a fix that will be issued before the next update but I don't know when. It is a priority item.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 31, 2019

Copy link to clipboard

Copied

Thanks for the insight Peter.

This is extremely disappointing, as I had issues with an RH Classic 2019 project failing to publish and TCS Support encouraged me to upgrade the project to the RH Full 2019 and make sure all updates were installed. Now I have tons of those references in the project to change and a publish deadline of Thursday at 10 am that I wonder if I can meet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 31, 2019

Copy link to clipboard

Copied

10am in what time zone?

I will send you a private message in the forum in a moment.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 31, 2019

Copy link to clipboard

Copied

See another PM.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 03, 2019

Copy link to clipboard

Copied

See the forum Announcements. There is an updated version of Update 8 available there to fix this issue.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 30, 2019

Copy link to clipboard

Copied

I updated my RoboHelp 2019 to version 10 and I am still having this issue. Is there an easy way to find all my hrefs? My project is over 4000 topics so manually going to be very difficult.

 

I can still successfully open smaller projects in RoboHelp 2019, but my primary project gets stuck in the Opening stage.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 31, 2019

Copy link to clipboard

Copied

@adrazkow

 

It's difficult to know what to suggest as in theory this is a fixed issue. In your case there must be something more to it.

 

Can you share the project? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct. I will take a look to see if I can spot anything.

 

If you cannot share it, then there are two options.

  1. Try Adobe support. Either look up the phone number where you are or email techcomm@adobe.com.
  2. Try rebuilding the project. See http://www.grainge.org/pages/authoring/opening/opening_projects.htm  That will only work if it is something other than the forward slash issue.

www.grainge.org

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...