Highlighted

"rhcl.exe has stopped working” (CMD) / "Failed to generate Printed Documentation" (Rh GUI)

Explorer ,
Feb 08, 2018

Copy link to clipboard

Copied

Hello Rh Community (Hi Peter and Rick )

Any of you come across this "acute" issue (unable to determine the exact timing on what was done prior to having this issue) when attempting to generate Printed Documentation from RoboHelp?

Thank You,

~PM

OS: Win 7

Adobe Rh Version: Rh11

History: Rh11 on a separate machine (Win 7). I did have Rh 2017 installed (not anymore) on the same Rh11 PC just to upgrade one project for testing. Local Build (No source control involve in this case.

Issue: When running the documentation build script from the Command Line (CMD) and Rh attempts to build the two certain documents. The first time Rh compiler hits the “PayablesAdministratorGuide”, a message pad (popup) indicating that the “rhcl.exe has stopped working” (see Pic 1 below). This error reoccurs when it comes to PayablesImportExportGuide document. Note: The remaining printed documentation (e.g. User/Admin guides) for all projects generate with no issue.

pic1.jpg

If I use Rh11 GUI (Opening Rh project and generating printed docs), I can not generate ANY Printed documentation, 20 seconds through the generation process I get an error "Failed to generate Printed Documentation (XXXXX)." (See Pic 2).

pic2.jpg

Notes:

  • This happens for any project. This even happens when I print the EmployeeCare2.
  • I am able to generate CHMs with no issue.

Attempts to resolve issue: I also Re-installed Rh11, as well as its Update. No change.

In a Nutshell: Using the command prompt works but crashes on two documents, and using Rh GUI, nothing works.

Topics

Documentation

Views

870

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

"rhcl.exe has stopped working” (CMD) / "Failed to generate Printed Documentation" (Rh GUI)

Explorer ,
Feb 08, 2018

Copy link to clipboard

Copied

Hello Rh Community (Hi Peter and Rick )

Any of you come across this "acute" issue (unable to determine the exact timing on what was done prior to having this issue) when attempting to generate Printed Documentation from RoboHelp?

Thank You,

~PM

OS: Win 7

Adobe Rh Version: Rh11

History: Rh11 on a separate machine (Win 7). I did have Rh 2017 installed (not anymore) on the same Rh11 PC just to upgrade one project for testing. Local Build (No source control involve in this case.

Issue: When running the documentation build script from the Command Line (CMD) and Rh attempts to build the two certain documents. The first time Rh compiler hits the “PayablesAdministratorGuide”, a message pad (popup) indicating that the “rhcl.exe has stopped working” (see Pic 1 below). This error reoccurs when it comes to PayablesImportExportGuide document. Note: The remaining printed documentation (e.g. User/Admin guides) for all projects generate with no issue.

pic1.jpg

If I use Rh11 GUI (Opening Rh project and generating printed docs), I can not generate ANY Printed documentation, 20 seconds through the generation process I get an error "Failed to generate Printed Documentation (XXXXX)." (See Pic 2).

pic2.jpg

Notes:

  • This happens for any project. This even happens when I print the EmployeeCare2.
  • I am able to generate CHMs with no issue.

Attempts to resolve issue: I also Re-installed Rh11, as well as its Update. No change.

In a Nutshell: Using the command prompt works but crashes on two documents, and using Rh GUI, nothing works.

Topics

Documentation

Views

871

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 08, 2018

Copy link to clipboard

Copied

Reviewed the CMD window print out:

ERROR! The source file X:\doc_4x\html\apps\projects\ap\output\McKesson\adminguid

es\PayablesAdministratorsGuide does not exist. Can't create a PDF

My Path:

X:\doc_4x\html\apps\projects\ap\output\McKesson\adminguides

Note: I have FULL Permissions to this drive/directory. I do see

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 08, 2018

Copy link to clipboard

Copied

Have you installed all RH updates or only 1? I think there should be 4.

Can you generate to a local folder such as c:\output and see if that works?

Is your project on the network, as well as generating to a network? If so, can you try copying the project to your c drive and also generating locally?

It's also possible that uninstalling RH2017 broke some reference to Word that RH11 needs, but Peter or Rick might be able to comment on that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 09, 2018

Copy link to clipboard

Copied

From offline emails Paul has sent, I believe the situation is that this build works on a build server but not on his local machine where X is one of the local drives.

Provided the updating was done from within RoboHelp rather than downloading the updates, it will have applied all the updates. The highest number update includes the earlier updates. It wasn't always that way but it is now. Possibly it was 11 where that started.

Now to the error message:-

ERROR! The source file X:\doc_4x\html\apps\projects\ap\output\McKesson\adminguid

es\PayablesAdministratorsGuide does not exist. Can't create a PDF

There's a big clue there. That has been seen over the years, albeit not so much recently. It's one of those problems that no one has really got to the bottom of but there is an easy solution. Don't laugh when I say don't generate a PDF. What I mean is generate a DOC file only. That usually works and from there you can generate a PDF.

When you select PDF in the SSL configuration, behind the scenes RoboHelp creates a Word document. You see it if you also tick the DOC check box but not otherwise. Either way, for some users selecting PDF only or with a DOC as well breaks the process.

Select just PDF and let us know if that works.

It could be worth checking what differs between the server and the local machine.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2018

Copy link to clipboard

Copied

Hi Peter,

I tried just checking the PDF checkbox = Same error ("Failed to generate Printed Documentation (XXXXX)."

I tried checking BOTH checkboxes (PDF and Word) = Same error

The error "ERROR! The source file X:\doc_4x\html\apps\projects\ap\output\McKesson\adminguid

es\PayablesAdministratorsGuide does not exist. Can't create a PDF" is received when generating from my build script and I believe it's a separate task (Word convert to PDF). Either way, through Rh GUI I can't generate anything.

~PM

PS - Updating was applied from Rh (selecting Updates).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 09, 2018

Copy link to clipboard

Copied

No, just check the Word doc box. Only create a DOC, not a PDF.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2018

Copy link to clipboard

Copied

Hi, all my SSLs use that setting "Generate Word Doc", the box checked. Same error.

Output View:

Starting to build Printed Documentation...

Printed Documentation processor 11.0.4.291

Building X:\doc_4x\html\apps\output\ap\mckesson\adminguides\PayablesAdministratorsGuide.doc ...

Preparing to create Printed Documentation...

Clearing output folder...

Preparing files for Print Document...

Copying files...

Warning: "X:\doc_4x\html\apps\projects\ap\!Language!\en_US\RoboHHRE.lng" cannot be copied to" X:\doc_4x\html\apps\output\ap\mckesson\adminguides\!doc_tmp_folder_0\RoboHHRE.lng". reason: source does not exist.

Updating files...

Finished preparing in 28 seconds.

Cleaning up temporary files...

Internal error encountered,  Failed to generate Printed Documentation.

* NOTE: The Warning makes no difference if I have those directories are in place, the warning goes away but I get the same Internal error message (I copied them in from the updated CT project, and it made no difference). Those directories are created when Rh2017 is installed and yet, this project (AP) was NOT upgraded.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 09, 2018

Copy link to clipboard

Copied

If you copy from an updated project, the file will likely be a mismatch.

Copy it from a backup that was not upgraded.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2018

Copy link to clipboard

Copied

I did a file compare (using Beyond Compare utility) on my ssl and the build server ssl and found no difference. While I was on the SSL inspection duty I noticed something odd... I ran my CMD script again and noticed that it created two ssl a "RHCL_McKessonPayables Import Export Guide.ssl" and a "RHCL_McKessonPayables Admin Guide.ssl" for the two printed documents that I problems generating. Note, the rest of my printed documents are created. Again, this is NOT using Rh GUI.

BTW - the "AP" project was Not upgraded.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 09, 2018

Copy link to clipboard

Copied

Can we back up a bit as I am getting very confused as to what is and is not working on the server and the local machine.

I thought the server was working just fine using the command line and generating all printed documents. Correct?

I thought the local RH11 machine was not producing printed documentation even though you reinstalled RoboHelp 11 and it has a compatible version of Word. Correct?

I had assumed you were using the GUI on the local machine now you are saying otherwise. Please try using the RoboHelp 11 GUI and not the command line. Does that work or fail?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2018

Copy link to clipboard

Copied

I thought the server was working just fine using the command line and generating all printed documents. Correct? YES

I thought the local RH11 machine was not producing printed documentation even though you reinstalled RoboHelp 11 and it has a compatible version of Word. Correct? YES (But, I am able to run the command line, generate all EXCEPT for two documents - this is where the RHCL error occurs)

I had assumed you were using the GUI on the local machine now you are saying otherwise. Please try using the RoboHelp 11 GUI and not the command line. Does that work or fail? If I use Rh GUI (for any projects), I get the "Internal error encountered,  Failed to generate Printed Documentation."

* I also checked for the "mso-bookmark" style in my css file (nothing there) per "Cannot create printed documentation in RoboHelp"

PS - I LMAO when I read your comment in an older post (I'm still laughing), "Were you an undertaker? Burying files that deep is almost award worthy. "

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 09, 2018

Copy link to clipboard

Copied

On the server we would conclude it is a project issue as anything other than the two rogue projects works fine.

The local machine also at first seems to be the same as the result using the command line is the same, everything except the same two documents works. However when you use the GUI, all projects fail to generate printed documentation.

There are thus two issues here. One is that you have a problem with two projects (when generating printed documentation) as they never generate and the other is that you have a problem with the RoboHelp GUI on the local machine.

Re the projects, can you share one with me? See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

Re the GUI, remind me of the operating system on the local machine.

Does the GUI work on the server?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2018

Copy link to clipboard

Copied

Thanks Peter! Email/transfer file per your instructions has been sent.

I will check out the server Rh11 GUI and let you know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 09, 2018

Copy link to clipboard

Copied

OK. Have downloaded project. It's evening here and about to go out. Will look in the morning.

It will be interesting to see what the server does via the GUI.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2018

Copy link to clipboard

Copied

No issue with Rh11 GUI on our Build Server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 10, 2018

Copy link to clipboard

Copied

I have managed to get PayablesAdminGuide printing!

The first issue I hit with the project you sent was that trying to open any of the print layouts crashed RoboHelp. I then created a new layout using as many of the settings as I could see before the crash occurred.

On the first pass, left the final page of the print dialog to map to the CSS. Document created.

On the second pass, I mapped the only Word template that was in the project as sent. I think that was when I got the Internal Error message you have seen.

I grabbed a StyleMapping.dot file from another project and that generated OK.

I suggest you create new print layouts, not duplicates, and grab a StyleMapping.dot file from a new RoboHelp 11 project. Then try generating again via the GUI.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 10, 2018

Copy link to clipboard

Copied

Thank you Peter for taking the time for your analysis. Is it possible that when I updated the another project (CT) on Rh2017, it made changes to the flexi_rh7.css (e.g. created new Styles for a  branding project), using Rh2017 and that Rh11 did not like it?  For example, all my projects use a shared "Common" folder which has the branding and template file (as well as other files) associated. The Word Template (flexi_RH.dot) is still version Word 2013.

I'm not at work now but if you still have your test environment open, could you try copying the html code from my flexi_rh7.css into a Rh 11 css file, giving it a same name (flexi_rh7.css) and try printing to see if that file is the culprit?

*EDIT* I was able to remote in from work and tried your suggestions (create new print layouts, not duplicates, and grab a StyleMapping.dot file from a new RoboHelp 11 project), I was unsuccessful. I believe this maybe my Application (Rh11).

Thank you,

~PM

BTW - this may be off topic, but what does it mean when files selected in a Printed Documentation Section Layout are grayed out?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 10, 2018

Copy link to clipboard

Copied

*(Rh Application - Internal Print Error -  RESOLUTION)*

Hi Peter,

I was able to get my Rh11 app to work, no longer internal print error; I can generate my projects now.

Recall, I loaded Rh2017 on my Win7 PC (which has Rh11 on it) to test upgrading Rh11 project (CT project), and then I uninstalled Rh2017 (TCS), and installed Rh2017 on my new Win10 PC. Well, when I installed the TCS 2017 on the Win7 PC, I also installed "Adobe Acrobat DC".

I thought about reverse engineering if you will, and reinstalled Acrobat DC on my Win7 PC. I opened Adobe DC and the program notified me that Adobe Addin in Word was NOT enable, do you want to enabled? I selected "Yes". NOTE: Lat week, I checked Word 2013 to see that Adobe Add-in was enabled (referring to another post on this topic and saw that Adobe Acrobat Add-in), must of been a Word bug...

*PROBLEM GENERATING McKesson ADMIN GUIDE (ONLY)*

As for the " “rhcl.exe has stopped working”, I am still receiving this on my Payables project (larger project) Rh 11 freezes when it gets to the section (ref. Output View log) "Saving 'PayablesAdministratorsGuide.doc". It doesn't reaching the ending steps:

Updating Table of Contents...

Saving 'PayablesUsersGuide.doc'...

Completed building Printed Documentation...

Preparing output directory...

Cleaning up temporary files...

Finished Printed Documentation generation in 8 minutes 46 seconds.

Building Printed Documentation complete.

NOTES:

  • This happens generating the "McKessonPayables Admin Guide" SSL.
  • This does NOT happen generating the "McKessonPayables Users Guide" SSL.
  • Flexi Payables Admin/Users Guide are fine.

Thank you again for your assistance.

~PM

BTW - this may be off topic, but what does it mean when files selected in a Printed Documentation Section Layout are grayed out?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 11, 2018

Copy link to clipboard

Copied

I have seen a CSS prevent generation of printed documentation but I don't think that is the issue here. As above, each of your layouts crashed RoboHelp.and the first document I created with the layout I added used the CSS in the topics. Also when I mapped to your template, that too failed. I believe a lot of the trouble was down to something in your project. That said, you have tried the same thing and it is failing. I'll come back to that.

You are now referring to TCS and I suspect that when you uninstalled that, it left parts of the full Acrobat behind. I thought you only had RoboHelp rather than the full TCS.You have now added Adobe DC to your Windows 7 machine. Is that the version that came with RoboHelp 11?

Quite honestly with all that has been done to your local machine I would no longer trust the installation. I will send you the project where my layout is working. Let's see if it works on your machine. I'm inclined to say you should try something like RevoUninstaller to remove all the TCS or standalone RoboHelp versions you have, then install just RoboHelp and use it's build in Acrobat. Only do that with your IT department's approval.

Greyed out topics will be ones you have included in the layout but have also excluded with your build expression.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 12, 2018

Copy link to clipboard

Copied

Hi Peter,

I downloaded the project you sent, ran the "PayableAdminPG", and no error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 12, 2018

Copy link to clipboard

Copied

Are the settings much the same as your one that I cannot open and you cannot get a result from?

Also now try to create a new layout for the other one you cannot generate. Does that work from a new layout. Do not use the Duplicate option.

Try various things like that and let us know what does / does not work.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 12, 2018

Copy link to clipboard

Copied

Hi Peter,

I narrowed it down (using your Printed Document 'PayableAdminPG' as I try this, try this attempt) when selecting my word.dot (flexi_RHT_.dot) is when I get the error: “rhcl.exe has stopped working”​. What does not make sense, again, this error only occurs on the following printed documentation (SSLs): 'McKessonPayables Admin Guide' and 'McKessonPayables Import Export Guide'. The remaining printed documentation SSLs in this project (AP) work fine. I did a Beyond Compare and nothing stuck out to show a difference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 12, 2018

Copy link to clipboard

Copied

Does it work if you use the Style Mapping template I used in my layout.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 12, 2018

Copy link to clipboard

Copied

I set the 'McKessonPayables Admin Guide' like your settings = Stylesheet radio-button selected, Apply CSS to all Topics: (None) - Use the Project's CSS Styles. Rh still crashed (“rhcl.exe has stopped working”. ).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 12, 2018

Copy link to clipboard

Copied

See what you can do via the GUI.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 12, 2018

Copy link to clipboard

Copied

I am working via RH11 GUI. I am not running the Command Line. I tried the same for the 'McKessonPayables Import Export Guide' SSL, same crash/error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 12, 2018

Copy link to clipboard

Copied

I had thought that message was seen when you generated via the command line, hence confusion. Late here now. Will look at it again in the morning.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 13, 2018

Copy link to clipboard

Copied

In Post 17 you referred to a larger project so let's clarify what is working where. Is the project I have the larger or the smaller? I believe it is the smaller as the XPJ is fap32 and you are referring to the error being in ap. However, what I have has layouts with names that tally with where you say you are having issues.

So what works for you in FAP? If you prefer to use different names for the two projects that's fine but make it clear which is the one I have and always refer to the project name when reporting what you are seeing. I need to know if what you are saying relates to the project I have.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 16, 2018

Copy link to clipboard

Copied

RESOLUTION for the "rhcl.exe has stopped working"

ISSUE: The problem occurred (onset not known) in ONE project and ONLY for certain layouts/Printed Documentations (SSLs).

RH Output View: The error occurred after (ref. Rh Output View): Updating list paragraphs... Saving 'PayablesAdministratorsGuide.doc...

rh_error.jpg

NOTE: All other SSLs in this project and in other projects, had no issues as indicated above.

RESOLUTION for the two outputs:

  • Editing the Generate Word DOC selection.
    • Using the drop-down list and changing the selection from .doc to “.docx

rh_resolution.jpg

IMPORTANT: This issue was specific to two outputs out of many and in a specific environment. Though, I was able to replicate this specific situation in a Win10, Rh2017 environment, the “.DOC” works (except for two output ssls) in the same Win7 environment and in other environments (Win10).

Credit: Kudos goes out to Peter for his knowledge, patience, persistence, and humor. ~PMR

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 17, 2018

Copy link to clipboard

Copied

This has been on of the most puzzling problems that I have ever dealt with on the forums from the point of view of the logic of the solution and what worked where during the troubleshooting. Nothing including the solution makes sense.

PROBLEM

Paul has a legacy RoboHelp 11 project but during the troubleshooting a copy was upgraded to RoboHelp 2017 and the problem persisted.  In short, for Paul, five of the seven print outputs work just fine while two will crash RoboHelp after they start generating. What could be the cause?

THE LAYOUTS

At first that seemed quite likely as on my machine they all crashed on my machine as soon as I opened any one of  them. Rebutting that is the fact that five of them do work for Paul.

I then created a new layout  not using Paul's template and that generated the layouts Paul was having trouble with. That seemed like an early fix except that when I sent that project back to Paul, the working layout crashed RoboHelp on his machine.

Next I found that if I removed the macro that was in Paul's template, I could use that template. Again though, when Paul did the same, it crashed on generation.

There was nothing we could do with the layouts that would work on Paul's machines.

THE COMPUTERS

Paul's two machines are very different but if they were the underlying cause, either all print outputs would work or all would fail. Remember, the issue is only with two out of seven outputs.

THE ENVIRONMENT

Same argument. All outputs would fail if that were the problem.

THE TOPICS

Could it be something in a topic that was only in the failing outputs? Ruled out by the fact that the same topics were working just fine using my new outputs on my machine. Again, sending that project back to Paul would result in a fail.

WORD VERSION

All outputs would fail if that were the problem.

FINAL SOLUTION

Paul found that if he changed the document type from DOC to DOCX the two failing outputs worked. So could it be something in the topics that required DOCX. No, as DOC worked just fine on my machine.

CAUSE

Unless anyone has a better idea, I believe the elves were at play.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...