Highlighted

Re-installed 2017 today and now I cant use RoboScreen capture : any ideas?

Explorer ,
Nov 28, 2019

Copy link to clipboard

Copied

Hi RoboHelp lovers (Solution to this issue is shown in CAPS, below) 

My techy colleagues have set up my Robohelp to push to GIT, in order that they can manage changes and versions in parallel with the software they are developing. 

 

Everything seems to be working OK but this morning (while working at home with no techies available) when I tried to open up a project in the new location they had created, the project tried to open up in 2019, which I didn't want to happen. (I'd installed an evaluation copy of 2019 some time ago and decided to stick with 2017 - thats another story for another day). As the project seemed insistent on opening in 2019 and 2017 did not even come up as an option on the "open using other programs" dialog the fix seemed to be uninstalling 2019.

Anyhow, having uninstalled 2019 and re installed 2017 (which subsequently seemed to be necessary) I found I was unable to use RoboScreen Capture. When I tried to do my first "Screen grab" of the day, a pop up message informed me there was an "Error in launching RoboScreenCapture".

Is there a simple reason why this has happened? Do I need to re-install RoboScreenCapture and if so, how do I go about it?

 

NOTE: THE SOLUTION TO THIS PROBLEM IS INSTALLING UPDATES AFTER RE-INSTALLING ROBOHELP. AS SOON AS I DID THIS AND RE-STARTED ROBOHELP, ROBO SCREEN CAPTURE WORKED AS USUAL.

 

The techies created a new directory for the compiled help and a new working directory for my project. These are both within the "My RoboHelp Projects" folder so I'm guessing that's not the cause of the problem. 

As usual, any advice / guidance would be muchly appreciated. 

Regards

 

JV

 

 

 
Adobe Community Professional
Correct answer by Jeff_Coatsworth | Adobe Community Professional

Found it! In my copy of RH11, it's in the Registry under \HKEY_CURRENT_USER\Software\Adobe\RoboHelp\11.00\Tools\RoboScreenCapture - there's a CommandLine entry that has the path to the .exe.

Topics

Classic, HTML5 layout

Views

277

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Re-installed 2017 today and now I cant use RoboScreen capture : any ideas?

Explorer ,
Nov 28, 2019

Copy link to clipboard

Copied

Hi RoboHelp lovers (Solution to this issue is shown in CAPS, below) 

My techy colleagues have set up my Robohelp to push to GIT, in order that they can manage changes and versions in parallel with the software they are developing. 

 

Everything seems to be working OK but this morning (while working at home with no techies available) when I tried to open up a project in the new location they had created, the project tried to open up in 2019, which I didn't want to happen. (I'd installed an evaluation copy of 2019 some time ago and decided to stick with 2017 - thats another story for another day). As the project seemed insistent on opening in 2019 and 2017 did not even come up as an option on the "open using other programs" dialog the fix seemed to be uninstalling 2019.

Anyhow, having uninstalled 2019 and re installed 2017 (which subsequently seemed to be necessary) I found I was unable to use RoboScreen Capture. When I tried to do my first "Screen grab" of the day, a pop up message informed me there was an "Error in launching RoboScreenCapture".

Is there a simple reason why this has happened? Do I need to re-install RoboScreenCapture and if so, how do I go about it?

 

NOTE: THE SOLUTION TO THIS PROBLEM IS INSTALLING UPDATES AFTER RE-INSTALLING ROBOHELP. AS SOON AS I DID THIS AND RE-STARTED ROBOHELP, ROBO SCREEN CAPTURE WORKED AS USUAL.

 

The techies created a new directory for the compiled help and a new working directory for my project. These are both within the "My RoboHelp Projects" folder so I'm guessing that's not the cause of the problem. 

As usual, any advice / guidance would be muchly appreciated. 

Regards

 

JV

 

 

 
Adobe Community Professional
Correct answer by Jeff_Coatsworth | Adobe Community Professional

Found it! In my copy of RH11, it's in the Registry under \HKEY_CURRENT_USER\Software\Adobe\RoboHelp\11.00\Tools\RoboScreenCapture - there's a CommandLine entry that has the path to the .exe.

Topics

Classic, HTML5 layout

Views

278

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Nov 28, 2019

Copy link to clipboard

Copied

PS > I just spotted the answer to this question on another thread. Apologies.

 

IS there a method for deleteing threads from this forum?  Last time I looked I couldnt work it out. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 28, 2019

Copy link to clipboard

Copied

Not yet (not be moderators anyway) - can you post the link to the other thread that gave you the answer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 28, 2019

Copy link to clipboard

Copied

https://community.adobe.com/t5/robohelp/roboscreen-capture-doesn-t-work-anymore/td-p/9516865

 

Well there's the link. But I've found its not very helpful. It shows where the shortcut to the RoboScreenCapture.exe file is, and Ive found it but I still cant make it open up in Robohelp. If I open RoboScreen Capture separately It prompts me to browse to the location of the folder where  I want to save the screen capture. I havent managed to successfully save a RoboScreenCapture file obtained this way to the right location and open it up in Robohelp so far. Its early days  but it Strikes me its going to its a bit of a drag even if I can work out how to do it. 

So Can I set things up so RoboScreen Capture can be invoked directly from Robohelp and I dont have to faff about each time I want to do a screen grab? 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 28, 2019

Copy link to clipboard

Copied

I've never actually used it, but I suspect that RH2017 is looking for the location of the capture .exe in the wrong spot - there's probably a registry key that's got the location still pointing to the RH2019 version location. You might want to hunt around to see if there's any mention of the capture .exe in there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Nov 28, 2019

Copy link to clipboard

Copied

Thanks Jeff. Thats a bit above my paygrade (Im a writer, not a fighter 🙂  )

 

Ill see if one of the techies can work out how to do it, next time Im in the office.. . Might be time to find another screen grab prog if not. .. .

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...