Relative path names needed for output and favicon fields in presets.

Community Beginner ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

This apparently has been a long-standing issue.   I ee a prior post on the subject here in relation to RH 2019 but I see things have not changed since then.

 

This is a defect in the product and I think a fix should be a high priority.

 

The problem:  We have multiple authors working on th same RH project.   I use MacOS, the others are Windows.   In the output presents you currently must enter a full pathname for the favicon and the output directory fields.   If you try to enter a relative path name (such as "../output/pub1/") you actually get an error message that this is not allowed.

 

On the Mac full pathnames start with "/" and on Windows it starts with a drive letter like "C:/".   So Mac Users and Windows users cannot use the same presets.

 

More than that, if the output directory is in a user directory, the path name will include the user directory root element.   So presets cannot be shared for that reason as well.   The solution offered for this is to use a non user-specific directory, such as "/tmp/RoboHelp/something/" but this can cause problems as well with regard to system management.

 

I have a hard time imagining what is driving this requirement from a software engineering perspective.  I do not believe there is one   It is a totaly arbitrary restriction.  Can someone please submit a trouble-ticket within Adobe to put this on the agenda to be fixed?

Views

47

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

I don't fully understand what you're saying, as I haven't used a Mac since System 7, and even then, not for work.

 

However, you can report issues and reqeuest new features here: https://tracker.adobe.com/

 

You can also contact Adobe support here: https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Amber, to clarify this please look at the following XML element from one of my preset files:

 

 <outputPath>C:/Robohelp/UserDocs_7_4_2_Frameless/7_4_2_Reactive/</outputPath>

 

 

The value of the tag is valid on Windows, but not on MacOS.   So when I check out the project from the git repository and try to run the preset it fails.   The problem is excacerbated if it includes a username as one of the path elements. 

 

As Peter pointed out below, this is not a problem with the favicon because in spite of what it display in the preset dialog box, it stores it as a relative path name, like this:

 

  <favicon>
    <name>favicon</name>
    <path>../../contents/assets/favicon.ico</path>
  </favicon>

 

That is what the outputPath element should be doing.

 

So I will submit a ticket regarding the output but not the favicon complaint.  Thanks for your response. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Whilst favicon does display a full path I have found that if I move the project to another machine with different drive letters, it still works. Also I get sent projects where somehow the link gets changed in the project.

 

I understood from Adobe that a project in 2020 should be able to work on a Mac and then on a Windows machine. You are saying that Mac machines write full paths in a different way, which would contradict that. 

 

I will flag this with an Adobe contact and come back to you. If it is an issue, then the advantage of this new UI is that the underlying program coding enables fixes to be implemented much faster than with Classic versions.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

My contact has responded that this does need fixing. Please file a bug report using the link that @Amebr has given you.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

I suggest including a link to this thread when you report this.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation